Bug 120176 - Menu icons won't theme
Summary: Menu icons won't theme
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-kickstart
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 119991
TreeView+ depends on / blocked
 
Reported: 2004-04-06 16:41 UTC by Jeff Moe (jebba)
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-04-08 19:14:35 UTC


Attachments (Terms of Use)

Description Jeff Moe (jebba) 2004-04-06 16:41:15 UTC
Icons in the menu do not change when the theme is changed. This
is true even if the theme has an icon of the correct name.

The cause of this is that in
/usr/share/applications/system-config-kickstart.desktop
the Icon= line has the absolute path to the icon instead of just the
icon name.

Icon=/usr/share/system-config-bind/system-config-kickstart.png
When it should have:
Icon=system-config-kickstart.png

The icon should be put in the hicolor theme, per freedesktop.org.
/usr/share/icons/hicolor/48x48/apps/

Comment 1 Brent Fox 2004-04-08 19:14:35 UTC
Should be fixed in system-config-kickstart-2.5.10-2 in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.