Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1202316 - NFS-Ganesha : Starting NFS-Ganesha independent of platforms
Summary: NFS-Ganesha : Starting NFS-Ganesha independent of platforms
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: nfs
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Meghana
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1188184
TreeView+ depends on / blocked
 
Reported: 2015-03-16 11:40 UTC by Meghana
Modified: 2015-09-01 02:54 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:29:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Meghana 2015-03-16 11:40:40 UTC
Description of problem:

Start NFS-Ganesha in a way that is independent of the platform it is running.

Comment 1 Niels de Vos 2015-03-17 12:12:59 UTC
GlusterD gained the ability to start the nfs-ganesha service. However, the 'service' command is hardcoded for this and that might not be suitable/clean enough for all distributions.

The idea is to use the 'service' command on RHEL6, 'systemctl' on RHEL7 and Fedora, and whatever other commands other distributions use.

Comment 2 Anand Avati 2015-03-25 09:48:46 UTC
REVIEW: http://review.gluster.org/9991 (NFS-Ganesha: Start and stop NFS-Ganesha service in a platform independent way.) posted (#1) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 3 Anand Avati 2015-03-25 10:18:02 UTC
REVIEW: http://review.gluster.org/9991 (NFS-Ganesha: Start and stop NFS-Ganesha service in a platform independent way.) posted (#2) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 4 Anand Avati 2015-03-27 09:10:00 UTC
REVIEW: http://review.gluster.org/9991 (NFS-Ganesha: Start and stop NFS-Ganesha service in a platform independent way) posted (#3) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 5 Anand Avati 2015-03-27 10:14:43 UTC
REVIEW: http://review.gluster.org/9991 (NFS-Ganesha: Start and stop NFS-Ganesha service in a platform independent way) posted (#4) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 6 Anand Avati 2015-03-30 04:34:19 UTC
REVIEW: http://review.gluster.org/9991 (NFS-Ganesha: Start and stop NFS-Ganesha service in a platform independent way) posted (#5) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 7 Anand Avati 2015-03-31 14:08:10 UTC
COMMIT: http://review.gluster.org/9991 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit e6f5ace08ad0a068cb49d3ca1274a27aa031992b
Author: Meghana Madhusudhan <mmadhusu@redhat.com>
Date:   Wed Mar 25 15:11:57 2015 +0530

    NFS-Ganesha: Start and stop NFS-Ganesha service in a platform independent way
    
    Check for what binaries are installed at run time,
    pick appropriate command and perform the required
    action. The service managers supported are systemctl,service
    and invoke-rc.d.
    
    Change-Id: I8deef2bfe5a09da5b055fe6176a58452a882fa76
    BUG: 1202316
    Signed-off-by: Meghana Madhusudhan <mmadhusu@redhat.com>
    Reviewed-on: http://review.gluster.org/9991
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: soumya k <skoduri@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 8 Niels de Vos 2015-05-14 17:29:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:35:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:38:15 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 11 Niels de Vos 2015-05-14 17:46:25 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.