Bug 1188184 - NFS-Ganesha new features support for 3.7
Summary: NFS-Ganesha new features support for 3.7
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: ganesha-nfs
Version: 3.7.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact:
URL:
Whiteboard:
: 847619 847626 (view as bug list)
Depends On: 1185654 1200262 1200265 1200359 1200440 1202316 1202637 1202893 1210712 1217711 1217793 1218963 1241871 1242148 1242358 1252410 1256616 1257007 1257014 1317482 1317902
Blocks: 854182 glusterfs-3.7.0
TreeView+ depends on / blocked
 
Reported: 2015-02-02 09:48 UTC by Meghana
Modified: 2016-03-15 13:15 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-15 13:39:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-02-02 10:17:01 UTC
REVIEW: http://review.gluster.org/9521 (mgmt/glusterd: Refactor brick graph generation in volgen) posted (#4) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 2 Anand Avati 2015-02-02 13:12:20 UTC
REVIEW: http://review.gluster.org/9538 (CLI : GLobal option for NFS-Ganesha) posted (#1) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 3 Anand Avati 2015-02-05 06:43:56 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#1) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 4 Anand Avati 2015-02-10 07:48:34 UTC
REVIEW: http://review.gluster.org/9621 (NFS-Ganesha: Place holder for scripts and config files) posted (#1) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 5 Anand Avati 2015-02-18 07:12:30 UTC
REVIEW: http://review.gluster.org/9621 (NFS-Ganesha: Place holder for scripts and config files) posted (#2) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 6 Anand Avati 2015-02-19 12:34:17 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#2) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 7 Anand Avati 2015-02-20 06:03:49 UTC
REVIEW: http://review.gluster.org/9621 (NFS-Ganesha: Install scripts and config files.) posted (#3) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 8 Anand Avati 2015-02-23 07:08:01 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#3) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 9 Anand Avati 2015-02-24 07:36:04 UTC
REVIEW: http://review.gluster.org/9535 (Upcall: New xlator to store various states and send cbk events.) posted (#7) for review on master by soumya k (skoduri@redhat.com)

Comment 10 Anand Avati 2015-02-24 07:36:08 UTC
REVIEW: http://review.gluster.org/9534 (rpcsvc: New rpc routines defined to send callback requests.) posted (#9) for review on master by soumya k (skoduri@redhat.com)

Comment 11 Anand Avati 2015-02-24 07:36:11 UTC
REVIEW: http://review.gluster.org/9536 (gfapi: APIs to store and process upcall notifications received) posted (#5) for review on master by soumya k (skoduri@redhat.com)

Comment 12 Anand Avati 2015-02-25 16:00:02 UTC
REVIEW: http://review.gluster.org/9535 (Upcall: New xlator to store various states and send cbk events.) posted (#8) for review on master by soumya k (skoduri@redhat.com)

Comment 13 Anand Avati 2015-02-25 16:00:05 UTC
REVIEW: http://review.gluster.org/9534 (rpcsvc: New rpc routines defined to send callback requests.) posted (#10) for review on master by soumya k (skoduri@redhat.com)

Comment 14 Anand Avati 2015-02-25 16:00:08 UTC
REVIEW: http://review.gluster.org/9536 (gfapi: APIs to store and process upcall notifications received) posted (#6) for review on master by soumya k (skoduri@redhat.com)

Comment 15 Anand Avati 2015-02-26 10:48:28 UTC
REVIEW: http://review.gluster.org/9621 (NFS-Ganesha: Install scripts and config files.) posted (#4) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 16 Anand Avati 2015-02-26 18:12:42 UTC
REVIEW: http://review.gluster.org/9621 (NFS-Ganesha: Install scripts and config files.) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 17 Anand Avati 2015-02-26 18:29:06 UTC
REVIEW: http://review.gluster.org/9535 (Upcall: New xlator to store various states and send cbk events.) posted (#9) for review on master by soumya k (skoduri@redhat.com)

Comment 18 Anand Avati 2015-02-26 18:29:13 UTC
REVIEW: http://review.gluster.org/9534 (rpcsvc: New rpc routines defined to send callback requests) posted (#11) for review on master by soumya k (skoduri@redhat.com)

Comment 19 Anand Avati 2015-02-26 18:29:16 UTC
REVIEW: http://review.gluster.org/9536 (gfapi: APIs to store and process upcall notifications received) posted (#7) for review on master by soumya k (skoduri@redhat.com)

Comment 20 Anand Avati 2015-02-27 07:18:23 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#4) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 21 Anand Avati 2015-02-27 07:44:19 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#5) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 22 Niels de Vos 2015-02-27 09:57:11 UTC
*** Bug 847626 has been marked as a duplicate of this bug. ***

Comment 23 Soumya Koduri 2015-02-27 10:07:01 UTC
*** Bug 847619 has been marked as a duplicate of this bug. ***

Comment 24 Anand Avati 2015-03-02 04:46:58 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#6) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 25 Anand Avati 2015-03-02 05:30:47 UTC
COMMIT: http://review.gluster.org/9534 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 56488efe3c858da7f8a0b66d30a2eface2f6f35e
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Thu Jan 29 12:56:35 2015 +0530

    rpcsvc: New rpc routines defined to send callback requests
    
    Change-Id: I7f95682faada16308314bfbf84298b02d1198efa
    BUG: 1188184
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/9534
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 26 Anand Avati 2015-03-02 05:47:33 UTC
REVIEW: http://review.gluster.org/9538 (CLI : GLobal option for NFS-Ganesha) posted (#2) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 27 Anand Avati 2015-03-02 09:33:43 UTC
REVIEW: http://review.gluster.org/9621 (NFS-Ganesha: Install scripts and config files.) posted (#6) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 28 Anand Avati 2015-03-02 09:35:37 UTC
REVIEW: http://review.gluster.org/9621 (NFS-Ganesha: Install scripts and config files.) posted (#7) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 29 Anand Avati 2015-03-02 11:06:41 UTC
REVIEW: http://review.gluster.org/9535 (Upcall: New xlator to store various states and send cbk events.) posted (#10) for review on master by soumya k (skoduri@redhat.com)

Comment 30 Anand Avati 2015-03-02 11:06:45 UTC
REVIEW: http://review.gluster.org/9536 (gfapi: APIs to store and process upcall notifications received) posted (#8) for review on master by soumya k (skoduri@redhat.com)

Comment 31 Anand Avati 2015-03-03 09:48:15 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#7) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 32 Anand Avati 2015-03-03 11:02:56 UTC
REVIEW: http://review.gluster.org/9538 (CLI : GLobal option for NFS-Ganesha) posted (#3) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 33 Anand Avati 2015-03-05 09:03:03 UTC
REVIEW: http://review.gluster.org/9538 (CLI : GLobal option for NFS-Ganesha) posted (#4) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 34 Anand Avati 2015-03-05 09:03:07 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#8) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 35 Anand Avati 2015-03-06 10:34:29 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#9) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 36 Anand Avati 2015-03-06 10:57:10 UTC
REVIEW: http://review.gluster.org/9538 (CLI : GLobal option for NFS-Ganesha) posted (#5) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 37 Anand Avati 2015-03-06 10:57:15 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#10) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 38 Anand Avati 2015-03-06 13:49:16 UTC
REVIEW: http://review.gluster.org/9621 (NFS-Ganesha: Install scripts and config files.) posted (#8) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 39 Anand Avati 2015-03-06 14:50:47 UTC
REVIEW: http://review.gluster.org/9621 (NFS-Ganesha: Install scripts and config files.) posted (#9) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 40 Anand Avati 2015-03-09 08:18:23 UTC
REVIEW: http://review.gluster.org/9621 (NFS-Ganesha: Install scripts and config files.) posted (#10) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 41 Anand Avati 2015-03-09 08:40:57 UTC
REVIEW: http://review.gluster.org/9621 (NFS-Ganesha: Install scripts and config files.) posted (#11) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 42 Anand Avati 2015-03-09 09:49:16 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#11) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 43 Anand Avati 2015-03-11 12:07:45 UTC
REVIEW: http://review.gluster.org/9538 (CLI : GLobal option for NFS-Ganesha) posted (#6) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 44 Anand Avati 2015-03-11 12:07:49 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#12) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 45 Anand Avati 2015-03-11 12:45:31 UTC
REVIEW: http://review.gluster.org/9538 (CLI : GLobal option for NFS-Ganesha) posted (#7) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 46 Anand Avati 2015-03-11 12:45:41 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#13) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 47 Anand Avati 2015-03-12 05:02:34 UTC
REVIEW: http://review.gluster.org/9621 (NFS-Ganesha: Install scripts and config files.) posted (#12) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 48 Anand Avati 2015-03-12 05:42:16 UTC
REVIEW: http://review.gluster.org/9538 (CLI : GLobal option for NFS-Ganesha) posted (#8) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 49 Anand Avati 2015-03-12 05:42:20 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#14) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 50 Anand Avati 2015-03-16 15:41:39 UTC
COMMIT: http://review.gluster.org/9621 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 586b8ef9067404b35daa1a11475f18a337e785e2
Author: Kaleb Keithley <kkeithle@redhat.com>
Date:   Mon Feb 9 17:08:54 2015 +0530

    NFS-Ganesha: Install scripts and config files.
    
    Scripts related to NFS-Ganesha is placed
    in extras/ganesha/scripts. Config files
    are placed in extras/ganesha/config.
    Files are copied to appropriate locations.
    
    Change-Id: I60647d4be64d713820213b2737c995b0d6c67d42
    BUG: 1188184
    Signed-off-by: Meghana Madhusudhan <mmadhusu@redhat.com>

Comment 51 Anand Avati 2015-03-17 05:17:51 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#15) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 52 Anand Avati 2015-03-17 06:52:42 UTC
REVIEW: http://review.gluster.org/9538 (CLI : GLobal option for NFS-Ganesha) posted (#9) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 53 Anand Avati 2015-03-17 13:28:46 UTC
REVIEW: http://review.gluster.org/9912 (NFS-Ganesha: Install scripts and config files.) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 54 Anand Avati 2015-03-17 14:43:02 UTC
REVIEW: http://review.gluster.org/9912 (NFS-Ganesha: Install scripts, config files, and resource agent scripts) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 55 Anand Avati 2015-03-17 16:20:37 UTC
REVIEW: http://review.gluster.org/9912 (NFS-Ganesha: Install scripts, config files, and resource agent scripts) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 56 Anand Avati 2015-03-17 20:39:49 UTC
COMMIT: http://review.gluster.org/9912 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit d81182cf69a4f188f304fcce6d651ffd56b67aac
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Tue Mar 17 09:27:05 2015 -0400

    NFS-Ganesha: Install scripts, config files, and resource agent scripts
    
    Resubmitting after a gerrit bug bungled the merge of
    http://review.gluster.org/9621 (was it really a gerrit bug?)
    
    Scripts related to NFS-Ganesha are in extras/ganesha/scripts.
    Config files are in extras/ganesha/config.
    Resource Agent files are in extras/ganesha/ocf
    
    Files are copied to appropriate locations.
    
    Change-Id: I137169f4d653ee2b7d6df14d41e2babd0ae8d10c
    BUG: 1188184
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/9912
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 57 Anand Avati 2015-03-18 06:06:39 UTC
REVIEW: http://review.gluster.org/9585 (NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.) posted (#16) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 58 Anand Avati 2015-03-18 08:53:37 UTC
COMMIT: http://review.gluster.org/9585 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 368dfd695928e8fc40988b8f2de86c3b469172d2
Author: Meghana Madhusudhan <mmadhusu@redhat.com>
Date:   Wed Mar 18 11:33:50 2015 +0530

    NFS-Ganesha: Volume set option for managing NFS-Ganesha exports.
    
    A dummy translator has been introduced as a place
    holder for functions related to managing NFS-Ganesha
    exports. A volume set option is introduced to
    manage volume level exports.
    
    gluster vol set <volname> ganesha.enable ON/OFF
    
    1. gluster volume set <volname> ganesha.enable ON
    
    It creates the export config file with a unique export ID.
    Sends a DBus signal to export this volume dynamically.
    
    2. gluster vol set <volname> ganesha.enable OFF
    
    Unexports the specific volume. Deletes the specfic
    config file related to the volume.
    
    This change also removes the handling of the older
    keys "nfs-ganesha.enable" and "nfs-ganesha.host"
    
    Change-Id: I8d4a0b542326a6a0c8e4711600b106274d666587
    BUG: 1188184
    Signed-off-by: Meghana Madhusudhan <mmadhusu@redhat.com>
    Reviewed-on: http://review.gluster.org/9585
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 59 Anand Avati 2015-03-18 09:08:27 UTC
REVIEW: http://review.gluster.org/9538 (CLI : GLobal option for NFS-Ganesha) posted (#10) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 60 Anand Avati 2015-03-18 11:33:17 UTC
COMMIT: http://review.gluster.org/9538 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 38ccaaf9d1a93c4fc6d733ee3bd5c73e5457bdab
Author: Meghana Madhusudhan <mmadhusu@redhat.com>
Date:   Mon Feb 2 16:23:22 2015 +0530

    CLI : GLobal option for NFS-Ganesha
    
    A new global CLI option has been introduced for NFS-Ganesha.
    gluster features.ganesha enable/disable.
    This option is persistent and shall be inherited
    by new volumes created after this option is set.
    
    gluster features.ganesha enable
    
    It carries out the following functions:
    1. Disables gluster-nfs across the cluster
    2. Starts NFS-Ganesha server on a subset of nodes and exports  '/'.
    3. Creates the HA cluster for NFS-Ganesha.
    4. Writes the option into the global config file.
    
    gluster features.ganesha disable
    
    1. Stops NFS-Ganesha server.
    2. Tears down the HA cluster for NFS-Ganesha
    
    With this change the older volume set
    options with keys "nfs-ganesha.host"
    and "nfs-ganesha.enable" will no longer
    be supported. This commit has only has the
    CLI related changes. Another patch will
    be submitted to support this feature entirely.
    
    Change-Id: Ie4b66a16c23b33b795738654b9a68f8e2c34efe3
    BUG: 1188184
    Signed-off-by: Meghana Madhusudhan <mmadhusu@redhat.com>
    Reviewed-on: http://review.gluster.org/9538
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 61 Anand Avati 2015-03-23 20:27:26 UTC
REVIEW: http://review.gluster.org/9974 (ganesha-ha: ganesha-ha.sh --status (one-liner) implementation) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 62 Anand Avati 2015-03-24 20:13:52 UTC
COMMIT: http://review.gluster.org/9974 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit fb81ee019655f8ce56f1610568526e51c49e8a11
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Mon Mar 23 16:23:00 2015 -0400

    ganesha-ha: ganesha-ha.sh --status (one-liner) implementation
    
    Change-Id: I17b7f6864dd8c1f89500a4bb89f1c249835e68da
    BUG: 1188184
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/9974
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 63 Anand Avati 2015-04-08 12:07:36 UTC
REVIEW: http://review.gluster.org/10163 (ganesha-ha: more robust pid file handling) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 64 Anand Avati 2015-04-08 17:51:43 UTC
COMMIT: http://review.gluster.org/10163 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 6ae434eeb3bfe421f34e624182d46ee11f57c736
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Apr 8 08:03:58 2015 -0400

    ganesha-ha: more robust pid file handling
    
    fix bug with reading pid file to determine if ganesha.nfsd is running
    
    Change-Id: I4050a119e2be93578045a221b67f616e152546d9
    BUG: 1188184
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/10163
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 65 Anand Avati 2015-04-14 12:29:10 UTC
REVIEW: http://review.gluster.org/10234 (common-ha: delete-node implementation) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 66 Anand Avati 2015-04-20 18:29:31 UTC
REVIEW: http://review.gluster.org/10234 (common-ha: delete-node implementation) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 67 Anand Avati 2015-04-21 14:49:19 UTC
REVIEW: http://review.gluster.org/10234 (common-ha: delete-node implementation) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)


Note You need to log in before you can comment on or make changes to this bug.