Bug 1202602 - logrotate configuration uses 'su' option, which doesn't exit on log rotate in CentOS 6. [NEEDINFO]
Summary: logrotate configuration uses 'su' option, which doesn't exit on log rotate in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: zabbix22
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Volker Fröhlich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-17 02:05 UTC by Dominik L. Borkowski
Modified: 2015-10-02 23:30 UTC (History)
8 users (show)

Fixed In Version: zabbix22-2.2.10-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-24 23:11:29 UTC
myles: needinfo?


Attachments (Terms of Use)

Description Dominik L. Borkowski 2015-03-17 02:05:48 UTC
Description of problem:
/etc/logrotate.d/zabbix-* files try to use option 'su', which is not available in logrotate-3.7.8-17.el6.x86_64


Version-Release number of selected component (if applicable):
zabbix22-agent-2.2.1-5.el6.x86_64
zabbix22-proxy-2.2.1-5.el6.noarch

How reproducible:
Always


Steps to Reproduce:
1) install zabbix22-{agentd,proxy}
2) run logrotate
# /usr/sbin/logrotate /etc/logrotate.conf

Actual results:
error: zabbix-agent:7 unknown option 'su' -- ignoring line
error: zabbix-agent:7 unexpected text
error: zabbix-proxy:7 unknown option 'su' -- ignoring line
error: zabbix-proxy:7 unexpected text


Expected results:

No errors or warnings.



Additional info:

Comment 1 Orion Poplawski 2015-05-11 16:00:05 UTC
Same here

Comment 2 Jeremias Keihsler 2015-08-11 06:08:45 UTC
Same with 
logrotate        3.7.8-23.el6.x86_64
zabbix20         2.0.13-2.el6.x86_64
zabbix20-agent   2.0.13-2.el6.x86_64

Comment 3 Fedora Update System 2015-08-11 22:57:21 UTC
zabbix20-2.0.15-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/zabbix20-2.0.15-1.el6

Comment 4 Volker Fröhlich 2015-08-11 22:59:16 UTC
*** Bug 1251728 has been marked as a duplicate of this bug. ***

Comment 5 rstory 2015-08-14 20:38:09 UTC
When will there be a fix for zabbix22?

Comment 6 Myles 2015-08-24 07:26:30 UTC
(In reply to Fedora Update System from comment #3)
> zabbix20-2.0.15-1.el6 has been submitted as an update for Fedora EPEL 6.
> https://admin.fedoraproject.org/updates/zabbix20-2.0.15-1.el6

Is this a fix for the zabbix-agent issue on this page? How long do these things normally take to resolve? The daily cron error is driving me nuts!

What happens next? Does the fix get included in an update when released or will I have to ask my host to apply a patch? Hope you can advise.

Comment 7 Orion Poplawski 2015-08-28 16:14:35 UTC
Note the fix is to just edit /etc/logrotate.d/zabbix-agent and remove the "su" line.

Comment 8 Myles 2015-08-28 16:27:21 UTC
(In reply to Orion Poplawski from comment #7)
> Note the fix is to just edit /etc/logrotate.d/zabbix-agent and remove the
> "su" line.

Great. I'll give that a go. Thanks! :)

Comment 9 Fedora Update System 2015-09-15 15:06:26 UTC
zabbix22-2.2.10-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8091

Comment 10 Fedora Update System 2015-09-16 00:20:13 UTC
zabbix22-2.2.10-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update zabbix22'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8091

Comment 11 Fedora Update System 2015-09-24 23:11:22 UTC
zabbix20-2.0.15-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-10-02 23:22:53 UTC
zabbix22-2.2.10-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.