Bug 1202773 - on Acer E 17 (E5-771G-36SL) touchpad tap to click isn't functional
Summary: on Acer E 17 (E5-771G-36SL) touchpad tap to click isn't functional
Keywords:
Status: CLOSED DUPLICATE of bug 1206961
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1201715 1215286 1220941 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-17 12:28 UTC by Rolle
Modified: 2019-09-23 19:16 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-16 23:08:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Rolle 2015-03-17 12:28:07 UTC
Description of problem:
"Tap to click" isn't functional. I enabled tap to click in system settings but it doesn't work. All other functions are fully functional. Two finger scroll work. Then I click the touchpad really (mechanical click) then the click is working. But not the tap click doesn't work.

Version-Release number of selected component (if applicable):
- Fedora 22 alpha Live CD,
- Acer E 17 (E5-771G-36SL),
- libinput 0.11.0,
- xorg-x11-drv-libinput.i686 0:0.7.0-4.fc22,
- kernel 4.0.0-0.rc1.git0.1.fc22.i686

How reproducible:
every time

Steps to Reproduce:
1. boot Fedora 22 alpha LiveCD
2. enable tap to click in system settings
3. try tap click on touchpad on Acer E 17 (E5-771G-36SL)

Actual results:
no click happened

Expected results:
click should happen

Additional info:

Comment 1 Peter Hutterer 2015-03-19 09:54:13 UTC
what's the output of xinput list-props "... your device"?

Comment 2 Rolle 2015-03-22 23:47:32 UTC
xinput --list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ SYN1B7C:01 06CB:2970 UNKNOWN            	id=12	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Video Bus                               	id=8	[slave  keyboard (3)]
    ↳ Power Button                            	id=9	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=10	[slave  keyboard (3)]
    ↳ HD WebCam                               	id=11	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]
    ↳ Acer WMI hotkeys                        	id=14	[slave  keyboard (3)]
[liveuser@localhost ~]$ man xinput
[liveuser@localhost ~]$ xinput list-props 12
Device 'SYN1B7C:01 06CB:2970 UNKNOWN':
	Device Enabled (139):	1
	Coordinate Transformation Matrix (141):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (271):	0
	libinput Accel Speed (272):	0.000000
	libinput Natural Scrolling Enabled (273):	0
	libinput Send Events Modes Available (257):	1, 1
	libinput Send Events Mode Enabled (258):	0, 0
	libinput Left Handed Enabled (274):	0
	libinput Scroll Methods Available (275):	1, 1, 0
	libinput Scroll Method Enabled (276):	1, 0, 0
	Device Node (259):	"/dev/input/event7"
	Device Product ID (260):	1739, 10608
[liveuser@localhost ~]$ lsusb
Bus 003 Device 002: ID 8087:8000 Intel Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 04f2:b469 Chicony Electronics Co., Ltd 
Bus 001 Device 003: ID 0bda:b005 Realtek Semiconductor Corp. 
Bus 001 Device 002: ID 13fe:3800 Kingston Technology Company Inc. Rage XT Flash Drive
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[liveuser@localhost ~]$ lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
05:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

Comment 3 Peter Hutterer 2015-03-24 05:38:03 UTC
(In reply to Rolle from comment #2)
> [liveuser@localhost ~]$ xinput list-props 12
> Device 'SYN1B7C:01 06CB:2970 UNKNOWN':
> 	Device Enabled (139):	1
> 	Coordinate Transformation Matrix (141):	1.000000, 0.000000, 0.000000,
> 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
> 	libinput Tapping Enabled (271):	0

 ^^ this should be 1, not 0. does it change at all when you toggle the settings?

Comment 4 Rolle 2015-03-24 22:26:37 UTC
I set the prop with: xinput set-prop 12 271 1
And now the tap works.

So now I learned about the xinput mechanism and I played a while with this. I see some other things aren't working out of the box, which I thought first are working correct.

Natural Scrolling isn't also with gnome settings switchable. It is default off and only with "xinput" it is possible to enable.

Both settings (tap, natural scrolling) are with xinput un/settable and the gnome settings don't recognize the changed state.

The two finger scroll is also not settable with gnome settings. Different here is it is default turned on. And I don't see a prop in the props list which could be responsible for the two finger scroll.

Comment 5 Peter Hutterer 2015-03-25 05:12:41 UTC
libinput Scroll Method Enabled is the property for scrolling, the order of values is 2-finger, edge, button-scrolling.

What surprises me more is that apparently libinput exposes edge scrolling on this laptop when it looks like the touchpad is a clickpad (no separate physical buttons). That's bug #1201532 btw, might want to update to the latest kernel.


do any of the UI toggles change the output of:
gsettings list-recursively  | grep touchpad

Comment 6 Rolle 2015-03-25 08:38:32 UTC
1. I booted again the LiveCD
2. opened Gnome settings
3. toggled 2 times "tap", toggled 2 times "two finger scroll", toggled 2 times "natural scrolling"
4. opened terminal and typed:

[liveuser@localhost ~]$ xinput --list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ SYN1B7C:01 06CB:2970 UNKNOWN            	id=12	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Video Bus                               	id=8	[slave  keyboard (3)]
    ↳ Power Button                            	id=9	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=10	[slave  keyboard (3)]
    ↳ HD WebCam                               	id=11	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]
    ↳ Acer WMI hotkeys                        	id=14	[slave  keyboard (3)]

[liveuser@localhost ~]$ xinput list-props
Usage: xinput list-props <device> [<device> ...]

[liveuser@localhost ~]$ xinput list-props 12
Device 'SYN1B7C:01 06CB:2970 UNKNOWN':
	Device Enabled (139):	1
	Coordinate Transformation Matrix (141):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (271):	0
	libinput Accel Speed (272):	0.000000
	libinput Natural Scrolling Enabled (273):	0
	libinput Send Events Modes Available (257):	1, 1
	libinput Send Events Mode Enabled (258):	0, 0
	libinput Left Handed Enabled (274):	0
	libinput Scroll Methods Available (275):	1, 1, 0
	libinput Scroll Method Enabled (276):	1, 0, 0
	Device Node (259):	"/dev/input/event10"
	Device Product ID (260):	1739, 10608

[liveuser@localhost ~]$ xinput set-prop 12 276 0, 1, 0

[liveuser@localhost ~]$ xinput set-prop 12 271 1

[liveuser@localhost ~]$ gsettings list-recursively |grep touchpad
org.gnome.desktop.peripherals.touchpad natural-scroll false
org.gnome.desktop.peripherals.touchpad scroll-method 'two-finger-scrolling'
org.gnome.desktop.peripherals.touchpad speed 0.0
org.gnome.desktop.peripherals.touchpad left-handed 'mouse'
org.gnome.desktop.peripherals.touchpad send-events 'enabled'
org.gnome.desktop.peripherals.touchpad tap-to-click false
org.gnome.desktop.peripherals.touchpad natural-scroll false
org.gnome.desktop.peripherals.touchpad scroll-method 'two-finger-scrolling'
org.gnome.desktop.peripherals.touchpad speed 0.0
org.gnome.desktop.peripherals.touchpad left-handed 'mouse'
org.gnome.desktop.peripherals.touchpad send-events 'enabled'
org.gnome.desktop.peripherals.touchpad tap-to-click false

[liveuser@localhost ~]$

Comment 7 Rolle 2015-03-25 08:43:15 UTC
Yes the touchpad is only one field without marked zones for scrolling or something else. And no separate hardware buttons for mouse or so exists. The whole touchpad area itself can physically clicked down and this acts as a hardware button. This hardware click is functional all the time.

Comment 8 Peter Hutterer 2015-03-25 22:04:12 UTC
(In reply to Rolle from comment #6)
> 1. I booted again the LiveCD
> 2. opened Gnome settings
> 3. toggled 2 times "tap", toggled 2 times "two finger scroll", toggled 2
> times "natural scrolling"

toggled 2 times as in disabled->enabled->disabled or enabled->disabled->enabled?
the output looks like it ended up disabled, that's what the property and the gsettings reflect. if you ended up with enabled, this seems to be a gnome bug.

Comment 9 Rolle 2015-03-27 10:30:29 UTC
(In reply to Peter Hutterer from comment #8)
> > toggled 2 times "tap", toggled 2 times "two finger scroll", toggled 2
> > times "natural scrolling"
> 
> toggled 2 times as in disabled->enabled->disabled or
> enabled->disabled->enabled?
> the output looks like it ended up disabled, that's what the property and the
> gsettings reflect. if you ended up with enabled, this seems to be a gnome
> bug.

- tap: default is: disabled in UI -> toggled 2 times (enabled, disabled)
       (changing UI settings has no functional effect)
- two finger scroll: default is: endabled in UI -> toggled 2 times (disabled, enabled)
       (changing UI settings has no functional effect)
- natural scrolling: default is: disabled in UI -> toggled 2 times (enabled, disabled)
       (changing UI settings has no functional effect)

Comment 10 Rolle 2015-03-27 10:33:43 UTC
I tried with Ubuntu 14.10 LiveCD: tapping works out of the box and all touchpad settings are changeable in UI and has the correct effect (enable/disable).

ubuntu@ubuntu:~$ xinput --list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ SYN1B7C:01 06CB:2970 UNKNOWN            	id=12	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Video Bus                               	id=8	[slave  keyboard (3)]
    ↳ Power Button                            	id=9	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=10	[slave  keyboard (3)]
    ↳ HD WebCam                               	id=11	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]
    ↳ Acer WMI hotkeys                        	id=14	[slave  keyboard (3)]
ubuntu@ubuntu:~$ xinput list-props 12
Device 'SYN1B7C:01 06CB:2970 UNKNOWN':
	Device Enabled (139):	1
	Coordinate Transformation Matrix (141):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	Device Accel Profile (265):	1
	Device Accel Constant Deceleration (266):	2.500000
	Device Accel Adaptive Deceleration (267):	1.000000
	Device Accel Velocity Scaling (268):	12.500000
	Synaptics Edges (269):	49, 1187, 48, 850
	Synaptics Finger (270):	25, 30, 0
	Synaptics Tap Time (271):	180
	Synaptics Tap Move (272):	67
	Synaptics Tap Durations (273):	180, 180, 100
	Synaptics ClickPad (274):	0
	Synaptics Middle Button Timeout (275):	75
	Synaptics Two-Finger Pressure (276):	282
	Synaptics Two-Finger Width (277):	7
	Synaptics Scrolling Distance (278):	30, 30
	Synaptics Edge Scrolling (279):	0, 0, 0
	Synaptics Two-Finger Scrolling (280):	1, 1
	Synaptics Move Speed (281):	1.000000, 1.750000, 0.130976, 0.000000
	Synaptics Off (282):	2
	Synaptics Locked Drags (283):	0
	Synaptics Locked Drags Timeout (284):	5000
	Synaptics Tap Action (285):	2, 3, 0, 0, 1, 3, 0
	Synaptics Click Action (286):	1, 3, 0
	Synaptics Circular Scrolling (287):	0
	Synaptics Circular Scrolling Distance (288):	0.100000
	Synaptics Circular Scrolling Trigger (289):	0
	Synaptics Circular Pad (290):	0
	Synaptics Palm Detection (291):	0
	Synaptics Palm Dimensions (292):	10, 200
	Synaptics Coasting Speed (293):	20.000000, 50.000000
	Synaptics Pressure Motion (294):	30, 160
	Synaptics Pressure Motion Factor (295):	1.000000, 1.000000
	Synaptics Resolution Detect (296):	1
	Synaptics Grab Event Device (297):	0
	Synaptics Gestures (298):	1
	Synaptics Capabilities (299):	1, 0, 0, 1, 1, 0, 0
	Synaptics Pad Resolution (300):	12, 12
	Synaptics Area (301):	0, 0, 0, 0
	Synaptics Noise Cancellation (302):	7, 7
	Device Product ID (260):	1739, 10608
	Device Node (261):	"/dev/input/event8"
ubuntu@ubuntu:~$

Comment 11 Rolle 2015-03-27 10:35:17 UTC
Ubuntu 14.10 LiveCD:

[liveuser@localhost ~]$ gsettings list-recursively |grep touchpad
org.gnome.settings-daemon.peripherals.touchpad tap-to-click true
org.gnome.settings-daemon.peripherals.touchpad natural-scroll true
org.gnome.settings-daemon.peripherals.touchpad left-handed 'mouse'
org.gnome.settings-daemon.peripherals.touchpad scroll-method 'two-finger-scrolling'
org.gnome.settings-daemon.peripherals.touchpad motion-acceleration -1.0
org.gnome.settings-daemon.peripherals.touchpad horiz-scroll-enabled true
org.gnome.settings-daemon.peripherals.touchpad disable-while-typing true
org.gnome.settings-daemon.peripherals.touchpad motion-threshold -1
org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled true
org.gnome.settings-daemon.peripherals.touchpad tap-to-click true
org.gnome.settings-daemon.peripherals.touchpad natural-scroll true
org.gnome.settings-daemon.peripherals.touchpad left-handed 'mouse'
org.gnome.settings-daemon.peripherals.touchpad scroll-method 'two-finger-scrolling'
org.gnome.settings-daemon.peripherals.touchpad motion-acceleration -1.0
org.gnome.settings-daemon.peripherals.touchpad horiz-scroll-enabled true
org.gnome.settings-daemon.peripherals.touchpad disable-while-typing true
org.gnome.settings-daemon.peripherals.touchpad motion-threshold -1
org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled true

Comment 12 Guillaume Poirier-Morency 2015-04-01 06:03:56 UTC
The same bug occurs with the Acer C720 touchpad

xinput --list

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Cypress APA Trackpad (cyapa)            	id=12	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=10	[slave  keyboard (3)]
    ↳ HD WebCam                               	id=11	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]

Comment 13 Peter Hutterer 2015-04-09 23:29:36 UTC
ubuntu uses the older synaptics driver, not the new libinput driver so the results are bound to be different.

(In reply to Rolle from comment #9)
> - tap: default is: disabled in UI -> toggled 2 times (enabled, disabled)
>        (changing UI settings has no functional effect)
> - two finger scroll: default is: endabled in UI -> toggled 2 times
> (disabled, enabled)
>        (changing UI settings has no functional effect)
> - natural scrolling: default is: disabled in UI -> toggled 2 times (enabled,
> disabled)
>        (changing UI settings has no functional effect)

ok, what I need you to do is to run the gsettings and xinput list-props before and after enabling it. if gsettings change but not the property, it's a gnome bug, if the property changes but it still won't work it's a libinput bug. if the gsettings doesn't change regardless, it's also a gnome bug.

Comment 14 Rolle 2015-04-10 13:26:28 UTC
I'm so sorry. This Acer Laptop isn't mine. Someone gave me to clean up the Windows partition. I haven't access anymore.
Maybe Guillaume Poirier-Morency could help?

Comment 15 Guillaume Poirier-Morency 2015-04-10 16:13:07 UTC
Funny.. here's what I get from xinput list-props 12

Device 'Cypress APA Trackpad (cyapa)':
	Device Enabled (138):	1
	Coordinate Transformation Matrix (140):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (272):	0
	libinput Accel Speed (273):	0.000000
	libinput Natural Scrolling Enabled (274):	0
	libinput Send Events Modes Available (258):	1, 1
	libinput Send Events Mode Enabled (259):	0, 0
	libinput Left Handed Enabled (275):	0
	libinput Scroll Methods Available (276):	1, 0, 0
	libinput Scroll Method Enabled (277):	1, 0, 0
	libinput Click Methods Available (278):	1, 1
	libinput Click Method Enabled (279):	1, 0
	Device Node (260):	"/dev/input/event13"
	Device Product ID (261):	0, 0

It seems like gsettings tapping is enabled, but not the underlying libinput property.

Okay, if I run

xinput --set-prop 12 'libinput Tapping Enabled' 1

It works!

Comment 16 Guillaume Poirier-Morency 2015-04-10 16:16:14 UTC
In fact, none of the options (tap, natural scrolling, two-finger scrolling) in the gnome-control-center works.

Comment 17 Rolle 2015-04-10 19:17:34 UTC
Thanks Guillaume that you did the job. Have a nice day.

Comment 18 Peter Hutterer 2015-04-13 01:19:56 UTC
reassigning to mutter. if the gsettings change but the property doesn't, then it's most likely a bug there.

Comment 19 Cédric Bellegarde 2015-04-15 11:59:32 UTC
ArchLinux is using libinput and this bug is not present...

Comment 20 Rolle 2015-04-22 20:51:26 UTC
The same problem with laptop Sony Vaio VGN-FS514S.
The gnome settings for touchpad doesn't have any effect.

gsettings show the change, xinput property doesn't. -> Gnome bug.

Comment 21 Peter Hutterer 2015-04-28 02:05:31 UTC
*** Bug 1201715 has been marked as a duplicate of this bug. ***

Comment 22 Peter Hutterer 2015-04-28 02:07:07 UTC
*** Bug 1215286 has been marked as a duplicate of this bug. ***

Comment 23 Bruno Larini 2015-04-30 18:26:49 UTC
I'm having the same problem on a Dell Vostro 1014. The touchpad is single-touch, the edge scroll is working fine but I can't tap to click after enabling it on Gnome configuration.

- Fedora 22 beta Live CD,
- Dell Vostro 1014,
- libinput 0.12.0-2.fc22.x86_64,
- xorg-x11-drv-libinput-0.8.0-2.fc22.x86_64,
- kernel 4.0.0-0.rc5.git4.1.fc22.x86_64


[root@localhost ~]# xinput --list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS GlidePoint                	id=11	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Video Bus                               	id=6	[slave  keyboard (3)]
    ↳ Power Button                            	id=7	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=8	[slave  keyboard (3)]
    ↳ Integrated_Webcam_2M                    	id=9	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=10	[slave  keyboard (3)]
    ↳ Dell WMI hotkeys                        	id=12	[slave  keyboard (3)]

[root@localhost ~]# xinput list-props 11
Device 'AlpsPS/2 ALPS GlidePoint':
	Device Enabled (131):	1
	Coordinate Transformation Matrix (133):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (265):	0
	libinput Accel Speed (266):	0.000000
	libinput Natural Scrolling Enabled (267):	0
	libinput Send Events Modes Available (251):	1, 1
	libinput Send Events Mode Enabled (252):	0, 0
	libinput Left Handed Enabled (268):	0
	libinput Scroll Methods Available (269):	0, 1, 0
	libinput Scroll Method Enabled (270):	0, 1, 0
	Device Node (253):	"/dev/input/event4"
	Device Product ID (254):	2, 8

Setting via command line:

[root@localhost ~]# xinput set-prop 11 265 1

made it work normally.

Comment 24 Peter Hutterer 2015-05-08 01:15:45 UTC
mutter-3.16.1.1-3.fc22 should include the required fixes now, can you please verify this? thanks.

Comment 25 Guillaume Poirier-Morency 2015-05-08 21:14:07 UTC
(In reply to Peter Hutterer from comment #24)
> mutter-3.16.1.1-3.fc22 should include the required fixes now, can you please
> verify this? thanks.

The bug is still occurring on my Acer C720.

Comment 26 Andrew Malcolmson 2015-05-10 02:30:55 UTC
Also not fixed on my Dell Latitude Z600.

Comment 27 Ondrej Holy 2015-05-13 11:34:40 UTC
*** Bug 1220941 has been marked as a duplicate of this bug. ***

Comment 28 Rui Matos 2015-05-13 13:27:59 UTC
Does it work if you toggle the gsetting on a terminal (as your user, not as root!) like

gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true

please try enabling and disabling it a few times like that. Does it work properly?

You can double check if the driver values are changing in a different terminal with 'xinput watch-props <device id>'

Comment 29 Andreas Gruenbacher 2015-05-13 14:17:54 UTC
As noted in bug 1220941, changing the gsettings value does not change the xinput value for me no matter how I change the gsettings value (GUI or commannd line).

Comment 30 Rui Matos 2015-05-14 10:03:53 UTC
(In reply to Andreas Gruenbacher from comment #29)
> As noted in bug 1220941, changing the gsettings value does not change the
> xinput value for me no matter how I change the gsettings value (GUI or
> commannd line).

The common pattern I'm noticing with these reports is that it doesn't seem to work for non-synaptics touchpads like yours and the ones reported on this bug.

I need to get my hands on one to be sure.

Comment 31 Andrew Malcolmson 2015-05-15 20:57:24 UTC
(In reply to Rui Matos from comment #30)
> The common pattern I'm noticing with these reports is that it doesn't seem
> to work for non-synaptics touchpads like yours and the ones reported on this
> bug.

Yes, my Dell Latitude Z600 has a AlpsPS/2 ALPS GlidePoint and behavior is identical to Andreas' comment #29.

Comment 32 Guillaume Poirier-Morency 2015-05-16 00:04:20 UTC
It works with GNOME under Wayland, but not under X11.

Could it be a problem with xorg-x11-drv-libinput?

Comment 33 Rui Matos 2015-05-16 23:08:15 UTC

*** This bug has been marked as a duplicate of bug 1206961 ***


Note You need to log in before you can comment on or make changes to this bug.