Bug 1206961 - Trackpad functionality has gone backward since fedora 21
Summary: Trackpad functionality has gone backward since fedora 21
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: clutter
Version: 22
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
: 1202773 1214348 1214350 1214351 1214352 1215324 1220024 1223070 (view as bug list)
Depends On:
Blocks: F22FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2015-03-30 00:29 UTC by Rodd Clarkson
Modified: 2015-06-02 03:26 UTC (History)
26 users (show)

Fixed In Version: gnome-shell-3.16.2-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-21 18:45:02 UTC


Attachments (Terms of Use)
/var/log/Xorg.0.log (44.63 KB, text/plain)
2015-04-07 12:38 UTC, Rodd Clarkson
no flags Details
Screen shot of Mouse and Touchpad settings. (25.71 KB, image/png)
2015-04-08 09:24 UTC, Rodd Clarkson
no flags Details
Updated Settings dialog with Gnome 3.16.1 (27.20 KB, image/png)
2015-04-19 00:49 UTC, Rodd Clarkson
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 749482 None None None Never

Description Rodd Clarkson 2015-03-30 00:29:30 UTC
Description of problem:

I whole bunch of things don't work on the trackpad in fedora 22 that did work in fedora 21.

Triple clicking no longer pastes.
Triple clicking no longer opens links in a new window.
I'm quessing triple clicking no longer works.

Also,

two finger scrolling works, but only in terms of manipulating the scroll bar, so dragging down makes the window go down and dragging up makes it go up.

There's an option in Settings > Mouse & Touchpad for Natural Scrolling (which I'm guessing means work like a touch screen) but toggling this makes no difference.


Version-Release number of selected component (if applicable):

xorg-x11-drv-synaptics-1.8.2-1.fc22.x86_86


How reproducible:

Since installation

Comment 1 Rodd Clarkson 2015-03-30 00:31:07 UTC
In fact, I just noticed that the two finger scroll option in settings > Mouse & Touchpad makes no difference either.  Two finger scrolling just works either way.

Comment 2 Peter Hutterer 2015-04-07 06:59:39 UTC
What's the evemu-describe output for the device?
Are you using the libinput driver or the synaptics driver? the xorg.log will tell you

Comment 3 Rodd Clarkson 2015-04-07 12:35:39 UTC
# evemu-describe 
Available devices:
/dev/input/event0:	Power Button
/dev/input/event1:	Lid Switch
/dev/input/event2:	Power Button
/dev/input/event3:	AT Translated Set 2 keyboard
/dev/input/event4:	Video Bus
/dev/input/event5:	HDA Intel HDMI HDMI/DP,pcm=3
/dev/input/event6:	HDA Intel HDMI HDMI/DP,pcm=7
/dev/input/event7:	HDA Intel HDMI HDMI/DP,pcm=8
/dev/input/event8:	HDA Intel PCH Headphone Mic
/dev/input/event9:	SYNAPTICS Synaptics Large Touch Screen
/dev/input/event10:	Integrated_Webcam_HD
/dev/input/event11:	Dell WMI hotkeys
/dev/input/event12:	DLL060A:00 06CB:2734

Comment 4 Rodd Clarkson 2015-04-07 12:37:09 UTC
Maybe you actually want:

# evemu-describe 
Available devices:
/dev/input/event0:	Power Button
/dev/input/event1:	Lid Switch
/dev/input/event2:	Power Button
/dev/input/event3:	AT Translated Set 2 keyboard
/dev/input/event4:	Video Bus
/dev/input/event5:	HDA Intel HDMI HDMI/DP,pcm=3
/dev/input/event6:	HDA Intel HDMI HDMI/DP,pcm=7
/dev/input/event7:	HDA Intel HDMI HDMI/DP,pcm=8
/dev/input/event8:	HDA Intel PCH Headphone Mic
/dev/input/event9:	SYNAPTICS Synaptics Large Touch Screen
/dev/input/event10:	Integrated_Webcam_HD
/dev/input/event11:	Dell WMI hotkeys
/dev/input/event12:	DLL060A:00 06CB:2734
Select the device event number [0-12]: 12
# EVEMU 1.2
# Input device name: "DLL060A:00 06CB:2734"
# Input device ID: bus 0x18 vendor 0x6cb product 0x2734 version 0x100
# Supported events:
#   Event type 0 (EV_SYN)
#     Event code 0 (SYN_REPORT)
#     Event code 1 (SYN_CONFIG)
#     Event code 2 (SYN_MT_REPORT)
#     Event code 3 (SYN_DROPPED)
#     Event code 4 ((null))
#     Event code 5 ((null))
#     Event code 6 ((null))
#     Event code 7 ((null))
#     Event code 8 ((null))
#     Event code 9 ((null))
#     Event code 10 ((null))
#     Event code 11 ((null))
#     Event code 12 ((null))
#     Event code 13 ((null))
#     Event code 14 ((null))
#   Event type 1 (EV_KEY)
#     Event code 272 (BTN_LEFT)
#     Event code 325 (BTN_TOOL_FINGER)
#     Event code 328 (BTN_TOOL_QUINTTAP)
#     Event code 330 (BTN_TOUCH)
#     Event code 333 (BTN_TOOL_DOUBLETAP)
#     Event code 334 (BTN_TOOL_TRIPLETAP)
#     Event code 335 (BTN_TOOL_QUADTAP)
#   Event type 3 (EV_ABS)
#     Event code 0 (ABS_X)
#       Value    396
#       Min        1
#       Max     4070
#       Fuzz       0
#       Flat       0
#       Resolution 41
#     Event code 1 (ABS_Y)
#       Value   2460
#       Min        1
#       Max     2472
#       Fuzz       0
#       Flat       0
#       Resolution 41
#     Event code 24 (ABS_PRESSURE)
#       Value      0
#       Min        0
#       Max      255
#       Fuzz       0
#       Flat       0
#       Resolution 0
#     Event code 47 (ABS_MT_SLOT)
#       Value      0
#       Min        0
#       Max        4
#       Fuzz       0
#       Flat       0
#       Resolution 0
#     Event code 48 (ABS_MT_TOUCH_MAJOR)
#       Value      0
#       Min        0
#       Max       15
#       Fuzz       0
#       Flat       0
#       Resolution 0
#     Event code 49 (ABS_MT_TOUCH_MINOR)
#       Value      0
#       Min        0
#       Max       15
#       Fuzz       0
#       Flat       0
#       Resolution 0
#     Event code 52 (ABS_MT_ORIENTATION)
#       Value      0
#       Min        0
#       Max        1
#       Fuzz       0
#       Flat       0
#       Resolution 0
#     Event code 53 (ABS_MT_POSITION_X)
#       Value      0
#       Min        1
#       Max     4070
#       Fuzz       0
#       Flat       0
#       Resolution 41
#     Event code 54 (ABS_MT_POSITION_Y)
#       Value      0
#       Min        1
#       Max     2472
#       Fuzz       0
#       Flat       0
#       Resolution 41
#     Event code 57 (ABS_MT_TRACKING_ID)
#       Value      0
#       Min        0
#       Max    65535
#       Fuzz       0
#       Flat       0
#       Resolution 0
#     Event code 58 (ABS_MT_PRESSURE)
#       Value      0
#       Min        0
#       Max      255
#       Fuzz       0
#       Flat       0
#       Resolution 0
# Properties:
#   Property  type 0 (INPUT_PROP_POINTER)
#   Property  type 2 (INPUT_PROP_BUTTONPAD)
N: DLL060A:00 06CB:2734
I: 0018 06cb 2734 0100
P: 05 00 00 00 00 00 00 00
B: 00 0b 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 01 00 00 00 00 00
B: 01 20 e5 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 01 00 00 00 00 00 00 00 00
B: 02 00 00 00 00 00 00 00 00
B: 03 03 00 00 01 00 80 73 06
B: 04 00 00 00 00 00 00 00 00
B: 05 00 00 00 00 00 00 00 00
B: 11 00 00 00 00 00 00 00 00
B: 12 00 00 00 00 00 00 00 00
B: 14 00 00 00 00 00 00 00 00
B: 15 00 00 00 00 00 00 00 00
B: 15 00 00 00 00 00 00 00 00
A: 00 1 4070 0 0 41
A: 01 1 2472 0 0 41
A: 18 0 255 0 0 0
A: 2f 0 4 0 0 0
A: 30 0 15 0 0 0
A: 31 0 15 0 0 0
A: 34 0 1 0 0 0
A: 35 1 4070 0 0 41
A: 36 1 2472 0 0 41
A: 39 0 65535 0 0 0
A: 3a 0 255 0 0 0

Comment 5 Rodd Clarkson 2015-04-07 12:38:19 UTC
Created attachment 1011744 [details]
/var/log/Xorg.0.log

Comment 6 Rodd Clarkson 2015-04-07 12:40:58 UTC
I guess I should clarify that I'm using the defaults for Fedora.

Comment 7 Peter Hutterer 2015-04-08 06:29:15 UTC
Can't find the bug number right now but make sure you have the latest kernel installed, those touchpads needed a few fixes.

Otherwise: what's "triple-clicking"? could mean any of a few things, so I want to make sure I know what you're referring to.

If you run xinput watch-props "<device name>" does toggling the checkboxes in gnome make any difference?

Comment 8 Rodd Clarkson 2015-04-08 09:09:23 UTC
This is the kernel I'm running.  F22 is all up to date to.

$ uname -r
4.0.0-0.rc5.git4.1.fc22.x86_64


By "Triple click" I mean click with three fingers at the same time.  This usually acts like the middle click on the mouse.

Comment 9 Rodd Clarkson 2015-04-08 09:23:23 UTC
This is all I get from 'xinput watch-props 11'

The only options that seem to trigger a response is the left button, right button options.  (I'll attach a copy of the Mouse and Touchpad dialog.)

$ xinput watch-props 11
Device 'DLL060A:00 06CB:2734':
	Device Enabled (136):	1
	Coordinate Transformation Matrix (138):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (271):	0
	libinput Accel Speed (272):	0.000000
	libinput Natural Scrolling Enabled (273):	0
	libinput Send Events Modes Available (254):	1, 1
	libinput Send Events Mode Enabled (255):	0, 0
	libinput Left Handed Enabled (274):	0
	libinput Scroll Methods Available (275):	1, 0, 0
	libinput Scroll Method Enabled (276):	1, 0, 0
	libinput Click Methods Available (277):	1, 1
	libinput Click Method Enabled (278):	1, 0
	Device Node (256):	"/dev/input/event12"
	Device Product ID (257):	1739, 10036
Property 'libinput Left Handed Enabled' changed.
	libinput Left Handed Enabled (274):	1
Property 'libinput Left Handed Enabled' changed.
	libinput Left Handed Enabled (274):	1
Property 'libinput Left Handed Enabled' changed.
	libinput Left Handed Enabled (274):	0

Comment 10 Rodd Clarkson 2015-04-08 09:24:13 UTC
Created attachment 1012117 [details]
Screen shot of  Mouse and Touchpad settings.

Comment 11 Hans de Goede 2015-04-08 09:29:30 UTC
Hi Rodd,

So what you want is what we call clickfinger behavior, and by default that is not enabled. For F-22 we're switching to a new userspace inputstack called libinput, see:

https://fedoraproject.org/wiki/Changes/LibinputForXorg

Since you've upgraded chances are you are still using xorg-x11-drv-synaptics, so first of all lets switch to libinput, please do:

dnf install xorg-x11-drv-libinput and then log out and log in again (or reboot)

Then open a terminal and do:

xinput list

And then

xinput list-props <id>

Where <id> is the id for your touchpad, ths should show something like this:

Device 'SynPS/2 Synaptics TouchPad':
        Device Enabled (136):   1
        Coordinate Transformation Matrix (138): 1.000000, 0.000000, 0.000000, 0
        libinput Tapping Enabled (268): 0
        libinput Accel Speed (269):     0.000000
        libinput Natural Scrolling Enabled (270):       0
        libinput Send Events Modes Available (254):     1, 1
        libinput Send Events Mode Enabled (255):        0, 0
        libinput Left Handed Enabled (271):     0
        libinput Scroll Methods Available (272):        1, 0, 0
        libinput Scroll Method Enabled (273):   1, 0, 0
        libinput Click Methods Available (274): 1, 1
        libinput Click Method Enabled (275):    1, 0
        Device Node (256):      "/dev/input/event4"
        Device Product ID (257):        2, 7

The interesting bit is:

        libinput Click Methods Available (274): 1, 1
        libinput Click Method Enabled (275):    1, 0

This says that you've 2 click methods available, both method 0 (LIBINPUT_CONFIG_CLICK_METHOD_BUTTON_AREAS) and  method 1 (LIBINPUT_CONFIG_CLICK_METHOD_CLICKFINGER) and currently method 0 is active, which means that to right click you click the bottom right of your touchpad and to middle click you need to put a finger in both the bottom left and the bottom right areas and then click (3 button mouse emulation style).

To change this to clickfinger do:

xinput set-prop <id> "libinput Click Method Enabled" 0 1

Now you can right click by pressing down the clickpad anywhere using 2 fingers, and middle click by pressing it down anywhere using 3 fingers.

If this helps please file a bug at:

https://bugzilla.gnome.org/enter_bug.cgi?product=gnome-control-center&component=Mouse

To request the gnome guys to add a toggle for clickfinger behavior to the control-panel. Also please start the summary with RFE to indicate that you're requesting an enhancement.

Regards,

Hans

Comment 12 Rodd Clarkson 2015-04-19 00:48:15 UTC
Thought I should update with the recent update to Gnome 3.16.1

$ rpm -q gnome-shell
gnome-shell-3.16.1-1.fc22.x86_64

I've attached a screenshot of the Settings > Mouse & Trackpad dialog.  Note that "Two finger scroll" is grey out.  Also, as you'll see from xinput watch-props (below) some of the other options make output appear (other than "Left / Right") but they don't seem to change the output.  For exampke, toggling Natural Scrolling sets the value to '0', but not '1'.


$ xinput watch-props 11
Device 'DLL060A:00 06CB:2734':
	Device Enabled (136):	1
	Coordinate Transformation Matrix (138):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (271):	0
	libinput Accel Speed (272):	0.000000
	libinput Natural Scrolling Enabled (273):	0
	libinput Send Events Modes Available (254):	1, 1
	libinput Send Events Mode Enabled (255):	0, 0
	libinput Left Handed Enabled (274):	0
	libinput Scroll Methods Available (275):	1, 0, 0
	libinput Scroll Method Enabled (276):	1, 0, 0
	libinput Click Methods Available (277):	1, 1
	libinput Click Method Enabled (278):	1, 0
	Device Node (256):	"/dev/input/event12"
	Device Product ID (257):	1739, 10036
Property 'libinput Accel Speed' changed.
	libinput Accel Speed (272):	0.000000
Property 'libinput Accel Speed' changed.
	libinput Accel Speed (272):	0.000000
Property 'libinput Natural Scrolling Enabled' changed.
	libinput Natural Scrolling Enabled (273):	0
Property 'libinput Natural Scrolling Enabled' changed.
	libinput Natural Scrolling Enabled (273):	0
Property 'libinput Left Handed Enabled' changed.
	libinput Left Handed Enabled (274):	1
Property 'libinput Left Handed Enabled' changed.
	libinput Left Handed Enabled (274):	1
Property 'libinput Left Handed Enabled' changed.
	libinput Left Handed Enabled (274):	0
^C

Comment 13 Rodd Clarkson 2015-04-19 00:49:05 UTC
Created attachment 1015959 [details]
Updated Settings dialog with Gnome 3.16.1

Comment 14 Peter Hutterer 2015-04-19 22:47:24 UTC
Reassigning to g-s-d, if the driver property doesn't change when you toggle the UI settings it's a gnome bug.

Comment 15 Rui Matos 2015-04-20 18:55:53 UTC
(In reply to Rodd Clarkson from comment #12)
> I've attached a screenshot of the Settings > Mouse & Trackpad dialog.  Note
> that "Two finger scroll" is grey out.

That normal because that's the only scroll method that driver advertises:

libinput Scroll Methods Available (275):	1, 0, 0

> Also, as you'll see from xinput
> watch-props (below) some of the other options make output appear (other than
> "Left / Right") but they don't seem to change the output.  For exampke,
> toggling Natural Scrolling sets the value to '0', but not '1'.

I can't reproduce this, the values do change for me.

Regarding the click method, what's the output of:

gsettings get org.gnome.desktop.peripherals.touchpad click-method

?

Comment 16 Rui Matos 2015-04-22 14:04:14 UTC
*** Bug 1214348 has been marked as a duplicate of this bug. ***

Comment 17 Rui Matos 2015-04-22 14:07:13 UTC
*** Bug 1214350 has been marked as a duplicate of this bug. ***

Comment 18 Rui Matos 2015-04-22 14:07:28 UTC
*** Bug 1214351 has been marked as a duplicate of this bug. ***

Comment 19 Rui Matos 2015-04-22 14:07:41 UTC
*** Bug 1214352 has been marked as a duplicate of this bug. ***

Comment 20 James Patterson 2015-04-22 14:08:33 UTC
I'm also having problems since upgrading from F21 to F22 Beta:
* Middle-click paste is broken (bug 1214352)
* Two-finger click for right-click is broken (bug 1214351)
* Natural scrolling checkbox does nothing, it's always disabled (bug 1214350)
* Two-finger scroll is greyed out (bug 1214348)

Comment 21 Rui Matos 2015-04-22 14:15:09 UTC
(In reply to James Patterson from comment #20)
> I'm also having problems since upgrading from F21 to F22 Beta:

Can you answer my question in comment 15 ? Also, does the update to GNOME 3.16.1 fix any of those issues?

Comment 22 James Patterson 2015-04-22 14:21:43 UTC
(In reply to Rui Matos from comment #21)
> Can you answer my question in comment 15 ? Also, does the update to GNOME
> 3.16.1 fix any of those issues?

gnome-3.16.1 hasn't hit my mirror yet, I'll try disabling the mirror for the .repo file.

I am seeing a string name for the touchpad in xinput list:

$ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ SYNAPTICS Synaptics Large Touch Screen  	id=9	[slave  pointer  (2)]
⎜   ↳ DLL060A:00 06CB:2734                    	id=11	[slave  pointer  (2)]

$ xinput list-props "DLL060A:00 06CB:2734"
Device 'DLL060A:00 06CB:2734':
	Device Enabled (136):	1
	Coordinate Transformation Matrix (138):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (273):	0
	libinput Accel Speed (274):	0.000000
	libinput Natural Scrolling Enabled (275):	0
	libinput Send Events Modes Available (256):	1, 1
	libinput Send Events Mode Enabled (257):	0, 0
	libinput Left Handed Enabled (276):	0
	libinput Scroll Methods Available (277):	1, 0, 0
	libinput Scroll Method Enabled (278):	1, 0, 0
	libinput Click Methods Available (279):	1, 1
	libinput Click Method Enabled (280):	1, 0
	Device Node (258):	"/dev/input/event12"
	Device Product ID (259):	1739, 10036

$ gsettings get org.gnome.desktop.peripherals.touchpad click-method
'default'

btw I removed xorg-x11-drv-synaptics

Comment 23 James Patterson 2015-04-22 14:22:53 UTC
s/string name/strange name/

Comment 24 James Patterson 2015-04-22 14:25:18 UTC
gnome 3.16.1: I have 24 packages with ^gnome and version 3.16.1, 18 with 3.16.0

Comment 25 Rui Matos 2015-04-22 14:32:00 UTC
Open 2 terminals and run these commands on each one of them, then change the values in UI and let us know what shows up:

gsettings monitor org.gnome.desktop.peripherals.touchpad
xinput watch-props 11

Comment 26 James Patterson 2015-04-22 14:35:42 UTC
I changed natural scrolling, and the terminal reacted. For middle-click paste, no reaction:

$ xinput watch-props 11
Device 'DLL060A:00 06CB:2734':
	Device Enabled (136):	1
	Coordinate Transformation Matrix (138):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (273):	0
	libinput Accel Speed (274):	0.000000
	libinput Natural Scrolling Enabled (275):	0
	libinput Send Events Modes Available (256):	1, 1
	libinput Send Events Mode Enabled (257):	0, 0
	libinput Left Handed Enabled (276):	0
	libinput Scroll Methods Available (277):	1, 0, 0
	libinput Scroll Method Enabled (278):	1, 0, 0
	libinput Click Methods Available (279):	1, 1
	libinput Click Method Enabled (280):	1, 0
	Device Node (258):	"/dev/input/event12"
	Device Product ID (259):	1739, 10036
Property 'libinput Natural Scrolling Enabled' changed.
	libinput Natural Scrolling Enabled (275):	0
Property 'libinput Natural Scrolling Enabled' changed.
	libinput Natural Scrolling Enabled (275):	0

$ gsettings monitor org.gnome.desktop.peripherals.touchpad
natural-scroll: false
natural-scroll: true

Comment 27 Rui Matos 2015-04-22 15:26:58 UTC
(In reply to James Patterson from comment #26)
> I changed natural scrolling, and the terminal reacted. For middle-click
> paste, no reaction:

Forget about pasting for a while. Does middle-click itself work anywhere? Does your touchpad have a physical middle button? How did you use to middle-click before?

Also, please post the output of

gsettings list-recursively org.gnome.desktop.peripherals.touchpad

> 	libinput Scroll Methods Available (277):	1, 0, 0

The driver reports two finger scroll as the only scroll method that's why it's grayed out.

> * Two-finger click for right-click is broken (bug 1214351)
> 	libinput Click Methods Available (279):	1, 1
> 	libinput Click Method Enabled (280):	1, 0

We don't currently have UI for this. How did you right-click before?

1, 0 here means that the default for you seems to be button areas, i.e. there's an area on the touchpad that does right clicks.

On my X240's touchpad I have 0, 1 which means the number of fingers on the touchpad when clicking determines if the kind of click. I'm not sure yet why we have different defaults. Peter? Hans?

> Property 'libinput Natural Scrolling Enabled' changed.
> 	libinput Natural Scrolling Enabled (275):	0
> Property 'libinput Natural Scrolling Enabled' changed.
> 	libinput Natural Scrolling Enabled (275):	0
> 
> $ gsettings monitor org.gnome.desktop.peripherals.touchpad
> natural-scroll: false
> natural-scroll: true

This is quite strange, but matches the original report here as well. It works for me though. Peter, any hints on how to debug this?

Comment 28 Rui Matos 2015-04-22 16:22:50 UTC
(In reply to Rui Matos from comment #27)
> On my X240's touchpad I have 0, 1 which means the number of fingers on the
> touchpad when clicking determines if the kind of click. I'm not sure yet why
> we have different defaults. Peter? Hans?

Oh, I know the answer to this one. The values applied by mutter at startup changed for 3.16.1, so when you update mutter to that version you should automatically get the nr. of fingers determines the kind of click method.

Comment 29 Ray Strode [halfline] 2015-04-22 20:32:37 UTC
see also https://bugzilla.gnome.org/show_bug.cgi?id=746840

Comment 30 James Patterson 2015-04-23 06:43:33 UTC
(In reply to Rui Matos from comment #27)
> (In reply to James Patterson from comment #26)
> > I changed natural scrolling, and the terminal reacted. For middle-click
> > paste, no reaction:
> 
> Forget about pasting for a while. Does middle-click itself work anywhere?
> Does your touchpad have a physical middle button? How did you use to
> middle-click before?

I don't have a physical middle-click button. I used to paste with three fingers irrc.

> Also, please post the output of
> 
> gsettings list-recursively org.gnome.desktop.peripherals.touchpad

$ gsettings list-recursively org.gnome.desktop.peripherals.touchpad
org.gnome.desktop.peripherals.touchpad natural-scroll true
org.gnome.desktop.peripherals.touchpad click-method 'default'
org.gnome.desktop.peripherals.touchpad scroll-method 'two-finger-scrolling'
org.gnome.desktop.peripherals.touchpad left-handed 'mouse'
org.gnome.desktop.peripherals.touchpad send-events 'enabled'
org.gnome.desktop.peripherals.touchpad tap-to-click true
org.gnome.desktop.peripherals.touchpad speed 0.0

> > 	libinput Scroll Methods Available (277):	1, 0, 0
> 
> The driver reports two finger scroll as the only scroll method that's why
> it's grayed out.
> 
> > * Two-finger click for right-click is broken (bug 1214351)
> > 	libinput Click Methods Available (279):	1, 1
> > 	libinput Click Method Enabled (280):	1, 0
> 
> We don't currently have UI for this. How did you right-click before?

Two-finger click, probably configured through gnome-tweak-tool.

> 1, 0 here means that the default for you seems to be button areas, i.e.
> there's an area on the touchpad that does right clicks.

The touchpad has a bottom area you can click, but they are not like the old-style buttons.

> On my X240's touchpad I have 0, 1 which means the number of fingers on the
> touchpad when clicking determines if the kind of click. I'm not sure yet why
> we have different defaults. Peter? Hans?
> 
> > Property 'libinput Natural Scrolling Enabled' changed.
> > 	libinput Natural Scrolling Enabled (275):	0
> > Property 'libinput Natural Scrolling Enabled' changed.
> > 	libinput Natural Scrolling Enabled (275):	0
> > 
> > $ gsettings monitor org.gnome.desktop.peripherals.touchpad
> > natural-scroll: false
> > natural-scroll: true
> 
> This is quite strange, but matches the original report here as well. It
> works for me though. Peter, any hints on how to debug this?

Comment 31 Peter Hutterer 2015-04-24 06:25:22 UTC
sounds like the bug Ray linked to, if you have "default" it changes sort-of randomly but generally comes up with what libinput picks as default (which is software buttons on non-Apple touchpads). You can verify that easily: at startup, if the multi-finger click doesn't work work check if the bottom software buttons work: bottom right is right click, both left and right is middle click.

Comment 32 Rodd Clarkson 2015-04-24 08:10:34 UTC
Clicking both pastes for me.  I'm following along with the discussion but at the moment I can't open gnome-settings, which makes this a little tricky to work on.

I'm using 3.16.1, it's actually a fresh install of fedora 22 alpha, and not an upgrade as comment 11 suggests and I'm getting similar output to James (with the exception of the stuff that needs gnome-settings.)

Comment 33 Rodd Clarkson 2015-04-24 11:26:23 UTC
Okay, let's see if I can break this down.  Here's a breakdown of the output of the two commands in Comment #25

Running in two separate terms I get this when I start each:

$ gsettings monitor org.gnome.desktop.peripherals.touchpad


$ xinput watch-props 11
Device 'DLL060A:00 06CB:2734':
	Device Enabled (136):	1
	Coordinate Transformation Matrix (138):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (271):	0
	libinput Accel Speed (272):	0.000000
	libinput Natural Scrolling Enabled (273):	0
	libinput Send Events Modes Available (254):	1, 1
	libinput Send Events Mode Enabled (255):	0, 0
	libinput Left Handed Enabled (274):	0
	libinput Scroll Methods Available (275):	1, 0, 0
	libinput Scroll Method Enabled (276):	1, 0, 0
	libinput Click Methods Available (277):	1, 1
	libinput Click Method Enabled (278):	1, 0
	Device Node (256):	"/dev/input/event12"
	Device Product ID (257):	1739, 10036


When I click Primary Button: Left / Right


Property 'libinput Left Handed Enabled' changed.
	libinput Left Handed Enabled (274):	1
Property 'libinput Left Handed Enabled' changed.
	libinput Left Handed Enabled (274):	1
Property 'libinput Left Handed Enabled' changed.
	libinput Left Handed Enabled (274):	0


When I change the Double-Click Speed:

<nothing in either output>


When I Toggle Touchpad ON / OFF

send-events: 'disabled'
send-events: 'enabled'


When I change Pointer Speed

speed: -0.3094170403587444

Property 'libinput Accel Speed' changed.
	libinput Accel Speed (272):	0.000000


When I toggle Tap to Click

tap-to-click: false
tap-to-click: true


When I toggle Natural Scrolling

natural-scroll: false
natural-scroll: true

Property 'libinput Natural Scrolling Enabled' changed.
	libinput Natural Scrolling Enabled (273):	0
Property 'libinput Natural Scrolling Enabled' changed.
	libinput Natural Scrolling Enabled (273):	0

Comment 34 James Patterson 2015-04-26 16:50:17 UTC
This isn't related to gnome settings being screwed up is it? bug 1215450

Comment 35 mlaverdiere 2015-04-30 13:41:07 UTC
*** Bug 1215324 has been marked as a duplicate of this bug. ***

Comment 36 mlaverdiere 2015-04-30 13:57:40 UTC
I don't know where all the explanations/investigation here are supposed to lead, but for now, the result for a regular user with hardware like mine (quite common laptop touchpad) upgrading to f22 is getting an erratic/non functional touchpad, making the experience quite irritating.

The main problem (among others) in my case is that right click gives me the same as left click, as it seems that right click functions are now available with 2 fingers click.  Overall, the touchpad regularly feels erratic, as it sometimes gives me the right click functions when I'm left clicking (seems like if the pas was too sensitive and behave like if I was a 2 fingers click)

(There is also the inability to disable touchpad while typing, covered by another report:  https://bugzilla.gnome.org/show_bug.cgi?id=747340)

Here are some info on my touchpad:

I: Bus=0011 Vendor=0002 Product=000e Version=0000
N: Name="ETPS/2 Elantech Touchpad"
P: Phys=isa0060/serio4/input0
S: Sysfs=/devices/platform/i8042/serio4/input/input11
U: Uniq=
H: Handlers=mouse0 event4 
B: PROP=5
B: EV=b
B: KEY=e420 10000 0 0 0 0
B: ABS=661800011000003

Comment 37 Peter Hutterer 2015-05-01 05:32:04 UTC
mlaverdiere: see comment #29

Comment 38 James Patterson 2015-05-13 12:29:55 UTC
Is F22 going to ship with libinput, or will it roll back?

Comment 39 Rodd Clarkson 2015-05-13 12:49:48 UTC
Surely this bug has to be a blocker for fedora 22 final!

Trackpad usability can't go this far backward and be acceptable.

Comment 40 Rui Matos 2015-05-13 13:28:58 UTC
There are some fixes in mutter 3.16.2 and in libinput 0.15.0 . Do things work better with those versions?

Comment 41 James Patterson 2015-05-13 15:30:10 UTC
$ rpm -q mutter libinput
mutter-3.16.1.1-3.fc22.x86_64
libinput-0.15.0-1.fc22.x86_64

Not for me: natural scrolling is still broken, so is paste, so is two-finger right-click.

Comment 42 Rodd Clarkson 2015-05-14 01:32:18 UTC
Right, I've just done the test above and there's no real change.

xinput watch-props 11 shows a bunch of libinput [setting] Defaults now along with the other settings, but all the other results are the sames.  See below for current output.

I've got libinput-0.15.0-1.fc22.x86_64 installed

Mutter on the other hand is only mutter-3.16.1.1-4.fc22.x86_64

I've looked on http://koji.fedoraproject.org/koji but can't find 3.16.2.  There's a 3.17.1 for fc23 which I could build for fc22 if you'd like.





$ xinput watch-props 11
Device 'DLL060A:00 06CB:2734':
	Device Enabled (136):	1
	Coordinate Transformation Matrix (138):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (273):	0
	libinput Tapping Enabled Default (274):	0
	libinput Accel Speed (275):	0.000000
	libinput Accel Speed Default (276):	0.000000
	libinput Natural Scrolling Enabled (277):	0
	libinput Natural Scrolling Enabled Default (278):	0
	libinput Send Events Modes Available (254):	1, 1
	libinput Send Events Mode Enabled (255):	0, 0
	libinput Send Events Mode Enabled Default (256):	0, 0
	libinput Left Handed Enabled (279):	0
	libinput Left Handed Enabled Default (280):	0
	libinput Scroll Methods Available (281):	1, 0, 0
	libinput Scroll Method Enabled (282):	1, 0, 0
	libinput Scroll Method Enabled Default (283):	1, 0, 0
	libinput Click Methods Available (284):	1, 1
	libinput Click Method Enabled (285):	1, 0
	libinput Click Method Enabled Default (286):	1, 0
	Device Node (257):	"/dev/input/event12"
	Device Product ID (258):	1739, 10036

Comment 43 Rodd Clarkson 2015-05-14 01:33:41 UTC
should this bug be moved to libinput or mutter instead of gnome-settings-daemon.

Comment 44 Rodd Clarkson 2015-05-15 05:45:17 UTC
I've updated to mutter-3.16.2-1.fc22.x86_64 but there's no improvement.

Comment 45 optimisme 2015-05-15 18:31:37 UTC
I will post my results hoping to help...

xinput watch-props 11
Device 'Apple Inc. Apple Internal Keyboard / Trackpad':
	Device Enabled (139):	1
	Coordinate Transformation Matrix (141):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Send Events Modes Available (259):	1, 0
	libinput Send Events Mode Enabled (260):	0, 0
	libinput Send Events Mode Enabled Default (261):	0, 0
	Device Node (262):	"/dev/input/event4"
	Device Product ID (263):	1452, 567

gsettings monitor org.gnome.desktop.peripherals.touchpad
natural-scroll: false
natural-scroll: true
natural-scroll: false
natural-scroll: true

rpm -q mutter libinput
mutter-3.16.1.1-4.fc22.x86_64
libinput-0.15.0-1.fc22.x86_64

But natural-scroll and  tap-to-click are not working.

:(

Comment 46 Hans de Goede 2015-05-15 18:37:23 UTC
Hi,

(In reply to optimisme from comment #45)
> I will post my results hoping to help...
> 
> xinput watch-props 11
> Device 'Apple Inc. Apple Internal Keyboard / Trackpad':
> 	Device Enabled (139):	1
> 	Coordinate Transformation Matrix (141):	1.000000, 0.000000, 0.000000,
> 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
> 	libinput Send Events Modes Available (259):	1, 0
> 	libinput Send Events Mode Enabled (260):	0, 0
> 	libinput Send Events Mode Enabled Default (261):	0, 0
> 	Device Node (262):	"/dev/input/event4"
> 	Device Product ID (263):	1452, 567

This does not look like the settings for a touchpad what is the output of "xinput list" ?
are you sure you are watching the props for the right device ?

Also please make sure that you've the latest xorg-x11-drv-libinput, you should have:
 xorg-x11-drv-libinput-0.9.0-1.fc22

Regards,

Hans

Comment 47 optimisme 2015-05-15 18:55:17 UTC
xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ bcm5974                                 	id=12	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ Built-in iSight                         	id=10	[slave  keyboard (3)]
    ↳ Apple Inc. Apple Internal Keyboard / Trackpad	id=11	[slave  keyboard (3)]
    ↳ Apple Computer, Inc. IR Receiver        	id=13	[slave  keyboard (3)]


rpm -q xorg-x11-drv-libinput
xorg-x11-drv-libinput-0.9.0-1.fc22.x86_64

Comment 48 optimisme 2015-05-15 20:00:42 UTC
It works (more or less) under "Gnome Wayland" session but not under "Gnome" one. 

- Tap to click works
- Natural scroll works but is not smooth/buttery
- Scroll does not work at 'overview apps' mode

Comment 49 Rodd Clarkson 2015-05-16 05:20:30 UTC
I've tested using "Gnome on Wayland" too.

Two finger scrolling works, along with natural scrolling, but there's a significant delay.

Three finger clicks don't work, nor does clicking the right and left buttons, so the middle click functionality is gone.

Mouse pointer speed and double click speed settings work.

In general there feels like there is lag between doing things on the trackpad and on the action occurring.

Would it be helpful to go through the tests above and give you feedback on what works in Wayland?

Comment 50 Hans de Goede 2015-05-16 07:55:31 UTC
(In reply to optimisme from comment #47)
> xinput list
> ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
> ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
> ⎜   ↳ bcm5974                                 	id=12	[slave  pointer  (2)]
> ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
>     ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
>     ↳ Power Button                            	id=6	[slave  keyboard (3)]
>     ↳ Video Bus                               	id=7	[slave  keyboard (3)]
>     ↳ Power Button                            	id=8	[slave  keyboard (3)]
>     ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
>     ↳ Built-in iSight                         	id=10	[slave  keyboard (3)]
>     ↳ Apple Inc. Apple Internal Keyboard / Trackpad	id=11	[slave  keyboard
> (3)]
>     ↳ Apple Computer, Inc. IR Receiver        	id=13	[slave  keyboard (3)]

Ok, so your touchpad is id 12, not 11, can you do "xinput watch-props 12", and then change tap-to-click / natural scrolling in the config panel and paste the output here ?

Comment 51 optimisme 2015-05-16 09:44:26 UTC
xinput watch-props 12
Device 'bcm5974':
	Device Enabled (139):	1
	Coordinate Transformation Matrix (141):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (274):	0
	libinput Tapping Enabled Default (275):	0
	libinput Accel Speed (276):	0.000000
	libinput Accel Speed Default (277):	0.000000
	libinput Natural Scrolling Enabled (278):	0
	libinput Natural Scrolling Enabled Default (279):	0
	libinput Send Events Modes Available (259):	1, 1
	libinput Send Events Mode Enabled (260):	0, 0
	libinput Send Events Mode Enabled Default (261):	0, 0
	libinput Left Handed Enabled (280):	0
	libinput Left Handed Enabled Default (281):	0
	libinput Scroll Methods Available (282):	1, 0, 0
	libinput Scroll Method Enabled (283):	1, 0, 0
	libinput Scroll Method Enabled Default (284):	1, 0, 0
	libinput Click Methods Available (285):	1, 1
	libinput Click Method Enabled (286):	0, 1
	libinput Click Method Enabled Default (287):	0, 1
	Device Node (262):	"/dev/input/event8"
	Device Product ID (263):	1452, 567
Property 'libinput Natural Scrolling Enabled' changed.
	libinput Natural Scrolling Enabled (278):	0
Property 'libinput Natural Scrolling Enabled' changed.
	libinput Natural Scrolling Enabled (278):	0
Property 'libinput Natural Scrolling Enabled' changed.
	libinput Natural Scrolling Enabled (278):	0
Property 'libinput Natural Scrolling Enabled' changed.
	libinput Natural Scrolling Enabled (278):	0


This is 4 'natural-scrolling' changes (but is allways 0)
I have also changed 'tap-to-click' but there was no output here.

Comment 52 Fedora Blocker Bugs Application 2015-05-16 09:53:20 UTC
Proposed as a Blocker for 22-final by Fedora user pwalter using the blocker tracking app because:

 A very obvious regression from Fedora 21.

Comment 53 Hans de Goede 2015-05-16 10:00:18 UTC
Hi,

(In reply to optimisme from comment #51)
> xinput watch-props 12
> Device 'bcm5974':
> 	Device Enabled (139):	1
> 	Coordinate Transformation Matrix (141):	1.000000, 0.000000, 0.000000,
> 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
> 	libinput Tapping Enabled (274):	0
> 	libinput Tapping Enabled Default (275):	0
> 	libinput Accel Speed (276):	0.000000
> 	libinput Accel Speed Default (277):	0.000000
> 	libinput Natural Scrolling Enabled (278):	0
> 	libinput Natural Scrolling Enabled Default (279):	0
> 	libinput Send Events Modes Available (259):	1, 1
> 	libinput Send Events Mode Enabled (260):	0, 0
> 	libinput Send Events Mode Enabled Default (261):	0, 0
> 	libinput Left Handed Enabled (280):	0
> 	libinput Left Handed Enabled Default (281):	0
> 	libinput Scroll Methods Available (282):	1, 0, 0
> 	libinput Scroll Method Enabled (283):	1, 0, 0
> 	libinput Scroll Method Enabled Default (284):	1, 0, 0
> 	libinput Click Methods Available (285):	1, 1
> 	libinput Click Method Enabled (286):	0, 1
> 	libinput Click Method Enabled Default (287):	0, 1
> 	Device Node (262):	"/dev/input/event8"
> 	Device Product ID (263):	1452, 567
> Property 'libinput Natural Scrolling Enabled' changed.
> 	libinput Natural Scrolling Enabled (278):	0
> Property 'libinput Natural Scrolling Enabled' changed.
> 	libinput Natural Scrolling Enabled (278):	0
> Property 'libinput Natural Scrolling Enabled' changed.
> 	libinput Natural Scrolling Enabled (278):	0
> Property 'libinput Natural Scrolling Enabled' changed.
> 	libinput Natural Scrolling Enabled (278):	0
> 
> 
> This is 4 'natural-scrolling' changes (but is allways 0)
> I have also changed 'tap-to-click' but there was no output here.

Ok, so it seems that there still is some problem on the gnome / mutter side. Can you please try (from the cmdline):

xinput set-prop 12 "libinput Natural Scrolling Enabled" 1
xinput set-prop 12 "libinput Tapping Enabled" 1

Then do:

xinput list-props 12

And confirm that they are indeed 1 now, and the  try the touchpad and see if this gives you the desired touchpad behavior ? Once that is confirmed I think we can safely say there still is some issue on the gnome side of things.

Thanks,

Hans

Comment 54 Rodd Clarkson 2015-05-16 12:27:38 UTC
(In reply to Hans de Goede from comment #53)
> Hi,
> 
snip
> 
> xinput set-prop 12 "libinput Natural Scrolling Enabled" 1
> xinput set-prop 12 "libinput Tapping Enabled" 1
> 
> Then do:
> 
> xinput list-props 12
> 
> And confirm that they are indeed 1 now, and the  try the touchpad and see if
> this gives you the desired touchpad behavior ? Once that is confirmed I
> think we can safely say there still is some issue on the gnome side of
> things.
> 
> Thanks,
> 
> Hans

Hans,

I've tried this too (except with 11 instead of 12 which suites my set up and I can confirm that both Natural Scrolling and Tapping (including 3 finger taps (to middle click)) both work.

I appears the gnome settings app needs some work. ;-]

Comment 55 optimisme 2015-05-16 17:10:15 UTC
This is it, now it works...

$ xinput set-prop 12 "libinput Natural Scrolling Enabled" 1
$ xinput set-prop 12 "libinput Tapping Enabled" 1
$ xinput list-props 12
Device 'bcm5974':
	Device Enabled (139):	1
	Coordinate Transformation Matrix (141):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (274):	1
	libinput Tapping Enabled Default (275):	0
	libinput Accel Speed (276):	0.000000
	libinput Accel Speed Default (277):	0.000000
	libinput Natural Scrolling Enabled (278):	1
	libinput Natural Scrolling Enabled Default (279):	0
	libinput Send Events Modes Available (259):	1, 1
	libinput Send Events Mode Enabled (260):	0, 0
	libinput Send Events Mode Enabled Default (261):	0, 0
	libinput Left Handed Enabled (280):	0
	libinput Left Handed Enabled Default (281):	0
	libinput Scroll Methods Available (282):	1, 0, 0
	libinput Scroll Method Enabled (283):	1, 0, 0
	libinput Scroll Method Enabled Default (284):	1, 0, 0
	libinput Click Methods Available (285):	1, 1
	libinput Click Method Enabled (286):	0, 1
	libinput Click Method Enabled Default (287):	0, 1
	Device Node (262):	"/dev/input/event8"
	Device Product ID (263):	1452, 567

Comment 56 Rui Matos 2015-05-16 23:08:15 UTC
*** Bug 1202773 has been marked as a duplicate of this bug. ***

Comment 57 Hans de Goede 2015-05-17 09:50:51 UTC
*** Bug 1220024 has been marked as a duplicate of this bug. ***

Comment 58 Fedora Update System 2015-05-17 13:26:39 UTC
gnome-shell-3.16.2-1.fc22, mutter-3.16.2-1.fc22, clutter-1.22.2-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-8311/gnome-shell-3.16.2-1.fc22,mutter-3.16.2-1.fc22,clutter-1.22.2-2.fc22

Comment 59 Fedora Update System 2015-05-17 20:33:19 UTC
Package gnome-shell-3.16.2-1.fc22, mutter-3.16.2-1.fc22, clutter-1.22.2-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-3.16.2-1.fc22 mutter-3.16.2-1.fc22 clutter-1.22.2-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8311/gnome-shell-3.16.2-1.fc22,mutter-3.16.2-1.fc22,clutter-1.22.2-2.fc22
then log in and leave karma (feedback).

Comment 60 Rodd Clarkson 2015-05-17 23:52:56 UTC
Okay this fixes things with a couple of reservations.

1. When you open Mouse and Touchpad settings, natural scrolling is listed as 'on' but it's not scrolling naturally.  If you click it a couple of times it comes good (I'm guessing that the libinput setting still has it off, but clicking turns if off and then on.)

2.  Two finger scrolling works (as well as multi-finger clicks) but the button is still greyed out.

3. Should the Defaults for Natural Scrolling and Tapping be set to 0 or 1?  See below.

$ xinput list-props 11
Device 'DLL060A:00 06CB:2734':
	Device Enabled (136):	1
	Coordinate Transformation Matrix (138):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (273):	1
	libinput Tapping Enabled Default (274):	0
	libinput Accel Speed (275):	-0.094170
	libinput Accel Speed Default (276):	0.000000
	libinput Natural Scrolling Enabled (277):	1
	libinput Natural Scrolling Enabled Default (278):	0
	libinput Send Events Modes Available (254):	1, 1
	libinput Send Events Mode Enabled (255):	0, 0
	libinput Send Events Mode Enabled Default (256):	0, 0
	libinput Left Handed Enabled (279):	0
	libinput Left Handed Enabled Default (280):	0
	libinput Scroll Methods Available (281):	1, 0, 0
	libinput Scroll Method Enabled (282):	1, 0, 0
	libinput Scroll Method Enabled Default (283):	1, 0, 0
	libinput Click Methods Available (284):	1, 1
	libinput Click Method Enabled (285):	1, 0
	libinput Click Method Enabled Default (286):	1, 0
	Device Node (257):	"/dev/input/event12"
	Device Product ID (258):	1739, 10036

Comment 61 Hans de Goede 2015-05-18 07:09:02 UTC
Hi,

(In reply to Rodd Clarkson from comment #60)
> Okay this fixes things with a couple of reservations.
> 
> 1. When you open Mouse and Touchpad settings, natural scrolling is listed as
> 'on' but it's not scrolling naturally.  If you click it a couple of times it
> comes good (I'm guessing that the libinput setting still has it off, but
> clicking turns if off and then on.)

This could due to your gsettings not yet being in sync with the new schema. Does natural scrolling stick around after a logout / login now, or do you need to redo the toggle every login? If you need to redo it every toggle please file a new bug for this against mutter.

> 2.  Two finger scrolling works (as well as multi-finger clicks) but the
> button is still greyed out.

If you've a clickpad (no physical buttons) that is expected, we do not support edge scrolling on touchpads without physical buttons. It should show selected while being grayed out to make clear that this cannot be toggled, but it active. If it is not selected please file a new bug against control-center.

> 3. Should the Defaults for Natural Scrolling and Tapping be set to 0 or 1? 

Both should be 0. Natural scrolling is not how scrolling works by default on ibm compatible laptops. And for people who are not used to tap-to-click having it on is very annoying, where as for people who want it, it is easy to turn on.

Comment 62 Rodd Clarkson 2015-05-18 08:54:43 UTC
(In reply to Hans de Goede from comment #61)
> Hi,
> 
> (In reply to Rodd Clarkson from comment #60)
> > Okay this fixes things with a couple of reservations.
> > 
> > 1. When you open Mouse and Touchpad settings, natural scrolling is listed as
> > 'on' but it's not scrolling naturally.  If you click it a couple of times it
> > comes good (I'm guessing that the libinput setting still has it off, but
> > clicking turns if off and then on.)
> 
> This could due to your gsettings not yet being in sync with the new schema.
> Does natural scrolling stick around after a logout / login now, or do you
> need to redo the toggle every login? If you need to redo it every toggle
> please file a new bug for this against mutter.

Filed as:

https://bugzilla.redhat.com/show_bug.cgi?id=1222445

Comment 63 Rodd Clarkson 2015-05-18 09:01:59 UTC
(In reply to Hans de Goede from comment #61)
> Hi,
> 
> (In reply to Rodd Clarkson from comment #60)

> 
> > 2.  Two finger scrolling works (as well as multi-finger clicks) but the
> > button is still greyed out.
> 
> If you've a clickpad (no physical buttons) that is expected, we do not
> support edge scrolling on touchpads without physical buttons. It should show
> selected while being grayed out to make clear that this cannot be toggled,
> but it active. If it is not selected please file a new bug against
> control-center.

The trackpad I have has physical buttons for left and right click at the base, so something is wrong here.

Filed as https://bugzilla.redhat.com/show_bug.cgi?id=1222450

Comment 64 James Patterson 2015-05-18 11:15:08 UTC
Natural scrolling works again at least, but now my touchpad is not being ignore when I am typing :(

Comment 65 Hans de Goede 2015-05-18 12:21:14 UTC
Hi,

(In reply to James Patterson from comment #64)
> Natural scrolling works again at least, but now my touchpad is not being
> ignore when I am typing :(

Support for disable while typing has recently been added to libinput upstream. We should be able to do a libinput during the coming days or weeks adding this. Please file a separate bug for tracking this against component libinput. Please also let us know which model touchpad and laptop you've as we're enabling disable-while-typing on a per model basis.

Regards,

Hans

Comment 66 James Patterson 2015-05-18 13:37:58 UTC
(In reply to Hans de Goede from comment #65)
> Support for disable while typing has recently been added to libinput
> upstream. We should be able to do a libinput during the coming days or weeks
> adding this.

Yeah okay, it's in bug 1222547 now. I don't think you will get any end users adding their trackpad and laptop information in that bug, so I didn't either: can't we use the existing stuff from whatever we are replacing this time to get that information?

> Please file a separate bug for tracking this against component
> libinput. Please also let us know which model touchpad and laptop you've as
> we're enabling disable-while-typing on a per model basis.

Come on guys. Fedora (and Red Hat) has got to stop ripping out core components and replacing it with new stuff that doesn't work yet.

I'd like to be able to type on my keyboard please, without thinking about the trackpad randomly clicking around the screen.

New stuff is great and all but let's wait until it's better than the thing it replaces. Surely that has to be the criteria for whether to use something new.

Comment 67 Stephen Gallagher 2015-05-18 14:19:15 UTC
-1 Blocker. This doesn't violate any release criteria that I can find. There's no reason this cannot be fixed with a post-release patch, so I don't think it's worth holding up the release for this.

I have some concern about the experience on the live media, so I'd be willing to accept a very controlled bugfix as a Freeze Exception (but not a wild pull from libinput upstream).

Comment 68 Hans de Goede 2015-05-18 14:27:14 UTC
(In reply to Stephen Gallagher from comment #67)
> -1 Blocker. This doesn't violate any release criteria that I can find.
> There's no reason this cannot be fixed with a post-release patch, so I don't
> think it's worth holding up the release for this.
> 
> I have some concern about the experience on the live media, so I'd be
> willing to accept a very controlled bugfix as a Freeze Exception (but not a
> wild pull from libinput upstream).

Erm, this has nothing to do with libinput actually, most of the issues people are reporting in this bug are about not being able to change trackpad settings through gnome-control-center. This is fixed by the 3.16.2 gnome update + 1 isolated clutter patch. I've no idea what the status is wrt the gnome 3.16.2 update, but if that is going into f22 final, then we should really also take the isolated clutter fix in.

Comment 69 Kalev Lember 2015-05-18 14:34:40 UTC
(In reply to Stephen Gallagher from comment #67)
> -1 Blocker. This doesn't violate any release criteria that I can find.
> There's no reason this cannot be fixed with a post-release patch, so I don't
> think it's worth holding up the release for this.
> 
> I have some concern about the experience on the live media, so I'd be
> willing to accept a very controlled bugfix as a Freeze Exception (but not a
> wild pull from libinput upstream).

Yes, I'd be -1 blocker too, but would be nice to pull in https://admin.fedoraproject.org/updates/FEDORA-2015-8311/gnome-shell-3.16.2-1.fc22,mutter-3.16.2-1.fc22,clutter-1.22.2-2.fc22 as FE.

Comment 70 Stephen Gallagher 2015-05-18 14:45:57 UTC
Sorry, I misunderstood which component was to blame, but it doesn't change my answer :)

I'm -1 blocker (if this isn't fixed, it shouldn't delay the release). I'm +1 to a Freeze Exception on the condition that it's a carefully-selected change and not a wild rebase. Pulling in a rebased gnome-shell makes me somewhat nervous, but since we're already pulling in the rest of 3.16.2, I suppose it's just a drop in the bucket.

Comment 71 Petr Schindler 2015-05-18 16:25:34 UTC
Discussed at today's blocker review meeting [1]. 

This bug was rejected as blocker but accepted as Freeze Exception: This bug doesn't violate any Release Criteria, but it would be nice to get a fix in if one shows up.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-18

Comment 72 optimisme 2015-05-18 17:22:38 UTC
Works for me with last update:

$ uname -r
4.0.3-300.fc22.x86_64

$ rpm -q clutter mutter libinput xorg-x11-drv-libinput
clutter-1.22.2-2.fc22.x86_64
mutter-3.16.2-1.fc22.x86_64
libinput-0.15.0-1.fc22.x86_64
xorg-x11-drv-libinput-0.9.0-1.fc22.x86_64


Thanks!

Comment 73 Peter Hutterer 2015-05-19 01:12:00 UTC
(In reply to James Patterson from comment #66)
> Yeah okay, it's in bug 1222547 now. I don't think you will get any end users
> adding their trackpad and laptop information in that bug, so I didn't
> either: can't we use the existing stuff from whatever we are replacing this
> time to get that information?

no. the "existing stuff" was an external daemon that was started by gnome-settings-daemon (or some script du jour) and kept monitoring the keyboard. Aside from being impossible in a Wayland world, it's a hack and we can do better.

It's also not needed on all touchpads, some touchpads give us finger width information that would allow us to detect palms without having to lock down the touchpad for some timeout. But that requires feedback from end users.

Despite whatever you may read on the interwebs, we're not working against you, we're trying to make things better long term.

Comment 74 James Patterson 2015-05-19 08:50:24 UTC
> Despite whatever you may read on the interwebs

This is insulting.

Of course you are aiming for something better long term. My lament was that you are constantly ripping out working functionality before the better functionality is ready. That is the problem, not anything else.

Comment 75 Andrew Malcolmson 2015-05-19 17:10:30 UTC
GCC now successfully enables tap to click and two finger scrolling.  Trackpad is AlpsPS/2 ALPS GlidePoint.

clutter.x86_64                          1.22.2-2.fc22            
libinput.x86_64                         0.15.0-2.fc22            
mutter.x86_64                           3.16.2-1.fc22     
xorg-x11-drv-libinput.x86_64            0.9.0-1.fc22  

Thanks here too!

Comment 76 Peter Hutterer 2015-05-19 22:46:13 UTC
*** Bug 1223070 has been marked as a duplicate of this bug. ***

Comment 77 bztdlinux 2015-05-19 23:23:02 UTC
Playing with  my W540 a bit more, in both modes, the trackpoint right-click zone works (it's unusably bad, but it's there if you try enough times). However, the trackpad has no lower marked soft button, so I would expect the default to be set as two-finger right click style.

Is there a libinput quirks database that these odd models can be added to?

Comment 78 Peter Hutterer 2015-05-21 03:13:16 UTC
(In reply to James Patterson from comment #74)
> Of course you are aiming for something better long term. My lament was that
> you are constantly ripping out working functionality before the better
> functionality is ready. That is the problem, not anything else.

Sometimes new things seem good enough until you expose it to a wide variety of users and hw. Palm detection for example has worked for me perfectly for months but I only have access to a limited number of devices.

(In reply to bztdlinux from comment #77)
> Playing with  my W540 a bit more, in both modes, the trackpoint right-click
> zone works (it's unusably bad, but it's there if you try enough times).
> However, the trackpad has no lower marked soft button, so I would expect the
> default to be set as two-finger right click style.
> 
> Is there a libinput quirks database that these odd models can be added to?

Not really. We tend to stick with whatever the manufacturer's intended defaults are but sometimes it's blurry. On apples and Chromebooks for example we have clickfinger as default, the rest is software button areas. There's a lot of room for interpretation everywhere, so while we change the defaults on some models I think on the Lenovo's we'll leave it as-is given that this was the default we've had for ages.

fwiw, if the right software button doesn't work as expected, please file a separate bug and assign it to me.

Comment 79 Fedora Update System 2015-05-21 18:45:02 UTC
gnome-shell-3.16.2-1.fc22, mutter-3.16.2-1.fc22, clutter-1.22.2-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 80 mlaverdiere 2015-05-24 17:39:10 UTC
I'm on Fedora 22 since Alpha and I did saw the progress made on this bug (thanks to devs), but sill, the trackpad (in my case at least) continue to feels quirky, when compared to Fedora 21 (not to mention other desktop environments and/or distros).  As an example of what is still feeling not right, left clicking too closed from the middle of the trackpad is regularly interpreted as right click. Not to mention that fluid/smooth scrolling (which is not the same thing as natural scrolling if I understand well) has disappeared.  

This is not a showstopper as it used to be at earlier Alpha stage, but it is still generating an awkward (somewhat frustrating...) experience as far as I'm concerned.

Comment 81 Peter Hutterer 2015-06-02 03:26:57 UTC
mlavidiere: this bug has been fixed (the bug title is a bit too generic). please file a new bug instead, makes it easier to keep track.


goes for everybody else too, please don't add to this bug here, file a new one and the chances of it getting fixed are much higher.


Note You need to log in before you can comment on or make changes to this bug.