Bug 1202788 - There is no error prompt when set the io throttling parameters FOO_max without FOO and iops_size without iops
Summary: There is no error prompt when set the io throttling parameters FOO_max withou...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: 7.3
Assignee: Stefan Hajnoczi
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1342330 RHV4.1PPC
TreeView+ depends on / blocked
 
Reported: 2015-03-17 12:51 UTC by Gu Nini
Modified: 2016-11-07 20:20 UTC (History)
12 users (show)

Fixed In Version: qemu-kvm-rhev-2.5.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 20:20:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Gu Nini 2015-03-17 12:51:38 UTC
Description of problem:
When boot up a guest in qemu cmd with the FOO_max while no the corresponding FOO(such as with bps_max while without bps), the guest could boot up and there is no error prompt, but the FOO_max takes no effect; and after the guest boot up, when set the FOO_max without FOO in qmp, it can be a success and the FOO_max also takes no effect. And there is the same problem on iops_size(while no iops).

Version-Release number of selected component (if applicable):
Host kernel: 3.10.0-229.el7.ppc64
Guest kernel: 3.10.0-229.el7.pc64/3.10.0-229.ael7b.ppc64le
Qemu-kvm-rhev:
qemu-kvm-common-rhev-2.2.0-5.el7.ppc64
qemu-kvm-tools-rhev-2.2.0-5.el7.ppc64
qemu-img-rhev-2.2.0-5.el7.ppc64
ipxe-roms-qemu-20130517-6.gitc4bce43.el7.noarch
qemu-kvm-rhev-2.2.0-5.el7.ppc64
qemu-kvm-rhev-debuginfo-2.2.0-5.el7.ppc64

How reproducible:
100%

Steps to Reproduce:
Please refer to case https://tcms.engineering.redhat.com/case/469227/?from_plan=15759

Actual results:


Expected results:


Additional info:

Comment 2 Xiaoqing Wei 2015-08-10 02:59:23 UTC
met this on x86_64
qemu-kvm-rhev-2.3.0-15.el7.x86_64

and C#0 using ppc, change hardware field to all

Comment 3 Stefan Hajnoczi 2015-09-08 09:40:01 UTC
Deferring to RHEL 7.3.  We have a fix upstream but this bug is not critical (blocker/exception).  This is a QEMU command-line issue which libvirt users will not see.

Comment 5 Stefan Hajnoczi 2016-01-29 14:01:19 UTC
Fixed in upstream version QEMU 2.5.

Comment 7 Gu Nini 2016-05-20 07:01:57 UTC
Stefan,

I have done some test on latest qemu-kvm-rhev version of rhel7.3, it's found the 'FOO_max without FOO' issue is fixed well, while the 'iops_size without iops' one is not. Should it be fixed in rhel7.3? If so, the bug should be reopened.


Thanks!
Nini Gu

Comment 8 Stefan Hajnoczi 2016-06-02 00:27:06 UTC
(In reply to Gu Nini from comment #7)
> I have done some test on latest qemu-kvm-rhev version of rhel7.3, it's found
> the 'FOO_max without FOO' issue is fixed well, while the 'iops_size without
> iops' one is not. Should it be fixed in rhel7.3? If so, the bug should be
> reopened.

Let's make iops_size a separate BZ.  Upstream QEMU does not check that iops/iops_rd/iops_wr has been set if iops_size is used.  A new patch will be required.

Comment 9 Gu Nini 2016-06-03 02:03:25 UTC
(In reply to Stefan Hajnoczi from comment #8)
> 
> Let's make iops_size a separate BZ.  Upstream QEMU does not check that
> iops/iops_rd/iops_wr has been set if iops_size is used.  A new patch will be
> required.

Report bz 1342330 for the iops_size one. And verify this bug on qemu-kvm-rhev-2.6.0-4.el7.x86_64.

Comment 11 errata-xmlrpc 2016-11-07 20:20:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.