Bug 1342330 - There is no error prompt when set the io throttling parameters iops_size without iops
Summary: There is no error prompt when set the io throttling parameters iops_size with...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Stefan Hajnoczi
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1202788
Blocks: RHV4.1PPC
TreeView+ depends on / blocked
 
Reported: 2016-06-03 02:00 UTC by Gu Nini
Modified: 2016-11-07 21:14 UTC (History)
7 users (show)

Fixed In Version: qemu-kvm-rhev-2.6.0-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 21:14:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Gu Nini 2016-06-03 02:00:26 UTC
Description of problem:
When boot up a guest in qemu cmd with io throttling parameter iops_size while without iops, the guest could boot up and there is no error prompt, but the iops_size takes no effect; and after the guest boot up, when set iops_size without iops in qmp, it can be a success, however there is no the iops_size parameter checked from qmp cmd '{ "execute": "query-block"}'. 

Version-Release number of selected component (if applicable):
Host kernel: 3.10.0-406.el7.x86_64
Qemu-kvm-rhev: qemu-kvm-rhev-2.6.0-4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Stefan Hajnoczi 2016-06-08 09:26:21 UTC
Upstream has merged the patch.  Backport sent.

Comment 3 Miroslav Rezanina 2016-06-15 13:08:42 UTC
Fix included in qemu-kvm-rhev-2.6.0-6.el7

Comment 5 Gu Nini 2016-06-21 09:22:06 UTC
Verify the bug on following sw versions:

Host kernel: 3.10.0-433.el7.x86_64
Guest kernel: 3.10.0-433.el7.x86_64
Qemu-kvm-rhev: qemu-kvm-rhev-2.6.0-7.el7.x86_64


Now there is following error prompt:
 
# /usr/libexec/qemu-kvm -name rhel7.3 -enable-kvm -m 4G -smp 4 -uuid ae361e8d-288b-4e70-8783-bda0d450ce38 -nodefconfig --nodefaults -boot order=cd,menu=on -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=03 -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,format=qcow2,file=/home/kvm_autotest_root/images/RHEL-Server-7.3-64-virtio-scsi.qcow2,iops_size=4096 -device scsi-hd,id=image1,drive=drive_image1,bootindex=0 -device nec-usb-xhci,id=xhci -vnc 0.0.0.0:14 -monitor stdio -netdev tap,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:52:5a:30:2e:61,bus=pci.0,addr=0x7 -chardev socket,id=qmpmonitor1,path=/tmp/monitor1,server,nowait -mon chardev=qmpmonitor1,mode=control -vga std -object rng-random,id=rng0,filename=/dev/random -device virtio-rng-pci,rng=rng0,id=rng0 -device usb-tablet,id=tablet0
qemu-kvm: -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,format=qcow2,file=/home/kvm_autotest_root/images/RHEL-Server-7.3-64-virtio-scsi.qcow2,iops_size=4096: iops size requires an iops value to be set

# nc -U /tmp/monitor1
{"QMP": {"version": {"qemu": {"micro": 0, "minor": 6, "major": 2}, "package": " (qemu-kvm-rhev-2.6.0-7.el7)"}, "capabilities": []}}
{"execute":"qmp_capabilities"}
{"return": {}}
{ "execute": "block_set_io_throttle", "arguments": { "device": "drive_image1","bps":0,"bps_rd":0,"bps_wr":0,"iops":0,"iops_rd":0,"iops_wr":0,"iops_size":4096}}
{"error": {"class": "GenericError", "desc": "iops size requires an iops value to be set"}}

Comment 7 errata-xmlrpc 2016-11-07 21:14:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.