Bug 1203385 - Please include cx18 firmware in the linux-firmware package
Summary: Please include cx18 firmware in the linux-firmware package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1203379 1211020 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-18 18:01 UTC by Simon Farnsworth
Modified: 2015-11-12 05:32 UTC (History)
8 users (show)

Fixed In Version: linux-firmware-20150410-47.gitec89525b.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-23 16:04:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Simon Farnsworth 2015-03-18 18:01:34 UTC
Description of problem:

cx18-firmware has been retired in Fedora 21 upwards. It contained the following 3 files, which are also in the upstream linux-firmware git repo:

v4l-cx23418-apu.fw
v4l-cx23418-cpu.fw
v4l-cx23418-dig.fw

I've offered to maintain cx18-firmware, but Josh Boyer on the fedora-devel list pointed out:

These files are included in the upstream linux-firmware git repo.

[jwboyer@lando linux-firmware]$ git log v4l-cx23418-*
commit a699eb6997f21d4fc88526754824e90417749db6
Author: Mauro Carvalho Chehab <mchehab@redhat.com>
Date:   Fri Apr 3 07:33:20 2009 -0300

    Add firmwares for three Conexant chipsets for cx18, cx23885 and cx23840

    Add firmwares for those V4L/DVB devices:
        CX23418 PCI Broadcast A/V with MPEG encoder
        CX25843 sideport Broadcast A/V decoder
        CX23885 PCI Express Broadcast A/V decoder

    Signed-off-by: Mauro Carvalho Chehab <mchehab@redhat.com>


It would probably make a lot more sense just to get them included in
the Fedora linux-firmware package.

josh

Version-Release number of selected component (if applicable):

linux-firmware-20150213-43.git17657c35.fc21.noarch


If you could add these three firmware files to linux-firmware, this would let me close bug #1203379.

Thanks,

Simon

Comment 1 Josh Boyer 2015-03-18 18:02:59 UTC
I'll get to this tomorrow most likely.

Comment 2 Simon Farnsworth 2015-04-09 09:59:53 UTC
Is there anything I can do to progress this bug?

Comment 3 Josh Boyer 2015-04-09 13:49:02 UTC
My apologies.  I fixed this in git quite a while ago, but haven't done an update yet.  I will try and do so today.

Comment 4 Fedora Update System 2015-04-10 17:38:59 UTC
linux-firmware-20150410-48.gitec89525b.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/linux-firmware-20150410-48.gitec89525b.fc22

Comment 5 Fedora Update System 2015-04-10 17:40:30 UTC
linux-firmware-20150410-46.gitec89525b.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/linux-firmware-20150410-46.gitec89525b.fc21

Comment 6 Fedora Update System 2015-04-10 17:44:17 UTC
linux-firmware-20150410-46.gitec89525b.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/linux-firmware-20150410-46.gitec89525b.fc20

Comment 7 Fedora Update System 2015-04-11 09:06:19 UTC
Package linux-firmware-20150410-46.gitec89525b.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing linux-firmware-20150410-46.gitec89525b.fc21'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5989/linux-firmware-20150410-46.gitec89525b.fc21
then log in and leave karma (feedback).

Comment 8 Freddy Willemsen 2015-04-11 13:39:32 UTC
This package conflicts with ivtv-firmware now as a result of this inclusion. Is that to be expected? I have no idea honestly why ivtv-firmware is installed (on all my systems that is) in the first place.

Comment 9 Nerijus Baliūnas 2015-04-11 15:27:51 UTC
Exact error:
file /usr/lib/firmware/v4l-cx25840.fw from install of linux-firmware-20150410-46.gitec89525b.fc21.noarch conflicts with file from package ivtv-firmware-2:20080701-26.noarch

Comment 10 Josh Boyer 2015-04-12 13:53:18 UTC
*** Bug 1211020 has been marked as a duplicate of this bug. ***

Comment 11 Josh Boyer 2015-04-12 13:57:08 UTC
As many have noted, there's a conflict now.  Sigh.

I've pulled the updates from updates-testing until I can get it fixed.

Comment 12 Fedora Update System 2015-04-14 15:02:30 UTC
linux-firmware-20150410-49.gitec89525b.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/linux-firmware-20150410-49.gitec89525b.fc22

Comment 13 Fedora Update System 2015-04-14 15:03:49 UTC
linux-firmware-20150410-47.gitec89525b.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/linux-firmware-20150410-47.gitec89525b.fc21

Comment 14 Fedora Update System 2015-04-14 15:05:16 UTC
linux-firmware-20150410-47.gitec89525b.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/linux-firmware-20150410-47.gitec89525b.fc20

Comment 15 Peter H. Jones 2015-04-16 22:17:33 UTC
linux-firmware-20150410-47.gitec89525b.fc20.noarch installed fine on an FC20 system.
ivtv-firmware-20080701-26.noarch is still present.

Comment 16 Fedora Update System 2015-04-18 09:45:14 UTC
Package linux-firmware-20150410-47.gitec89525b.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing linux-firmware-20150410-47.gitec89525b.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6333/linux-firmware-20150410-47.gitec89525b.fc20
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2015-04-23 16:04:17 UTC
linux-firmware-20150410-49.gitec89525b.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2015-04-23 16:10:25 UTC
linux-firmware-20150410-47.gitec89525b.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2015-05-10 23:33:16 UTC
linux-firmware-20150410-47.gitec89525b.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 David Ward 2015-05-15 23:40:47 UTC
This created a conflict on Fedora 20 which still has cx18-firmware. See bug 1222164.

Comment 21 Simon Farnsworth 2015-05-17 19:18:45 UTC
*** Bug 1203379 has been marked as a duplicate of this bug. ***

Comment 22 D. Hugh Redelmeier 2015-11-12 05:32:51 UTC
I just installed F23 on a machine with one of these tuner cards.  Booting took a long time.  When I looked at dmesg output, I saw:

[   10.524043] ivtv 0000:04:01.0: Direct firmware load for v4l-cx2341x-enc.fw failed with error -2
[   10.524050] ivtv1: Unable to open firmware v4l-cx2341x-enc.fw (must be 376836 bytes)
[   10.524053] ivtv1: Did you put the firmware in the hotplug firmware directory?
[   10.524055] ivtv1: Retry loading firmware
[  126.916248] audit_printk_skb: 33 callbacks suppressed

so the system spun its wheels for almost two minutes looking for firmware that is no longer automatically installed.  The error message does not really give me enough information to know that all I have to do is "dnf install ivtv-firmware".

Is there a way that we can make this more discoverable?

[Sorry for piggybacking on an old bug.  I don't think that the F23 situation is a bug but google will direct people with my problem to this bug report.]


Note You need to log in before you can comment on or make changes to this bug.