Bug 1222164 - Conflict with linux-firmware and cx18-firmware on Fedora 20
Summary: Conflict with linux-firmware and cx18-firmware on Fedora 20
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 20
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-15 23:23 UTC by David Ward
Modified: 2015-06-09 15:18 UTC (History)
3 users (show)

Fixed In Version: linux-firmware-20150521-48.git3161bfa4.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-28 12:00:48 UTC
Type: Bug


Attachments (Terms of Use)
Patch for linux-firmware package git repository (1.17 KB, patch)
2015-05-16 02:25 UTC, David Ward
no flags Details | Diff
Patch for linux-firmware package git repository (1.17 KB, application/mbox)
2015-05-16 03:15 UTC, David Ward
no flags Details

Description David Ward 2015-05-15 23:23:11 UTC
Bug 1203385 updated the linux-firmware package for Fedora 20, which still has the cx18-firmware package. Now there is a conflict when trying to update linux-firmware:

Transaction check error:
  file /usr/lib/firmware/v4l-cx23418-apu.fw from install of linux-firmware-20150410-47.gitec89525b.fc20.noarch conflicts with file from package cx18-firmware-20080628-8.noarch
  file /usr/lib/firmware/v4l-cx23418-cpu.fw from install of linux-firmware-20150410-47.gitec89525b.fc20.noarch conflicts with file from package cx18-firmware-20080628-8.noarch
  file /usr/lib/firmware/v4l-cx23418-dig.fw from install of linux-firmware-20150410-47.gitec89525b.fc20.noarch conflicts with file from package cx18-firmware-20080628-8.noarch


As a result it has broken pungi's ability to compose a Fedora 20 image from scratch:

template command error in runtime-install.tmpl:
  run_pkg_transaction
  YumTestTransactionError: Test Transaction Errors:   file /usr/lib/firmware/v4l-cx23418-apu.fw conflicts between attempted installs of linux-firmware-20150410-47.gitec89525b.fc20.noarch and cx18-firmware-20080628-8.noarch
  file /usr/lib/firmware/v4l-cx23418-cpu.fw conflicts between attempted installs of linux-firmware-20150410-47.gitec89525b.fc20.noarch and cx18-firmware-20080628-8.noarch
  file /usr/lib/firmware/v4l-cx23418-dig.fw conflicts between attempted installs of linux-firmware-20150410-47.gitec89525b.fc20.noarch and cx18-firmware-20080628-8.noarch


(I've already tried explicitly excluding the cx18-firmware package in the kickstart file, but it is getting pulled in during a later stage.)

Should you use 'Conflicts: cx18-firmware' in the linux-firmware package?

Comment 1 David Ward 2015-05-16 02:25:36 UTC
Created attachment 1026135 [details]
Patch for linux-firmware package git repository

or rather than Conflicts,

Obsoletes: cx18-firmware < 20080628-9

A patch with this change is attached for the linux-firmware package git repository. I tested that this resolves the issues with both yum system updates and pungi composes.

Comment 2 David Ward 2015-05-16 03:15:28 UTC
Created attachment 1026136 [details]
Patch for linux-firmware package git repository

Actually cx18-firmware-20080628-9 exists in Koji for Fedora 21 (during development), so it is probably better to use

Obsoletes: cx18-firmware < 20080628-10

Comment 3 Fred Houweling 2015-05-16 23:45:41 UTC
I can confirm that the transaction error on my Fedora 20 server existed as follows:
Transaction check error:
  file /usr/lib/firmware/v4l-cx23418-apu.fw from install of linux-firmware-20150410-47.gitec89525b.fc20.noarch conflicts with file from package cx18-firmware-20080628-8.noarch
  file /usr/lib/firmware/v4l-cx23418-cpu.fw from install of linux-firmware-20150410-47.gitec89525b.fc20.noarch conflicts with file from package cx18-firmware-20080628-8.noarch
  file /usr/lib/firmware/v4l-cx23418-dig.fw from install of linux-firmware-20150410-47.gitec89525b.fc20.noarch conflicts with file from package cx18-firmware-20080628-8.noarch

I resolved it by running:

yum remove cx18-firmware.noarch

A subsequent 'yum update' then succeeded.

Comment 4 David Ward 2015-05-17 15:04:59 UTC
@Fred: that is a workaround for an installed system, but using pungi to compose an ISO image is still broken because of this issue. It will try to pull in both packages, even if you explicity exclude cx18-firmware in the kickstart script. An update to the linux-firmware package is still needed to address this.

Comment 5 David Ward 2015-05-17 15:19:05 UTC
@Fred: I expect that network installations will fail because of this issue as well.

Comment 6 Josh Boyer 2015-05-21 13:38:57 UTC
Thanks for the patch.  I had to tweak it slightly but I've added the conflicts to the spec on all branches.  An update will be coming shortly.

Comment 7 Fedora Update System 2015-05-21 14:05:04 UTC
linux-firmware-20150521-52.git3161bfa4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/linux-firmware-20150521-52.git3161bfa4.fc22

Comment 8 Fedora Update System 2015-05-21 14:06:53 UTC
linux-firmware-20150521-48.git3161bfa4.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/linux-firmware-20150521-48.git3161bfa4.fc21

Comment 9 Fedora Update System 2015-05-21 14:07:26 UTC
linux-firmware-20150521-48.git3161bfa4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/linux-firmware-20150521-48.git3161bfa4.fc20

Comment 10 Fedora Update System 2015-05-22 02:31:45 UTC
Package linux-firmware-20150521-52.git3161bfa4.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing linux-firmware-20150521-52.git3161bfa4.fc22'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8693/linux-firmware-20150521-52.git3161bfa4.fc22
then log in and leave karma (feedback).

Comment 11 David Ward 2015-05-22 19:42:16 UTC
This update resolves the issue. Thanks!

Comment 12 Fedora Update System 2015-05-28 12:00:48 UTC
linux-firmware-20150521-52.git3161bfa4.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-06-09 15:00:45 UTC
linux-firmware-20150521-48.git3161bfa4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2015-06-09 15:18:39 UTC
linux-firmware-20150521-48.git3161bfa4.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.