Bug 12034 - Error mounting md0: Invalid argument
Error mounting md0: Invalid argument
Status: CLOSED DUPLICATE of bug 13544
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-09 13:04 EDT by Michael McConachie
Modified: 2013-09-02 01:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-20 21:13:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael McConachie 2000-06-09 13:04:00 EDT
Traceback:

File "/usr/bin/anaconda", line 392, in ? intf.run(todo, test = test)
File "/usr/lib/anaconda/text.py", line 348, in __call__
todo.upgradeFindPackages (root)
File "/usr/lib/anaconda/todo.py", line 784, in upgradeFindPackages
self.fstab.mountFilesystems (self.instpath)
File "/usr/lib/anaconda/fstab.py", line 633, in mountFilesystems raise
SystemError, (errno, msg) SystemError: (22, 'Invalid argument')


Install Log:

going to insmod vfat.o (path is NULL)
got mount list [('/', 'sda1', 'ext2', 0, 0)]
got mount list [('/', 'sda1', 'ext2', 0, 0), ('/usr', 'sda3', 'ext2', 0,
0)]
got mount list [('/', 'sda1', 'ext2', 0, 0), ('/usr', 'sda3', 'ext2', 0,
0)]
got mount list [('/', 'sda1', 'ext2', 0, 0), ('/usr', 'sda3', 'ext2', 0,
0), ('/usr/local', 'sdf1', 'ext2', 0, 0)]
got mount list [('/', 'sda1', 'ext2', 0, 0), ('/home', 'sdg1', 'ext2', 0,
0), ('/usr', 'sda3', 'ext2', 0, 0), ('/usr/local', 'sdf1', 'ext2', 0, 0)]
got mount list [('/', 'sda1', 'ext2', 0, 0), ('/home', 'sdg1', 'ext2', 0,
0), ('/home/mux', 'md0', 'ext2', 0, 0), ('/usr', 'sda3', 'ext2', 0, 0),
('/usr/local', 'sdf1', 'ext2', 0, 0)]

System Log:

<4>raid0: Allocating 8 bytes for hash.
<6>md: updating md0 RAID superblock on device
<4>sdd1 [events: 0000004b] (write) sdd1's sb offset 510848
<4>sdc1 [events: 0000004b] (write) sdc1's sb offset 510848
<4>sdb1 [events: 0000004b] (write) sdb1's sb offset 510848
<4>.
<4>... autorun DONE.
<4>EXT2-fs warnming: maximal mount count reached, running e2fsck is
recommended
<4>marking sb clean...
<6>md: updating md0 RAID superblock on device
<4>sdd1 [events: 0000003c] (write) sdd1's sb offset 510848
<4>sdc1 [events: 0000003c] (write) sdc1's sb offset 510848
<4>sdb1 [events: 0000003c] (write) sdb1's sb offset 510848
<4>.
<4>unbind<sdd1,2>
<4>export_rdev(sdd1)
<4>unbind<sdc1,0>
<4>export_rdev(sdc1)
<4>unbind<sdb1,0>
<4>export_rdev(sdb1)
<6>md0 stopped.
<4>EXT2-fs warning: maximal mount count reached, running e2fsck is
recommended
<3>Bad md_map in ll_rw_block
<4>EXT2-fs: unable to read superblock

/etc/fstab:
/dev/sda1               /                       ext2    defaults        1 1
/dev/sda3               /usr                    ext2    defaults        1 2
/dev/sda2               swap                    swap    defaults        0 0
#/dev/sdf1               /home                   ext2    defaults        1
2
/dev/sdf1               /usr/local              ext2    defaults        1 2
/dev/sdg1               /home                   ext2    defaults        1 2
#/dev/sdb1               /mnt/oldlocal           ext2    defaults        1
2
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,ro 0 0
/dev/fd0                /mnt/floppy             ext2    noauto,owner    0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/pts                devpts  gid=5,mode=620  0 0
/dev/md0                /home/mux               ext2    defaults0 0

(removed the commented out entries; same result)

Interestingly enough, a network install lastnight from winston/i386/ worked
after a couple tries.

Commenting out /dev/md0 has the result of the installation continuing
Comment 1 Michael Fulbright 2000-06-22 14:52:33 EDT
Passed to test lab for verification.
Comment 2 Brock Organ 2000-06-23 16:11:37 EDT
does winston beta2 solve this problem ...?
Comment 3 Michael McConachie 2000-06-29 13:41:47 EDT
Nope, same results.  The log entries even look identical (except for the
increment increase for sdx1 events).

    --gleep
Comment 4 Glen Foster 2000-07-18 14:23:44 EDT
This defect is considered MUST-FIX for Winston Beta-5
Comment 5 Michael Fulbright 2000-07-20 21:13:36 EDT

*** This bug has been marked as a duplicate of 13544 ***
Comment 6 Brock Organ 2000-08-17 09:29:38 EDT
Date: Wed, 16 Aug 2000 18:03:23 -0400 (EDT)                                     
From: Michael McCormack <michael@redhat.com>                                    
To: Brock Organ <borgan@redhat.com>                                             
Subject: Bug
#12034                                                                                                                                              
I went to the bug I had opened but discovered that I no longer have             
permission to view it . . . Heh.                                                 

Anyway, it looks like the latest version of pinstripe has fixed the             
problem with the raid array not being recognized right in fstab.                 

--gleep
Comment 7 Brock Organ 2000-08-17 09:30:32 EDT
Michael, you should be able to view this bug now ... :)

Note You need to log in before you can comment on or make changes to this bug.