Bug 13544 - Installer Fails to Upgrade When Software RAID Drive Present
Installer Fails to Upgrade When Software RAID Drive Present
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Brock Organ
Winston rc1
:
: 12034 13191 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-06 15:40 EDT by Thornton Prime
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-15 15:08:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thornton Prime 2000-07-06 15:40:49 EDT
Description pretty much says it all.

The installer fails to upgrade because it can't mount /dev/md0 where
/dev/md0 is a raid5 array set up with the detect-superblock on.
Comment 1 Glen Foster 2000-07-18 16:03:29 EDT
This defect is considered MUST-FIX for Winston Beta-5
Comment 2 Michael Fulbright 2000-07-20 21:13:34 EDT
*** Bug 12034 has been marked as a duplicate of this bug. ***
Comment 3 Michael Fulbright 2000-07-20 21:14:03 EDT
*** Bug 13191 has been marked as a duplicate of this bug. ***
Comment 4 Erik Troan 2000-07-21 18:31:45 EDT
Fixed (finally!) for beta 5.
Comment 5 Thornton Prime 2000-07-27 12:47:04 EDT
The installer correctly identifies and upgrades with the RAID resent, but didn't
add the raid kernel modules to the initrd. The system installed fine, but did
not boot.
Comment 6 Glen Foster 2000-07-30 15:04:34 EDT
This defect is considered MUST-FIX for Winston Release-Candidate #1
Comment 7 Erik Troan 2000-07-31 12:55:34 EDT
Have you seen this with beta 5? We fixed bugs in here, and it both works fine in
our labs and we've gotten confirmations from beta testers that this is fixed.

If you're still seeing this, please send a copy of your fstab.
Comment 8 Thornton Prime 2000-08-03 16:51:42 EDT
Looks fixed. Thanks.

I did do an upgrade from beta-3 to (what I thought was) beta-5 and had problems,
but now I can't recreate, so I'm marking as WORKSFORME.
Comment 9 Brock Organ 2000-08-07 11:04:41 EDT
verified fix in post-pinstripe internal build ... thanks for the report!
Comment 10 Thornton Prime 2000-08-11 13:20:07 EDT
Sorry I had to re-open. I just duplicated again with RC1.

I did an upgrade of beta4 -> rc1 over FTP. It installed and upgraded fine, but
when booting in for the first time it can't find /dev/md0. Apparently the raid
software drivers didn't get into the initrd, though the scsi drivers did, so it
failed in the fsck check when it couldn't fsck /dev/md0

I fixed the problem by building a new initrd and re-running lilo.

on a side note, mkinitrd should give better error messages if it can't find it's
components ... I had forgotten to mount /usr and running mkinitrd just produced
a bunch of shell errors. It would be best to add a little sanity at the top to
check for the stuff it needs.
Comment 11 Brock Organ 2000-08-14 11:18:18 EDT
Are you able to duplicate this error using a 6.2 -> RC1 upgrade path ...? 

Beta->Beta upgrade path bugs aren't as crucial as previous release -> beta
upgrades, so please let us know if you have this problem using a non-beta
release such as 6.2 ...

I did not have this problem with an upgrade from a minimum 6.2 install ->
Winston RC-1 in test ...
Comment 12 Brock Organ 2000-08-15 15:05:19 EDT
Please reopen this issue if you are having trouble with 6.2 (or any other
previous non-beta release)

Note You need to log in before you can comment on or make changes to this bug.