Bug 120362 - FC2 release notes -- Random suggestions
FC2 release notes -- Random suggestions
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Bailey
:
Depends On:
Blocks: fc-relnotes-blocker
  Show dependency treegraph
 
Reported: 2004-04-07 20:43 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 17:15:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-04-07 20:43:16 EDT
For the Hardware section....

NPTL not available in i586 and lower architectures.  This includes VIA
and K6 processors, and most often causes problems for certain db4
applications like Subversion.


perhaps under the kernel notes...

Experimental DPT I2O SCSI RAID support
Fedora Core 2 Test3 (x86 only) has activated the kernel-2.6 generic
I2O layer for stability trials of Adaptec DPT I2O based SCSI hardware
RAID controllers.  This controller was previously supported 
in the 2.4 kernel series by the dpt_i2o driver, which is no longer
operational.  Testing should be done on Anaconda installation,
partitioning, and stress tests with heavy workloads if possible.  If
these test results prove to be positive, I2O may be kept for the final
release of Fedora Core 2.  Unfortunately at the time of this writing
x86-64 native I2O has not yet been fully stabilized, so it has not
been activated within the distribution.  Help is needed on the
linux-scsi mailing list with the known x86-64 blockers.

http://i2o.shadowconnect.com
For more details about I2O development please visit the I2O Home Page.
 Please discuss I2O specific topics at the linux-scsi mailing list.



gcc32 — *** FIXME -- need reason ***
It was required only to compile the 2.4 kernel.  We no longer ship a
2.4 kernel and the 
distribution relies on 2.6 specific features.

ipchains — *** FIXME -- need reason ***
Obsoleted by iptables.
Comment 1 Ed Bailey 2004-04-07 21:58:18 EDT
(I'm going to take this a bit at a time...)

Fixed reasons for gcc32 and ipchains -- thanks!

I'll get to the other ones shortly...
Comment 2 Warren Togami 2004-04-08 17:34:53 EDT
Updated Notes:

Experimental DPT I2O SCSI RAID support
Fedora Core 2 Test3 (x86 & x86-64) has activated the kernel-2.6
generic I2O layer for stability trials of Adaptec DPT I2O based SCSI
hardware RAID controllers.  This controller was previously supported 
in the 2.4 kernel series by the dpt_i2o driver, which is no longer
operational.  Testing should be done on Anaconda installation,
partitioning, and stress tests with heavy workloads if possible, and
only on non-production hardware because of the risk for data loss. If
these test results prove to be positive, I2O may be kept for the final
release of Fedora Core 2.  Note that the i2o_scsi module has been
disabled on x86-64 because it is known to cause deadlocks and crashes,
however RAID capability with /dev/i2o/hdX devices has worked in
initial testing.

http://i2o.shadowconnect.com
For more details about I2O development please visit the I2O Home Page.
Please discuss I2O specific topics at the linux-scsi mailing list.
Comment 3 Ed Bailey 2004-04-13 15:28:16 EDT
Ok, added the following for the NPTL entry:

NOTE: NPTL is not available in i586 and lower-end architectures. This
includes VIA and K6 processors, and most often causes problems for
certain db4 applications such as Subversion.

Is that ok?
Comment 4 Warren Togami 2004-04-13 15:45:44 EDT
Sorry, regarding comment #3 notting recommended excluding it from
release notes.
Comment 5 Ed Bailey 2004-04-13 15:59:25 EDT
Ok, will pull the nptl reference.

As far as the I2O stuff is concerned, here is what I currently have:

Experimental DPT I2O SCSI RAID support — Fedora Core 1.91 Test 2 has
activated the kernel-2.6 generic I2O layer for stability trials of
Adaptec DPT I2O-based SCSI hardware RAID controllers. This controller
was previously supported in the 2.4 kernel series by the dpt_i2o
driver, which is no longer operational. Testing should be done on
Anaconda installations, partitioning, and stress tests with heavy
workloads, if possible.

      Note

Only perform testing in non-production environments, due to the risk
of data loss.

If these test results prove to be positive, I2O may be kept for the
final Fedora Core release. Note that the i2o_scsi module has been
disabled on x86-64 because it is known to cause deadlocks and crashes;
however RAID capability with /dev/i2o/hdX devices has worked in
initial testing.

For more information about I2O development visit the "I2O on Linux" page:

http://i2o.shadowconnect.com

Discuss I2O-specific topics at the linux-scsi mailing list. *** FIXME
-- need pointers to the list ***

As you can tell from that last paragraph, I need a pointer to this
list (subscription email address, Web archive of the list, etc.)

Other than that, does this look ok to you?
Comment 6 Warren Togami 2004-04-13 17:10:02 EDT
http://www.linuxhq.com/lnxlists/subscribe.html
Subscribing is described here.  Perhaps you want to copy the text.

http://marc.theaimsgroup.com/?l=linux-scsi
Mailing list archive

Your above comment says "Test 2".  Don't forget to change that to Test
3 for this upcoming release. =)
Comment 7 Ed Bailey 2004-04-13 17:15:16 EDT
Super -- thanks!  And don't worry about "Test 2" -- that is added
whenever the document is built.  When the final fedora-release is
built, it'll say the right thing... :-)
Comment 8 Ed Bailey 2004-04-23 16:01:23 EDT
Make sure all relevant sections reference this bug (the I2O one
currently does not)

Note You need to log in before you can comment on or make changes to this bug.