Bug 1203680 - [Regression] s390.sh - incorrect syntax of equation
Summary: [Regression] s390.sh - incorrect syntax of equation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: s390utils
Version: 6.7
Hardware: s390x
OS: Unspecified
medium
medium
Target Milestone: rc
: 6.7
Assignee: Dan Horák
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-19 12:36 UTC by Frantisek Sumsal
Modified: 2015-07-22 06:49 UTC (History)
5 users (show)

Fixed In Version: s390utils-1.8.2-57.el6
Doc Type: Bug Fix
Doc Text:
Previously, the Bash syntax for comparison was used by the s390.script, which could lead to errors when a different shell was used. With this update, the correct syntax for value comparison is used, and the s390.sh file is processed correctly by all shells.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:49:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1341 normal SHIPPED_LIVE s390utils bug fix and enhancement update 2015-07-20 17:52:53 UTC

Description Frantisek Sumsal 2015-03-19 12:36:49 UTC
Possible regression of BZ#851096.

This bug has been fixed in s390utils-1.8.1-18.el5. Nevertheless, it appears in RHEL 6 builds and disappears again in RHEL 7 builds.

RHEL 5 - s390utils-1.8.1-18.el5.s390x (PASS)
--------------------------------------------
# cat /etc/profile.d/s390.sh 
# /etc/profile.d/s390.sh - set TERM variable

contype=`/sbin/consoletype stdout`
if [ "$contype" = "serial" ]; then
    export TERM=dumb
fi

# zsh /etc/profile.d/s390.sh


RHEL 6.7 - s390utils-1.8.2-56.el6.s390x (FAIL)
----------------------------------------------
# cat /etc/profile.d/s390.sh 
# /etc/profile.d/s390.sh - set TERM variable

contype=`/sbin/consoletype stdout`
if [ "$contype" == "serial" ]; then
    export TERM=dumb
fi

# zsh /etc/profile.d/s390.sh 
/etc/profile.d/s390.sh:4: = not found


RHEL 7.1 - s390utils-1.23.0-17.el7.s390x (PASS)
-----------------------------------------------
# cat /etc/profile.d/s390.sh 
# /etc/profile.d/s390.sh - set TERM variable

contype=`/sbin/consoletype stdout`
if [ "$contype" = "serial" ]; then
    export TERM=dumb
fi

# zsh /etc/profile.d/s390.sh

Comment 7 errata-xmlrpc 2015-07-22 06:49:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1341.html


Note You need to log in before you can comment on or make changes to this bug.