Bug 120389 - FC2 release notes -- notes on IIIMF needed
FC2 release notes -- notes on IIIMF needed
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Bailey
:
Depends On:
Blocks: fc-relnotes-blocker
  Show dependency treegraph
 
Reported: 2004-04-08 08:23 EDT by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 11:36:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2004-04-08 08:23:41 EDT
In FC2 the default Input Method (IM) for Chinese (Simplified and
Traditional), Japanese and Korean has been changed to iiimf.
iiimf is supported as a native gtk2 IM module, and also through
XIM using the httx client.  iiimf supports using multiple Language
Engines (LEs) at the same time: using the Gnome Input Method
Switcher applet (Gimlet for short) it is possible to switch between
LEs inside gtk2 applications.
Comment 1 Ed Bailey 2004-04-08 16:55:59 EDT
Jens -- is there anything else what someone using the previous input
methods should know?  Are there functional differences that could
confuse someone used to the older stuff?
Comment 2 Jens Petersen 2004-04-08 22:50:41 EDT
(Good question. :)

IIIMF currently defaults to using Ctrl-Space for toggling
the input method on and off.  (Emacs users can use Ctrl-@
instead to set-mark.)  The old XIM based IMs are still present
(expect nabi has replaced ami for Korean).

[For the final release we need to document here how to
change the system default IM and how users can override it.
-- will depend partly on whether xinput.d support makes it into
xinitrc or not.]
Comment 3 Ed Bailey 2004-04-09 21:27:37 EDT
Ok, so IIIMF uses Ctrl-Space(or Ctrl-@) -- what did the XIM-based
input methods use?

What should I say about the nabi/ami situation?

As for changing/overriding the system-wide default input method, just
let me know what to say, and I'll make sure it gets into the release
notes.  With the slip, we have about one week to everything written,
so don't forget about me! :-)
Comment 4 Akira TAGOH 2004-04-10 06:14:22 EDT
ah, no. you seem to be confused :) Ctrl-space is often used as
set-mark on emacs/xemacs. but the input method grabs the key event
faster than emacs/xemacs. so even if people press Ctrl-space in order
to do set-mark, it won't work on emacs/xemacs working IIIMF. but they
can use Ctrl-@ instead of, because Ctrl-@ is also assigned as set-mark.

And XIM-based input methods used Shift-space or Ctrl-space. it depends
on what IM you mean. but right now IIIMF uses Ctrl-space to activate
the input method on all of locales, which is supported by IIIMF.
Comment 8 Lawrence Lim 2004-04-14 04:09:02 EDT
Hi Ed,
The Nabi/Ami situation is as follows:

Nabi will be replacing the deprecated Ami. 

User who have used Ami will have no problem migrating over to Nabi.
The major noticable difference that user will notice is an applet on
the panel that notify user when the Nabi Input Method is turn on or
off, which I think is a great feature over Ami.





Comment 10 Ed Bailey 2004-04-14 16:55:59 EDT
Here is my draft of the IIIMF entry; please let me know if this is
acceptable, or if there is something needing more work:

The default Input Method (IM) for Chinese (Simplified and
Traditional), Japanese, and Korean has been changed to IIMF — the
Internet/Intranet Input Method Framework. IIIMF is supported as a
native GTK2 IM module, and also through XIM using the httx client.
IIMF supports the use of multiple Language Engines (LEs) at the same
time; using the Gnome Input Method Switcher applet (Gimlet) it is
possible to switch between LEs inside GTK2 applications.

IIIMF currently defaults to using Ctrl-Space for toggling the input
method on and off (Emacs users can use Ctrl-@ instead of Ctrl-Space to
set the mark.)
Comment 13 Jens Petersen 2004-04-14 23:14:24 EDT
Thanks, Ed.  Just a couple of small changes:

1) "IIMF" should be "IIIMF" everywhere.

2) Also sorry I got the gimlet acronym wrong.  Apparently GIMLET
stands for "GNOME Input Method Language Engine Tool".

Otherwise I think it is fine.
Comment 14 Jens Petersen 2004-04-15 08:32:55 EDT
Sorry one more change request:

3) Please could you change "switch between LEs inside" to
"switch between LEs of different languages inside".

Thanks.
Comment 15 Ed Bailey 2004-04-15 11:33:34 EDT
Jens -- The IIMF/IIIMF thing already caught me several times while
trying to find the IIIMF RPMs in the rawhide trees. :-)  Thanks for
catching those!

Fixed the GIMLET reference...

Revised the "switch between" phrase...

Thanks for the great feedback!



Comment 17 Jens Petersen 2004-04-16 12:18:13 EDT
Ed, for the second parts of comment 2 and comment 3: we added a small
script called "im-switch" which allows users to easily change the
system default input method and the user's default input method between
IIIMF and legacy XIM clients.  (It is part of the iiimf-x package.)

Could you add a mention of that to the IIIMF section?  Thanks.
Comment 18 Ed Bailey 2004-04-16 14:01:54 EDT
Jens -- how's this?

To switch between IIIMF and the legacy XIM input methods, use the
im-switch command. Enter the following command for more information:

      im-switch -h

Comment 19 Ed Bailey 2004-04-19 11:36:31 EDT
In the absence of a confirmation regarding comment #18, and the
rapidly-approaching deadline for the release notes, I'm forced to
either remove the reference of im-switch, or assume that what I've
written is better than nothing. :-)

I'm going to take the latter approach, and close this bug.

Thanks to everyone for their help!
Comment 20 Leon Ho 2004-04-19 20:24:23 EDT
Sorry about that Ed I slipped through this bug. Yes it is good! Thanks
again!

Note You need to log in before you can comment on or make changes to this bug.