Bug 1204 - Kickstart unable to make to swap partition
Kickstart unable to make to swap partition
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
: 9893 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-16 11:55 EST by nickg
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-11 18:27:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nickg 1999-02-16 11:55:52 EST
Hi,

I'm not sure where to put this since there is no
specific Kickstart section (I could find anyways).

There is no way of making two linux swap paritions.
We are making an unusual disk configuration as such:

Primary /     256M
Primary swap  128M
Primary swap  128M
Extended
 many other paritions

Under kickstart, it makes one primary parition,
and then one big extended parition.  My understanding
is that Linux can't use more than 128M of swap space
per parition, (true?) so we wanted to double it up as
such.  That may or may not be true, but the bug is
Kickstart doesn't allow this configuration.

Ideally, the "part" kickstart command should take
another paramter "--primary" as a hint to make a
primary configuration.

thanks,

--nickg@sightpath.com
Comment 1 David Lawrence 1999-03-11 18:27:59 EST
This is not a bug, the current libfdisk partitioning algorithm that is
used in the install process does not support more than 1 primary
partition. You will need to use fdisk by hand or change the swaps to
extended logical partitions.
Comment 2 Jeff Johnson 1999-06-07 07:38:59 EDT
*** Bug 3311 has been marked as a duplicate of this bug. ***

When laying out a disk with the following lines in the
ks.cfg

clearpart --all
part / --size 1024 --grow
part swap --size 127
part swap --size 127

kickstart fails to create the second swap partition.


------- Additional Comments From sfalvey@uk.oracle.com  06/07/99 07:07 -------
Just noticed bud id 1204. It should at least complain telling you it
is unable to perform the partitioning requested.
Comment 3 Pug Bainter 2000-03-01 11:04:59 EST
*** Bug 9893 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.