Bug 1204179 - missing /bin/vi breaks visudo, sudoedit, crontab -e, etc.
Summary: missing /bin/vi breaks visudo, sudoedit, crontab -e, etc.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vim
Version: 6.7
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Karsten Hopp
QA Contact: Filip Holec
URL:
Whiteboard:
Keywords: Regression
Depends On: 1202897
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-20 14:30 UTC by Martin Žember
Modified: 2016-04-18 10:27 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-07-22 06:27:42 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1310 normal SHIPPED_LIVE vim bug fix and enhancement update 2015-07-20 17:53:38 UTC
Red Hat Bugzilla 831224 None CLOSED visudo has hardcoded path to /bin/vi 2019-01-17 15:19 UTC

Internal Trackers: 831224

Description Martin Žember 2015-03-20 14:30:15 UTC
Description of problem:
/bin/vi is missing while some programs expect it being there by default


Version-Release number of selected component (if applicable):
RHEL-6.7-20150304.0 compose
# rpm -qa | grep ^vim
vim-minimal-7.4.629-3.el6.x86_64
vim-filesystem-7.4.629-3.el6.x86_64
vim-common-7.4.629-3.el6.x86_64
vim-enhanced-7.4.629-3.el6.x86_64
# rpm -qa | grep ^sudo
sudo-1.8.6p3-16.el6.x86_64


How reproducible:
Every time


Steps to Reproduce:
1. # crontab -e
no crontab for root - using an empty one
/bin/sh: /bin/vi: No such file or directory
crontab: "/bin/vi" exited with status 127

2. # sudoedit /etc/hosts
sudoedit: /bin/vi: command not found

3. # visudo
visudo: no editor found (editor path = /bin/vi)


Actual results:
/bin/vi: command not found


Expected results:


Additional info:
It used to work with RHEL-6.5
# rpm -qa | grep ^vim
vim-minimal-7.2.411-1.8.el6.x86_64
vim-enhanced-7.2.411-1.8.el6.x86_64
vim-common-7.2.411-1.8.el6.x86_64
# rpm -qa | grep ^sudo
sudo-1.8.6p3-12.el6.x86_64

In both setups, the following variables were empty:
# echo $EDITOR $SUDO_EDITOR $VISUAL

Comment 6 errata-xmlrpc 2015-07-22 06:27:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1310.html


Note You need to log in before you can comment on or make changes to this bug.