Bug 1204392 - Wireless keybord K330 Logitech not working for dm-crypt passphrase
Wireless keybord K330 Logitech not working for dm-crypt passphrase
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
21
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: dracut-maint-list
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1229650
  Show dependency treegraph
 
Reported: 2015-03-21 11:34 EDT by Frank Ansari
Modified: 2015-06-09 06:45 EDT (History)
20 users (show)

See Also:
Fixed In Version: dracut-038-39.git20150518.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1229650 (view as bug list)
Environment:
Last Closed: 2015-05-21 13:36:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ansari 2015-03-21 11:34:52 EDT
Description of problem:
I use a wireless keyboard K330 from Logitech. Also I use dm-crypt.
When I start my PC the keyboard does not work for entering the dm-crpyt passwphrase.This happend to me today after updating to kernel 3.19.

Version-Release number of selected component (if applicable):
3.19.1-201.fc21.x86_64

How reproducible:
Use kernel 3.19.1-201.fc21.x86_64. 
It still works correctly with 3.18.9-200.fc21.x86_64.

Steps to Reproduce:
1. Use a Linux system which asks for a dm-crypt (luks) passphrase while booting.
2. Use a K300 Logitech wireless keyboard.
3. Boot the PC and try to enter the passphrase.

Actual results:
No characters (dots) appear. You cannot enter the passphrase.

Expected results:
It should be possible to enter the passphrase.

Additional info:
This is the second time there was a bad surprise for dm-crypt after a kernel update this year (first surprise was that the keyboard layout was suddenly German instead of English).
Comment 1 Frank Ansari 2015-03-21 11:40:34 EDT
I also tried to rebuild the initramfs (using kernel-install). 
But the result is the same.
Comment 2 Frank Ansari 2015-03-21 12:32:09 EDT
Sorry, typo in the description. It is K330 (not K300). Maybe all wireless keyboards will fail - but I just have this one for testing.
Comment 3 Thomas Howard 2015-03-23 01:40:00 EDT
This is affecting me since the update to kernel 3.19.1-201, also. Though I am using a Logitech MK700 Keyboard and a Logitech M705 connected to the same receiver.
Comment 4 Thomas Howard 2015-03-23 02:17:20 EDT
Adding "hid-logitech-hidpp" to my additional drivers in /etc/dracut.conf and rebuilding my initramfs seems to have fixed this for me.
Comment 5 Frank Ansari 2015-03-23 16:02:25 EDT
Yes, I can confirm this. With this configuration it is working on my system too.
Remains the question: why was this removed? Is this a bug or a feature?
Comment 6 wintonian 2015-03-24 11:11:08 EDT
Also broken in 3.19.2-201 for me and another user (as reported on Fedoraforum I won't link as nothing useful is said the the thread)
Comment 7 wintonian 2015-03-24 11:14:13 EDT
Apologies forgot to mention I'm using a K750
Comment 8 Boricua 2015-03-26 08:50:55 EDT
I am the other FedoraForum user mentioned by wintonian. Mine is a Logitech K350. It does not work at cryptsetup with current kernel 3.19.1-201.fc21.x86_64. I also tried kernel 3.19.2-200.fc21.x86_64 from the testing repo, with the same negative result.
Comment 9 Eric Smith 2015-03-30 06:06:21 EDT
This happens whenever the kernel modules needed for the Logitech receivers change. It happened with kernel 3.2 (bug #786303), and now it's happened again with 3.19, which now requires the hid-logitech-hidpp module.

Thomas provided the workaround in comment 4 above, but the fix requires a patch to the dracut package to /usr/lib/dracut/modules.d/90kernel-modules/module-setup.sh to add hid-logitech-hidpp after hid-logitech-dj.
Comment 10 wintonian 2015-03-30 14:37:16 EDT
That worked for 3.19.2-201 (and beyond I will assume), thank you.

I still hope someone will find time to issue an update or at least have it fixed for F22 release? As there is quite enough tinkering to do on a clean install to get basic functionality (mainly thinking about propitiatory graphic drivers), as it is.
Comment 11 Tibbs Brookside 2015-03-30 16:22:21 EDT
I'm having problems with a Logitech K520 keyboard. I've tried both the "amending the /usr/lib/dracut/modules.d/90kernel-modules/module-setup.sh script" option and the "adding the driver to /etc/dracut.conf" option but, while I see the driver listed in the new initramfs:

lsinitrd /boot/initramfs-3.19.2-201.fc21.x86_64.img | grep logitech
-rw-r--r--   1 root     root         6996 Mar 24 03:48 usr/lib/modules/3.19.2-201.fc21.x86_64/kernel/drivers/hid/hid-logitech-dj.ko.xz
-rw-r--r--   1 root     root         7060 Mar 24 03:49 usr/lib/modules/3.19.2-201.fc21.x86_64/kernel/drivers/hid/hid-logitech-hidpp.ko.xz

I still get no response from the keyboard during boot.
Comment 12 Tibbs Brookside 2015-04-01 05:07:27 EDT
(In reply to Carrot Cruncher from comment #11)
> I'm having problems with a Logitech K520 keyboard. I've tried both the
> "amending the /usr/lib/dracut/modules.d/90kernel-modules/module-setup.sh
> script" option and the "adding the driver to /etc/dracut.conf" option but,
> while I see the driver listed in the new initramfs:
> 
> lsinitrd /boot/initramfs-3.19.2-201.fc21.x86_64.img | grep logitech
> -rw-r--r--   1 root     root         6996 Mar 24 03:48
> usr/lib/modules/3.19.2-201.fc21.x86_64/kernel/drivers/hid/hid-logitech-dj.ko.
> xz
> -rw-r--r--   1 root     root         7060 Mar 24 03:49
> usr/lib/modules/3.19.2-201.fc21.x86_64/kernel/drivers/hid/hid-logitech-hidpp.
> ko.xz
> 
> I still get no response from the keyboard during boot.

Not sure what has changed but I've just tried it again and it is working now. Apologies for the confusion.
Comment 13 Steven Pehrson 2015-04-01 12:08:12 EDT
(In reply to Thomas Howard from comment #4)
> Adding "hid-logitech-hidpp" to my additional drivers in /etc/dracut.conf and
> rebuilding my initramfs seems to have fixed this for me.

This workaround worked for me too, thanks!

Steps:
 1) sudo vi /etc/dracut.conf 
    modification: add_drivers+="hid-logitech-hidpp"
 2) cp /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r).img.bak
 3) dracut -f
 4) reboot
Comment 14 Frank Ansari 2015-04-01 15:11:07 EDT
(In reply to Eric Smith from comment #9)
> This happens whenever the kernel modules needed for the Logitech receivers
> change. It happened with kernel 3.2 (bug #786303), and now it's happened
> again with 3.19, which now requires the hid-logitech-hidpp module.
> 
> Thomas provided the workaround in comment 4 above, but the fix requires a
> patch to the dracut package to
> /usr/lib/dracut/modules.d/90kernel-modules/module-setup.sh to add
> hid-logitech-hidpp after hid-logitech-dj.

For me both solutions work indepedently. When I add the driver to module-setup.sh and remove it from dracut.conf it works and vice versa.
Comment 15 Illya 2015-04-02 04:23:14 EDT
Same problem with K710 keyboard and 3.19.3-200.fc21.x86_64 kernel.

Workaround from comment 13 solves this. Thanks!
Comment 16 Boricua 2015-04-20 18:00:49 EDT
Just to report that I upgraded to Fedora 22 Beta RC3, updated to kernel 4.0.0-1 and found the same issue.
Comment 18 Steeve McCauley 2015-05-05 12:29:44 EDT
(In reply to Steven Pehrson from comment #13)
> (In reply to Thomas Howard from comment #4)
> > Adding "hid-logitech-hidpp" to my additional drivers in /etc/dracut.conf and
> > rebuilding my initramfs seems to have fixed this for me.
> 
> This workaround worked for me too, thanks!
> 
> Steps:
>  1) sudo vi /etc/dracut.conf 
>     modification: add_drivers+="hid-logitech-hidpp"
>  2) cp /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r).img.bak
>  3) dracut -f
>  4) reboot

This also worked for me, although I had to rebuild a different kernel I was running an older kernel that wasn't affected by the issue.  To rebuild for a newer kernel version,

$ sudo dracut -f /boot/initramfs-3.19.5-200.fc21.x86_64.img 3.19.5-200.fc21.x86_64

After reboot I was able to enter the Luks password and boot without problems, and the HID++ multi-touch features of the new driver seem to be working well.
Comment 19 Chris Bredesen 2015-05-16 12:45:33 EDT
The workaround in comment 13 also worked for me but it's not clear in which version this will be fixed. Does the dracut fix persist across newer kernels? Thanks for the help folks.
Comment 20 Fedora Update System 2015-05-18 08:17:59 EDT
dracut-038-39.git20150518.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dracut-038-39.git20150518.fc21
Comment 21 Fedora Update System 2015-05-19 12:21:05 EDT
Package dracut-038-39.git20150518.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-038-39.git20150518.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8504/dracut-038-39.git20150518.fc21
then log in and leave karma (feedback).
Comment 22 Fedora Update System 2015-05-21 13:36:40 EDT
dracut-038-39.git20150518.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Aniruddha 2015-05-27 12:39:40 EDT
I have the same problem with a Logitech K800 on Fedora 22 with dracut 041, release 10.fc22.1, kernel 4.0.4-301.fc22.x86_64.
Comment 24 Frank Ansari 2015-05-28 06:02:08 EDT
Please let me add that I had the same issue while using fedup to update to 22. Only option was to use my USB keyboard to open the HDD.
Comment 25 Joe Spencer 2015-05-30 09:49:12 EDT
This is why I love open source.  Had the same issue with my K520, did some googling, arrived here, tried the solution posted in comment #4 and voila!

For those arriving here needing more guidance, this worked for me (fedora 20):

1. vim /etc/dracut.conf
2. uncomment add_drivers and add hid-logitech-hidpp
3. save the file
4. sudo dracut -f
5. reboot
Comment 26 Chris Bredesen 2015-05-31 13:50:47 EDT
This was definitely fixed for me in F-21. Did the patch not go into rawhide/22?
Comment 27 Steeve McCauley 2015-05-31 15:54:03 EDT
I think I got bit by this using fedup to upgrade f21 to f22.

$ lsinitrd initramfs-fedup.img  | grep logitech
-rw-r--r--   1 root     root         6956 May 21 09:57 usr/lib/modules/4.0.4-301.fc22.x86_64/kernel/drivers/hid/hid-logitech-dj.ko.xz

Got to the LUKs prompt and keyboard didn't work on my logitech K520 keyboard, which fortunately had never been prone to this particular issue in any of the F21 kernels.

I don't have a USB keyboard so I had to bail from the upgrade so cannot tell if it's just the initramfs-fedup image or whether it's a more general problem with f22.  Regardless it looks like the hid-logitech-hidpp module is missing in this image.

Note You need to log in before you can comment on or make changes to this bug.