This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 120459 - bootup lvm vgscan fails due to missing libreadline.so.4
bootup lvm vgscan fails due to missing libreadline.so.4
Status: CLOSED DUPLICATE of bug 120458
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-08 19:15 EDT by Mika Hirvonen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-26 13:03:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mika Hirvonen 2004-04-08 19:15:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
When booting a system with lvm2-2.00.10-1.3 and the /usr filesystem in
a LV, the initial lvm vgscan fails due to missing libreadline.so.4,
which usually resides in /usr/lib and is thus inaccessible at this
part of the bootup.

Booting into rescue mode and downgrading to lvm2-2.00.08-5 fixed the
problem and allowed the system to boot.

Version-Release number of selected component (if applicable):
lvm2-2.00.10-1.3

How reproducible:
Always

Steps to Reproduce:
1. put /usr into a LV
2. install lvm2-2.00.10-1.3
3. reboot
    

Actual Results:  system fails to complete lvm vgscan, fails to mount
the filesystems and drops to a maintenance shell

Expected Results:  system should have completed vgscan normally and
continued to mount filesystems on logical volumes

Additional info:
Comment 1 Mika Hirvonen 2004-04-09 01:36:42 EDT

*** This bug has been marked as a duplicate of 120458 ***

Note You need to log in before you can comment on or make changes to this bug.