Bug 120458 - /sbin/lvm missing libreadline.so.4... /usr not avail yet!
Summary: /sbin/lvm missing libreadline.so.4... /usr not avail yet!
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm2   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 120459 120705 (view as bug list)
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-04-08 23:12 UTC by David Carrigan
Modified: 2014-03-17 02:44 UTC (History)
6 users (show)

Fixed In Version: 7.50-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 21:19:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test patch for /etc/rc.d/rc.sysinit (962 bytes, patch)
2004-04-14 13:14 UTC, Alasdair Kergon
no flags Details | Diff
Additional patch (1.30 KB, patch)
2004-04-14 13:23 UTC, Alasdair Kergon
no flags Details | Diff

Description David Carrigan 2004-04-08 23:12:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
/sbin/lvm in this RPM is linked dynamically to three(3) libraries
under /usr/lib (libreadline.so.4, libncurses.so.5, and libgpm.so.1).

At boot, /sbin/lvm is called from /etc/rc.d/rc.sysinit at line 378,
but /usr--if a separate partition--is not mounted/available until
line 605 of same.


Version-Release number of selected component (if applicable):
lvm2-2.00.10-1.3

How reproducible:
Always

Steps to Reproduce:
1. Boot a system with /usr as separate from / filesystem
2. Error: /sbin/lvm: libreadline.so.4 not found 
3. Enter root passwd at sulogin prompt
4. `e2fsck -y /dev/<where /usr is>; mount /dev/</usr> /usr'
5. run /sbin/lvm --mknodes[...] as "usual."
    

Actual Results:  System works OK after steps 3. - 5., but on reboot, we're
back in the same mess

Expected Results:  Simply boot the system as before the "upgrade" to
lvm2-2.00.10-1.3


Additional info:

Will roll back to other lvm2 version, until this is fixed

Comment 1 Mika Hirvonen 2004-04-09 05:36:45 UTC
*** Bug 120459 has been marked as a duplicate of this bug. ***

Comment 2 Miloslav Trmac 2004-04-13 11:37:55 UTC
*** Bug 120705 has been marked as a duplicate of this bug. ***

Comment 3 Alasdair Kergon 2004-04-14 12:46:44 UTC
rc.sysinit should be using lvm.static not lvm.

Comment 4 Alasdair Kergon 2004-04-14 13:14:40 UTC
Created attachment 99403 [details]
Test patch for /etc/rc.d/rc.sysinit

Comment 5 Alasdair Kergon 2004-04-14 13:23:13 UTC
Created attachment 99405 [details]
Additional patch

Comment 6 Alasdair Kergon 2004-04-14 13:27:36 UTC
2 patches to rc.sysinit attached to fix the init script to use the
static version of the binary instead of the dynamically-linked one.

Comment 7 Alasdair Kergon 2004-04-15 11:34:58 UTC
2.00.12 released which moves the non-static binaries to /usr/sbin and
has a temporary workaround (extra symlinks in /sbin) until initscripts
gets updated with the attached patches.

Comment 8 Bill Nottingham 2004-05-03 21:19:12 UTC
This is fixed in 7.50-1.


Note You need to log in before you can comment on or make changes to this bug.