Bug 1204929 - activation key - create: "Loading...." hangs on UI due to 404/elasticsearch error
Summary: activation key - create: "Loading...." hangs on UI due to 404/elasticsearch ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1252150 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-23 19:10 UTC by Corey Welton
Modified: 2019-06-13 21:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-15 18:19:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1911 normal SHIPPED_LIVE Satellite 6.1.3 bug fix update 2015-10-15 22:19:19 UTC
Foreman Issue Tracker 9887 None None None 2016-04-22 16:01:11 UTC

Description Corey Welton 2015-03-23 19:10:15 UTC
Description of problem:

When creating AKs, user will sporadically get a "Loading...." hang, upon submission.  This is apparently due to a resource 404.  This 404, in turn, is due to things being completed/returned too quickly for elasticsearch, which is apparently returning our ak info.


Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-7-20150317.0

How reproducible:
Sometimes!! It seems to happen every 2-3 AK creates on this box, but not every time.  On jcalla's box, we haven't seen it at all.... yet.

Steps to Reproduce:
1.  attempt to create an activation key; submit.
2.  If you do not get stuck, repeat step 1 until you do get stuck
3.  View results

Actual results:

* UI reading "Loading...." with a misplaced "environments" arrowhead

* Console in chrome reads

Remote Address:10.16.4.115:443
Request URL:https://rhsm-qe-3.rhq.lab.eng.bos.redhat.com/katello/api/v2/activation_keys/15?fields=full
Request Method:GET
Status Code:404 Not Found

* In production log:

2015-03-23 14:44:49 [I] Completed 404 Not Found in 18ms (Views: 0.3ms | ActiveRecord: 0.9ms)
2015-03-23 14:44:50 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.26/app/views/katello/api/v2/environments/paths.json.rabl within katello/api/v2/layouts/collection (225.3ms)


Expected results:
No 404s, "Loading" page 'just works.

Additional info:

Comment 3 Corey Welton 2015-03-23 19:30:29 UTC
FWIW, according to jsherrill, this is a bz no matter what because elasticsearch shouldn't be used to return such sorts of results anymore, anyway.

Comment 6 Walden Raines 2015-03-24 15:44:56 UTC
Created redmine issue http://projects.theforeman.org/issues/9887 from this bug

Comment 7 Walden Raines 2015-03-24 16:43:55 UTC
PR: https://github.com/Katello/katello/pull/5135

Comment 8 Bryan Kearney 2015-03-25 20:05:34 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/9887 has been closed
-------------
Walden Raines
Applied in changeset commit:katello|a15d5098b0252eaeed3bc4a8c59ede2177f61593.

Comment 9 jcallaha 2015-03-27 17:31:25 UTC
Verified by QE on version Satellite-6.1.0-RHEL-7-20150324.0

Comment 10 Bryan Kearney 2015-08-11 13:21:04 UTC
This bug is slated to be released with Satellite 6.1.

Comment 11 Bryan Kearney 2015-08-12 13:57:00 UTC
This bug was fixed in version 6.1.1 of Satellite which was released on 12 August, 2015.

Comment 12 Ivan Necas 2015-09-10 15:35:22 UTC
I don't see the change from this bug to be present in the recent satellite 6 builds and I was able to reproduce the issue. Probably cherry-pick missed in the process

Comment 13 Ivan Necas 2015-09-10 15:37:32 UTC
*** Bug 1252150 has been marked as a duplicate of this bug. ***

Comment 15 Chris Peters 2015-09-29 20:15:09 UTC
cherry-picked commit a15d5098b0252eaeed3bc4a8c59ede2177f61593

Comment 17 jcallaha 2015-10-02 19:23:58 UTC
Verified in 6.1.3 compose #2

Comment 19 errata-xmlrpc 2015-10-15 18:19:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911


Note You need to log in before you can comment on or make changes to this bug.