Bug 1252150 - Activation key create page loads indefinitely
Activation key create page loads indefinitely
Status: CLOSED DUPLICATE of bug 1204929
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Activation Keys (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high (vote)
: 6.1.3
: --
Assigned To: Chris Peters
sthirugn@redhat.com
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 16:06 EDT by sthirugn@redhat.com
Modified: 2017-02-23 14:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-10 11:37:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Page loads forever (61.06 KB, image/png)
2015-08-10 16:06 EDT, sthirugn@redhat.com
no flags Details
production.log error (12.81 KB, text/plain)
2015-08-10 16:09 EDT, sthirugn@redhat.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 11563 None None None 2016-04-22 12:29 EDT

  None (edit)
Description sthirugn@redhat.com 2015-08-10 16:06:49 EDT
Created attachment 1061223 [details]
Page loads forever

Description of problem:
Activation key create page loads indefinitely

Version-Release number of selected component (if applicable):
Sat 6.1 GA Snap 15

How reproducible:


Steps to Reproduce:
1. Create an activation key ak1 in the UI
2. Now go to UI -> Content -> Activation Keys -> Select the activation key ak1 created in Step 1
3. Click on +New Activation key - Enter Name, Environment, Content View and click Save.

Actual results:
The page loads forever

Expected results:
The activation key created successfully and the Activation key -> Details page is displayed

Additional info:
A page refresh solves the indifinitely page loading error.  A quick test of Create/Remove/Update/Delete of such an errored activation key seems to work fine after the page refresh.
Comment 2 sthirugn@redhat.com 2015-08-10 16:09:56 EDT
Created attachment 1061226 [details]
production.log error
Comment 3 sthirugn@redhat.com 2015-08-10 16:12:06 EDT
Note that this bug happens in the following scenario only:
Select an already existing Activation key -> +New Activation Key

It works fine in:
Web UI -> Content -> Activation Keys -> +New Activation Key
Comment 6 Bryan Kearney 2015-08-25 14:57:41 EDT
Created redmine issue http://projects.theforeman.org/issues/11563 from this bug
Comment 8 Ondřej Pražák 2015-09-10 07:44:53 EDT
I ran into this as well, this issue seems to be a duplicate: https://bugzilla.redhat.com/show_bug.cgi?id=1204929
Comment 9 Ivan Necas 2015-09-10 11:37:32 EDT
I agree it's a duplicate with 1204929, closing this one. I was able to reproduce the issue, seems like missed cherry-pick, I've updated the original BZ about that fact and moved to POST

*** This bug has been marked as a duplicate of bug 1204929 ***

Note You need to log in before you can comment on or make changes to this bug.