Bug 120513 - curl-7.11.1 breaks compiling of php <= 4.3.5
Summary: curl-7.11.1 breaks compiling of php <= 4.3.5
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: php   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL: http://news.php.net/article.php?group...
Whiteboard:
Keywords:
: 122460 (view as bug list)
Depends On: 121011
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-09 18:07 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 4.3.6-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-01 15:35:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2004-04-09 18:07:01 UTC
Description of problem:
curl-7.11.1 breaks compiling of php <= 4.3.5:

--- snipp ---
/usr/src/redhat/BUILD/php-4.3.5/ext/curl/curl.c: In function `curl_free_post':
/usr/src/redhat/BUILD/php-4.3.5/ext/curl/curl.c:568: warning: passing arg 1 of `curl_formfree' from incompatible pointer type
/usr/src/redhat/BUILD/php-4.3.5/ext/curl/curl.c: In function `alloc_curl_handle':
/usr/src/redhat/BUILD/php-4.3.5/ext/curl/curl.c:608: sizeof applied to an incomplete type
/usr/src/redhat/BUILD/php-4.3.5/ext/curl/curl.c: In function `zif_curl_setopt':
/usr/src/redhat/BUILD/php-4.3.5/ext/curl/curl.c:845: duplicate case value
/usr/src/redhat/BUILD/php-4.3.5/ext/curl/curl.c:700: previously used here
/usr/src/redhat/BUILD/php-4.3.5/ext/curl/curl.c:890: warning: passing arg 1 of `curl_formadd' from incompatible pointer type
/usr/src/redhat/BUILD/php-4.3.5/ext/curl/curl.c:890: warning: passing arg 2 of `curl_formadd' from incompatible pointer type
/usr/src/redhat/BUILD/php-4.3.5/ext/curl/curl.c:898: warning: passing arg 1 of `curl_formadd' from incompatible pointer type
/usr/src/redhat/BUILD/php-4.3.5/ext/curl/curl.c:898: warning: passing arg 2 of `curl_formadd' from incompatible pointer type
make: *** [ext/curl/curl.lo] Error 1
--- snapp ---

I was still able to reproduce the problem with php 4.3.4, too.

Version-Release number of selected component (if applicable):
curl-7.11.1
php-4.3.4-11
(php-4.3.5-1)

How reproducible & Steps to Reproduce:
1. Install curl-7.11.1
2. Enable curl support in the php spec file
3. Rebuild php-4.3.4-11
  
Actual results:
PHP 4.3.6RC3 is released, which fixes the problem (maybe RC1/2 fixes
it already, too).

Expected results:
Please DON'T backport something from 4.3.6-rcX to 4.3.4/4.3.5 (and 
please don't create a patch), because PHP 4.3.6 will be released 
soon. A patch would be only unnecessary work ;-)

Additional info:
At current, there are 2 patches that have to changed for 4.3.6.

Comment 1 Joe Orton 2004-05-12 15:31:51 UTC
Awaiting 4.3.6 update for FC2.

Comment 2 Joe Orton 2004-05-24 19:10:03 UTC
*** Bug 122460 has been marked as a duplicate of this bug. ***

Comment 3 Joe Orton 2004-06-01 15:35:51 UTC
Fixed in 4.3.6-5 update.

http://www.redhat.com/archives/fedora-announce-list/2004-May/msg00029.html




Note You need to log in before you can comment on or make changes to this bug.