Bug 120531 - ifup starts multiple dhclient's
Summary: ifup starts multiple dhclient's
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 120533 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-09 21:45 UTC by Nickolai Zeldovich
Modified: 2014-03-17 02:44 UTC (History)
2 users (show)

Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 20:48:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for /sbin/ifup (864 bytes, patch)
2004-04-09 21:45 UTC, Nickolai Zeldovich
no flags Details | Diff

Description Nickolai Zeldovich 2004-04-09 21:45:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
When ifup is ran multiple times, multiple copies of dhclient are
started.  This is exacerbated by a DHCP server that takes a long time
to reply -- this means that the race condition window between ifup
doing a kill on the old dhclient, and the new dhclient writing out the
/var/run/pid file upon getting a lease, is quite large.

The attached patch uses /usr/bin/lockfile to do strict locking to
avoid the possibility of concurrently running dhclient processes
altogether.

Version-Release number of selected component (if applicable):
initscripts-7.49-1

How reproducible:
Always

Steps to Reproduce:
1.Run /sbin/ifup eth0 &
2.Run /sbin/ifup eth0
3.Notice two dhclient's running that don't exit
    

Actual Results:  As a result of having two dhclient processes running,
each process obtains a different DHCP lease and reconfigures the
interface according to _its_ lease periodically.

Additional info:

Comment 1 Nickolai Zeldovich 2004-04-09 21:45:50 UTC
Created attachment 99287 [details]
Patch for /sbin/ifup

Comment 2 Miloslav Trmac 2004-04-12 10:07:56 UTC
*** Bug 120533 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2005-09-30 20:48:54 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

This should be fixed as of Fedora Core 4.


Note You need to log in before you can comment on or make changes to this bug.