Bug 120540 - alsasink fails with error in pcm_plug.c with snd_via82xx soundcard
Summary: alsasink fails with error in pcm_plug.c with snd_via82xx soundcard
Status: CLOSED DUPLICATE of bug 116086
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-10 07:54 UTC by Noa Resare
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Noa Resare 2004-04-10 07:54:55 UTC
Description of problem:

When trying to use the alsasink to play audio it fails consistently.
Using osssink and alsa's oss emulation layer works however.

Version-Release number of selected component (if applicable):

gstreamer-0.8.0-4 (from core/development)

[noa@marit slask]$ uname -r
2.6.5-1.309



How reproducible:
always

Steps to Reproduce:
1. set up a gstreamer pipeline with the following command:
gst-launch-0.8 filesrc location="/usr/share/sounds/startup3.wav" !
wavparse ! alsasink
2.
3.
  
Actual results:
gst-launch-0.8: pcm_plug.c:882: snd_pcm_plug_hw_params: Assertion `err
>= 0' failed.
Avbruten (SIGABRT)


Expected results:
something similiar to the result when replacing alsasink above with
osssink

Additional info:

as an additional datapoint ogg123 from vorbis-tools-1.0.1-2 seems to
be able to successfully use alsa output

Comment 1 Noa Resare 2004-04-10 13:28:42 UTC
The upstream bug is http://bugzilla.gnome.org/show_bug.cgi?id=134007
who in turn references an alsa bug at
https://bugtrack.alsa-project.org/alsa-bug/bug_view_page.php?bug_id=0000116

It seems like the problem is hardware specific to my soundcard,
identified by lspci as

00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 50)

Unfortunately the alsa bugtracker seems broken so I can't sign up.

Comment 2 Colin Walters 2004-04-15 02:08:00 UTC

*** This bug has been marked as a duplicate of 116086 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:02:31 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.