Bug 1205545 - Effect of Trash translator over CTR translator
Summary: Effect of Trash translator over CTR translator
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: All
OS: All
medium
medium
Target Milestone: ---
Assignee: Jiffin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1218032 1260923
TreeView+ depends on / blocked
 
Reported: 2015-03-25 07:30 UTC by Jiffin
Modified: 2016-05-28 06:02 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1218032 (view as bug list)
Environment:
Last Closed: 2016-05-28 06:02:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Jiffin 2015-03-25 07:30:21 UTC
Description of problem:

Trash translator is just above posix.If it is on and unlink happens, then trash translator redirect unlink call to rename. So the CTR will record wrong information about the file, i.e trash translator should update CTR the file has been removed  

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Everytime

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jiffin 2015-03-25 09:14:39 UTC
Also , CTR does not require to track contents of trash-directory

Comment 2 Anand Avati 2015-03-25 09:40:32 UTC
REVIEW: http://review.gluster.org/9989 (features/trash : Notify CTR translator if an unlink happens to a file) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)

Comment 3 Anand Avati 2015-03-26 09:07:17 UTC
REVIEW: http://review.gluster.org/9989 (features/trash : Notify CTR translator if an unlink happens to a file) posted (#2) for review on master by Joseph Fernandes (josferna@redhat.com)

Comment 4 Anand Avati 2015-03-26 09:09:55 UTC
REVIEW: http://review.gluster.org/9989 (features/trash : Notify CTR translator if an unlink happens to a file) posted (#3) for review on master by Joseph Fernandes (josferna@redhat.com)

Comment 5 Anand Avati 2015-03-26 15:00:19 UTC
REVIEW: http://review.gluster.org/9989 (features/trash : Notify CTR translator if an unlink happens to a file) posted (#4) for review on master by Joseph Fernandes (josferna@redhat.com)

Comment 6 Anand Avati 2015-03-28 07:33:49 UTC
REVIEW: http://review.gluster.org/9989 (features/trash : Notify CTR translator if an unlink happens to a file) posted (#5) for review on master by Anoop C S (achiraya@redhat.com)

Comment 7 Anand Avati 2015-04-06 06:49:20 UTC
REVIEW: http://review.gluster.org/9989 (features/trash : Notify CTR translator if an unlink happens to a file) posted (#6) for review on master by jiffin tony Thottan (jthottan@redhat.com)

Comment 8 Anand Avati 2015-04-06 08:37:31 UTC
REVIEW: http://review.gluster.org/9989 (features/trash : Notify CTR translator if an unlink happens to a file) posted (#7) for review on master by jiffin tony Thottan (jthottan@redhat.com)

Comment 9 Anand Avati 2015-04-06 10:46:58 UTC
REVIEW: http://review.gluster.org/9989 (features/trash : Notify CTR translator if an unlink happens to a file) posted (#8) for review on master by jiffin tony Thottan (jthottan@redhat.com)

Comment 10 Anand Avati 2015-04-07 04:37:34 UTC
REVIEW: http://review.gluster.org/9989 (features/trash : Notify CTR translator if an unlink happens to a file) posted (#9) for review on master by jiffin tony Thottan (jthottan@redhat.com)

Comment 11 Anand Avati 2015-04-07 11:14:29 UTC
REVIEW: http://review.gluster.org/9989 (features/trash : Notify CTR translator if an unlink happens to a file) posted (#10) for review on master by jiffin tony Thottan (jthottan@redhat.com)

Comment 12 Anand Avati 2015-04-23 09:13:04 UTC
REVIEW: http://review.gluster.org/9989 (features/trash : Notify CTR translator if an unlink happens to a file) posted (#11) for review on master by Anoop C S (achiraya@redhat.com)

Comment 13 Anand Avati 2015-04-23 09:28:46 UTC
REVIEW: http://review.gluster.org/9989 (features/trash : Notify CTR translator if an unlink happens to a file) posted (#12) for review on master by Anoop C S (achiraya@redhat.com)

Comment 14 Anand Avati 2015-04-24 18:07:28 UTC
COMMIT: http://review.gluster.org/9989 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit b72bc58ecc108a2fddbdb6f606cd86a57ca5a68f
Author: Jiffin Tony Thottan <jthottan@redhat.com>
Date:   Wed Mar 25 15:04:19 2015 +0530

    features/trash : Notify CTR translator if an unlink happens to a file
    
    This implementation is same as the posix_unlink_cbk() where CTR sends
    a request during a unlink to send the number of links to the inode
    and posix obliges sending it using the unwind xdata dict.
    For Trash xlator a unlink is stat + mkdir(if parent is not present)
    + rename. And hence this is handled in trash_unlink_rename_cbk().
    
    Change-Id: I402e83567b88e3c9fe171379693c82937af567f9
    BUG: 1205545
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Signed-off-by: Anoop C S <achiraya@redhat.com>
    Reviewed-on: http://review.gluster.org/9989
    Tested-by: NetBSD Build System
    Tested-by: Joseph Fernandes
    Reviewed-by: Joseph Fernandes
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 15 Niels de Vos 2015-05-15 12:54:50 UTC
This change should not be in "ON_QA", the patch posted for this bug is only available in the master branch and not in a release yet.

Bug 1218032 was used for backporting, and that bug is now CLOSED because the fix is in a released version.

Comment 16 Nagaprasad Sathyanarayana 2015-10-25 15:22:19 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.


Note You need to log in before you can comment on or make changes to this bug.