Bug 1205596 - [SNAPSHOT]: Output message when a snapshot create is issued when multiple bricks are down needs to be improved
Summary: [SNAPSHOT]: Output message when a snapshot create is issued when multiple bri...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard: SNAPSHOT
Depends On: 1121560
Blocks: 1232886
TreeView+ depends on / blocked
 
Reported: 2015-03-25 09:40 UTC by Mohammed Rafi KC
Modified: 2016-06-16 12:45 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1121560
: 1232886 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:45:03 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-03-25 09:45:39 UTC
REVIEW: http://review.gluster.org/9990 (Snapshot: Remove brick details on snapshot create error) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-03-25 18:11:36 UTC
REVIEW: http://review.gluster.org/9999 (Snapshot: Remove brick details on snapshot create error) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Anand Avati 2015-04-01 08:17:20 UTC
REVIEW: http://review.gluster.org/9999 (Snapshot: Remove brick details on snapshot create error) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 4 Anand Avati 2015-04-09 12:46:32 UTC
COMMIT: http://review.gluster.org/9999 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit e405f6e419387d160f6564d15ad9fd3a43af0d10
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Wed Mar 25 15:11:48 2015 +0530

    Snapshot: Remove brick details on snapshot create error
    
    Since we are not providing complete details of stopped
    bricks on snapshot create error, it is better to remove
    the incomplete brick details.
    
    BUG: 1205596
    Change-Id: I73386059c0d29a6cbe7f2bb6834d8b8fb393db0a
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/9999
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 5 Niels de Vos 2015-05-14 17:29:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:35:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:38:16 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:46:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Anand Avati 2015-06-15 12:36:42 UTC
REVIEW: http://review.gluster.org/11234 (snapshot: Don't print brickdown message multiple times) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 10 Anand Avati 2015-06-16 05:43:22 UTC
REVIEW: http://review.gluster.org/11234 (snapshot: Don't print failure messages multiple times) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 11 Anand Avati 2015-06-17 08:52:18 UTC
REVIEW: http://review.gluster.org/11234 (glusterd/mgmt_v3: Print the node info, with failure messages) posted (#4) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 12 Anand Avati 2015-06-22 08:51:56 UTC
COMMIT: http://review.gluster.org/11234 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit d9e688e42a9b1e4be221fed9c1c85db0c2ae3664
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Wed Jun 17 14:18:32 2015 +0530

    glusterd/mgmt_v3: Print the node info, with failure messages
    
    While reporting multiple failure messages from different
    nodes, print the node ip and the failure stage.
    
    Change-Id: I657d3debf1b509e4a27baf9e4b580f1ee32e3c5f
    BUG: 1205596
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/11234
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 13 Nagaprasad Sathyanarayana 2015-10-25 14:52:05 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 14 Niels de Vos 2016-06-16 12:45:03 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.