Bug 1232886 - [SNAPSHOT]: Output message when a snapshot create is issued when multiple bricks are down needs to be improved
Summary: [SNAPSHOT]: Output message when a snapshot create is issued when multiple bri...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.7.1
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard: SNAPSHOT
Depends On: 1121560 1205596
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-17 18:07 UTC by Avra Sengupta
Modified: 2015-07-30 09:49 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1205596
Environment:
Last Closed: 2015-07-30 09:49:30 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-17 18:07:57 UTC
REVIEW: http://review.gluster.org/11293 (glusterd/mgmt_v3: Print the node info, with failure messages) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-06-24 09:09:08 UTC
COMMIT: http://review.gluster.org/11293 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 2c541e1872df1f87c6946d33316228cbf332a3db
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Wed Jun 17 14:18:32 2015 +0530

    glusterd/mgmt_v3: Print the node info, with failure messages
    
        Backport of http://review.gluster.org/#/c/11234/
    
    While reporting multiple failure messages from different
    nodes, print the node ip and the failure stage.
    
    Change-Id: I657d3debf1b509e4a27baf9e4b580f1ee32e3c5f
    BUG: 1232886
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/11293
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 3 Kaushal 2015-07-30 09:49:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.