Bug 120610 - SATA drive not initializing properly on cold boot
SATA drive not initializing properly on cold boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-11 19:25 EDT by Gene Czarcinski
Modified: 2013-07-02 22:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 00:50:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot FC2T2 from poweroff state (1.49 KB, text/plain)
2004-04-11 19:26 EDT, Gene Czarcinski
no flags Details
boot FC1 with libata and "scsi" for sata drive -- boot OK (741 bytes, text/plain)
2004-04-11 19:27 EDT, Gene Czarcinski
no flags Details
boot FC2T2 after booting FC1 .. boot OK (1.14 KB, text/plain)
2004-04-11 19:28 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2004-04-11 19:25:15 EDT
Description of problem:

The sata drive is not initializing properly when I boot fc2 from the
power-off state.  However, if I first boot FC1 which brings us the
drive as SCSI with libata and then boot FC2, it works OK.

1. boot FC2T2 .. bad
2. reboot FC2T2 .. still bad
3. reboot FC1 .. OK
4. reboot FC2T2 .. OK

I am attaching the selected parts of the kernel boot log for each case.

Version-Release number of selected component (if applicable):
kernel 2.6.5-1.315

How reproducible:
yes
Comment 1 Gene Czarcinski 2004-04-11 19:26:47 EDT
Created attachment 99316 [details]
boot FC2T2 from poweroff state

2nd reboot not recorded since it has the same.
Comment 2 Gene Czarcinski 2004-04-11 19:27:35 EDT
Created attachment 99317 [details]
boot FC1 with libata and "scsi" for sata drive -- boot OK
Comment 3 Gene Czarcinski 2004-04-11 19:28:19 EDT
Created attachment 99318 [details]
boot FC2T2 after booting FC1 .. boot OK
Comment 4 Gene Czarcinski 2004-04-28 12:17:45 EDT
reverified with FC2-T3 that the problem still exists.

Note: this is an Opteron 140 (x86_64) system -- I should have flagged
that in the original report.

To summerize:

1. from poweroff, boot the FC2-T3 boot.iso cdrom ... hangs trying to
initialize hde which is the SATA drive.

2. reboot into FC2-T2+lots-of-updates-and-327-kernel does the same thing.

3. reboot into FC1 x86_64 and the drive initializes as /dev/sda.

4. reboot the FC2-T3 cdrom, boot OK.

Note: seems to work OK (sort of) as long as not powered off.

Note: performance under FC2 as hde sucks although under FC1 it works fine.
Comment 5 raxet 2004-05-12 01:04:37 EDT
Similar to my bug 123067. Only I'm not x86_64
Comment 6 Dave Jones 2004-12-07 00:36:35 EST
fixed in the 2.6.9 based errata kernel ?
Comment 7 Gene Czarcinski 2004-12-07 00:50:28 EST
I am not running FC2 anymore and this problem does not appear in FC3.
 In fact, the whole SATA support is looking good in FC3.  With the
current errata, the same kernel is available for FC2 and FC3 so I
assume that it should be OK in FC2 also.

Given the current status, I am closing this.

Note You need to log in before you can comment on or make changes to this bug.