Bug 12064 - RFE: Build python shared library
Summary: RFE: Build python shared library
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: python
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL: http://www.python.org/doc/FAQ.html#3.30
Whiteboard:
Keywords: FutureFeature
: 16219 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-10 19:54 UTC by andrew.chatham
Modified: 2008-05-01 15:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-01-27 02:44:28 UTC


Attachments (Terms of Use)

Description andrew.chatham 2000-06-10 19:54:11 UTC
The official Python distribution does not build a shared library on Unices,
though it's pretty easy to do on Linux (see the URL). Just un-ar the static
library and relink it. It'd make embedding Python a lot nicer (and smaller,
too). I'm currently working on putting it in Guppi. It's too bad the
official distribution doesn't include a shared library, but Debian does
already, and I think it'd be useful if Red Hat did too.

Comment 1 Matt Wilson 2001-01-27 02:02:49 UTC
un-aring and relinking isn't enough - the code isn't -fPIC code so it does not
work on some architectures.


Comment 2 Matt Wilson 2001-01-27 02:44:23 UTC
*** Bug 16219 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.