Bug 1206546 - [RFE] Data Tiering:Need a way from CLI to identify hot and cold tier bricks easily
Summary: [RFE] Data Tiering:Need a way from CLI to identify hot and cold tier bricks e...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: All
OS: Linux
urgent
medium
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: qe_tracker_everglades 1219842 1219843 1260923
TreeView+ depends on / blocked
 
Reported: 2015-03-27 12:00 UTC by Nag Pavan Chilakam
Modified: 2016-06-16 12:45 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1219842 1219843 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:45:56 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nag Pavan Chilakam 2015-03-27 12:00:50 UTC
Description of problem:
======================
Currently there is no easy way of identifying hot and cold tier bricks easily from the CLI commands like volume info or volume status.
If at all the user wants to know which brick belongs to which tier, he/she needs to issue a getfattr to see the tier hash value, which is cumbersome.
It would be ideal to display the tiers and the respective bricks in the volume info command output itself.
For eg, the current o/p of "volume info " of a  distribute tiered volume is as below:
[root@rhs-client44 ~]# gluster v info tiervol10
 
Volume Name: tiervol10
Type: Tier
Volume ID: e6223c16-50fa-4916-b8b9-a83db6e8ec6c
Status: Started
Number of Bricks: 5 x 1 = 5
Transport-type: tcp
Bricks:
Brick1: rhs-client37:/pavanbrick2/tiervol10/hb1
Brick2: rhs-client44:/pavanbrick2/tiervol10/hb1
Brick3: rhs-client44:/pavanbrick1/tiervol10/b1
Brick4: rhs-client37:/pavanbrick1/tiervol10/b1
Brick5: rhs-client38:/pavanbrick1/tiervol10/b1


I would suggest something like below should be o/p:
[root@rhs-client44 ~]# gluster v info tiervol10
 
Volume Name: tiervol10
Type: Tier
Volume ID: e6223c16-50fa-4916-b8b9-a83db6e8ec6c
Status: Started
Number of Bricks: 5 x 1 = 5
Transport-type: tcp

Bricks:
HOT TIER:
Brick1: rhs-client37:/pavanbrick2/tiervol10/hb1
Brick2: rhs-client44:/pavanbrick2/tiervol10/hb1

COLD TIER:
Brick1: rhs-client44:/pavanbrick1/tiervol10/b1
Brick2: rhs-client37:/pavanbrick1/tiervol10/b1
Brick3: rhs-client38:/pavanbrick1/tiervol10/b1



Version-Release number of selected component (if applicable):
============================================================
3.7 upstream nightlies build http://download.gluster.org/pub/gluster/glusterfs/nightly/glusterfs/epel-6-x86_64/glusterfs-3.7dev-0.803.gitf64666f.autobuild/

glusterfs 3.7dev built on Mar 26 2015 01:04:24


How reproducible:
================
Easily reproducible


Steps to Reproduce:
1.create a distribute volume
2.attach a tier using attach-tier to the volume
3.issue a volume info or volume status command

Actual results:
==============
No easy way to identify cold/hot tier bricks


Expected results:
================
Enhance the volume info o/p to display hot and cold bricks dedicatedly.

Comment 1 Anand Avati 2015-04-22 06:28:52 UTC
REVIEW: http://review.gluster.org/10328 (cli/tiering: display hot tier, and cold tier separately) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-04-22 14:57:15 UTC
REVIEW: http://review.gluster.org/10328 (cli/tiering: display hot tier, and cold tier separately) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Dan Lambright 2015-04-22 16:54:43 UTC
*** Bug 1212400 has been marked as a duplicate of this bug. ***

Comment 4 Mohammed Rafi KC 2015-04-23 11:18:13 UTC
upstream patch : http://review.gluster.org/#/c/10328/

Comment 5 Anand Avati 2015-04-27 06:35:27 UTC
REVIEW: http://review.gluster.org/10328 (cli/tiering: display hot tier, and cold tier separately) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 6 Anand Avati 2015-04-29 13:06:12 UTC
REVIEW: http://review.gluster.org/10328 (cli/tiering: display hot tier, and cold tier separately) posted (#4) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 7 Anand Avati 2015-05-02 13:23:23 UTC
REVIEW: http://review.gluster.org/10328 (cli/tiering: display hot tier, and cold tier separately) posted (#5) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 8 Anand Avati 2015-05-03 11:01:05 UTC
REVIEW: http://review.gluster.org/10328 (cli/tiering: display hot tier, and cold tier separately) posted (#6) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 9 Anand Avati 2015-05-05 08:41:35 UTC
REVIEW: http://review.gluster.org/10328 (cli/tiering: display hot tier, and cold tier separately) posted (#7) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 10 Anand Avati 2015-05-08 14:14:02 UTC
REVIEW: http://review.gluster.org/10328 (cli/tiering: display hot tier, and cold tier separately) posted (#10) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 11 Anand Avati 2015-05-08 19:55:46 UTC
REVIEW: http://review.gluster.org/10328 (cli/tiering: display hot tier, and cold tier separately) posted (#11) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 12 Anand Avati 2015-05-08 21:37:23 UTC
REVIEW: http://review.gluster.org/10328 (cli/tiering: display hot tier, and cold tier separately) posted (#12) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 13 Anand Avati 2015-05-09 13:40:38 UTC
REVIEW: http://review.gluster.org/10328 (cli/tiering: display hot tier, and cold tier separately) posted (#15) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 14 Anand Avati 2015-05-10 03:59:00 UTC
REVIEW: http://review.gluster.org/10328 (cli/tiering: display hot tier, and cold tier separately) posted (#16) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 15 Niels de Vos 2015-05-15 13:00:02 UTC
This change should not be in "ON_QA", the patch posted for this bug is only available in the master branch and not in a release yet. Moving back to MODIFIED until there is an beta release for the next GlusterFS version.

Comment 16 Nagaprasad Sathyanarayana 2015-10-25 15:15:21 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 17 Niels de Vos 2016-06-16 12:45:56 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.