Bug 1212400 - Attach tier failing and messing up vol info
Summary: Attach tier failing and messing up vol info
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Dan Lambright
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1260923
TreeView+ depends on / blocked
 
Reported: 2015-04-16 10:35 UTC by Anoop
Modified: 2016-06-16 12:52 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 12:52:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Anoop 2015-04-16 10:35:45 UTC
Description of problem:
Attach tier is failing and also messing up the volume info (brick config)

Version-Release number of selected component (if applicable):

glusterfs-server-3.7dev-0.885.git0d36d4f.el6.x86_64


Steps to Reproduce:
1. Create a dispere volume
[root@dhcp35-166 ~]# gluster vol create volt1 disperse 6 redundancy 2 10.70.35.4:/b1 10.70.35.4:/b2 10.70.35.4:/b3 10.70.35.166:/b1 10.70.35.166:/b2 10.70.35.166:/b3 force

Volume Name: volt1
Type: Disperse
Volume ID: 2665b778-b7d9-4ace-94dd-d196bcd8d4ac
Status: Started
Number of Bricks: 1 x (4 + 2) = 6
Transport-type: tcp
Bricks:
Brick1: 10.70.35.4:/b1
Brick2: 10.70.35.4:/b2
Brick3: 10.70.35.4:/b3
Brick4: 10.70.35.166:/b1
Brick5: 10.70.35.166:/b2
Brick6: 10.70.35.166:/b3

2. Try attaching a tier (dist.rep) to the already created volume:
[root@dhcp35-166 ~]# gluster vol attach-tier volt1 replica 2 10.70.35.4:/b4 10.70.35.166:/b4 10.70.35.4:/b5 10.70.35.166:/b5 forcevolume add-brick: failed: /b5 is already part of a volume

NOTE: b5 is a fresh brick and not used before, so not sure about it's complaining 

3.Now check the volume status:
Volume Name: volt1
Type: Distributed-Disperse
Volume ID: 2665b778-b7d9-4ace-94dd-d196bcd8d4ac
Status: Started
Number of Bricks: 1 x (4 + 2) = 10
Transport-type: tcp
Bricks:
Brick1: 10.70.35.166:/b5
Brick2: 10.70.35.4:/b5
Brick3: 10.70.35.166:/b4
Brick4: 10.70.35.4:/b4
Brick5: 10.70.35.4:/b1
Brick6: 10.70.35.4:/b2
Brick7: 10.70.35.4:/b3
Brick8: 10.70.35.166:/b1
Brick9: 10.70.35.166:/b2
Brick10: 10.70.35.166:/b3

4. Shows some wierd o/p "1 x (4 + 2) = 10"


Expected results:
1. Attach tier should succeed or fail completely

Comment 1 Anand Avati 2015-04-22 14:57:17 UTC
REVIEW: http://review.gluster.org/10339 (cli/tiering: volume info should diplay details about tier) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Dan Lambright 2015-04-22 16:54:43 UTC
This is being fixed in a separate bug.

*** This bug has been marked as a duplicate of bug 1206546 ***

Comment 3 Anand Avati 2015-04-27 06:35:25 UTC
REVIEW: http://review.gluster.org/10339 (cli/tiering: volume info should diplay details about tier) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 4 Anand Avati 2015-04-29 13:06:07 UTC
REVIEW: http://review.gluster.org/10339 (cli/tiering: volume info should diplay details about tier) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 5 Anand Avati 2015-05-02 13:23:02 UTC
REVIEW: http://review.gluster.org/10339 (cli/tiering: volume info should display details about tier) posted (#4) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 6 Anand Avati 2015-05-05 08:41:27 UTC
REVIEW: http://review.gluster.org/10339 (cli/tiering: volume info should display details about tier) posted (#5) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 7 Anand Avati 2015-05-05 11:27:05 UTC
REVIEW: http://review.gluster.org/10339 (cli/tiering: volume info should display details about tier) posted (#6) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 8 Anand Avati 2015-05-08 21:37:12 UTC
REVIEW: http://review.gluster.org/10339 (cli/tiering: volume info should display details about tier) posted (#7) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 9 Anand Avati 2015-05-09 10:26:14 UTC
REVIEW: http://review.gluster.org/10339 (cli/tiering: volume info should display details about tier) posted (#8) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 10 Anand Avati 2015-05-09 13:39:53 UTC
REVIEW: http://review.gluster.org/10339 (cli/tiering: volume info should display details about tier) posted (#9) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 11 Anand Avati 2015-05-10 03:58:57 UTC
REVIEW: http://review.gluster.org/10339 (cli/tiering: volume info should display details about tier) posted (#10) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 12 Niels de Vos 2016-06-16 12:52:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.