Bug 1206841 (qtsingleapplication-qt5) - qtsingleapplication: Build for qt5
Summary: qtsingleapplication: Build for qt5
Keywords:
Status: CLOSED ERRATA
Alias: qtsingleapplication-qt5
Product: Fedora
Classification: Fedora
Component: qtsingleapplication
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL: https://forum.qt.io/topic/22460/solve...
Whiteboard:
Depends On: qtlockedfile-qt5
Blocks: 1091704 1206833 1217968
TreeView+ depends on / blocked
 
Reported: 2015-03-29 00:04 UTC by Raphael Groner
Modified: 2015-05-22 19:25 UTC (History)
5 users (show)

Fixed In Version: qtsingleapplication-2.6.1-17.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-22 17:57:32 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
MITK 17529 0 None None None Never

Description Raphael Groner 2015-03-29 00:04:06 UTC
Description of problem:
KDocker [1] v4.9 moved to Qt5 and depends on QtSingleApplication. It is FTBTS cause QtSingeApplication is built to require Qt4.

Version-Release number of selected component (if applicable):
2.6.1-11/2.6.1-12

How reproducible:
yes

Steps to Reproduce:
1. qmake-qt5 CONFIG+=qtsingleapplication
2.
3.

Actual results:
compiler error

Expected results:
available packages qtsingleapplication-qt5 and qtsingleapplication-qt5-devel (or named somehow the like) 

Additional info:

Comment 1 Raphael Groner 2015-03-31 10:07:38 UTC
Latest version of qtsingleapplication from Qt Solutions supports Qt5. MITK's copy just needs to be updated.

https://qt.gitorious.org/qt-solutions/qt-solutions/merge_requests/7

Comment 2 Fabio Alessandro Locati 2015-03-31 15:22:56 UTC
Current F22 version of source does support Qt5. The problem is the compilation. At the moment I'm not successing doing a package that compiles it for both qt4 and 5

Comment 3 Raphael Groner 2015-03-31 15:53:19 UTC
(In reply to Fabio Alessandro Locati from comment #2)
> Current F22 version of source does support Qt5. The problem is the
> compilation. At the moment I'm not successing doing a package that compiles
> it for both qt4 and 5

Maybe take a look to this example how pcmanfm was built for both qt versions:
http://pkgs.fedoraproject.org/cgit/pcmanfm-qt.git/commit/?id=92a2d83c9876cd89a10fda2a49124bce90ba1cae

Comment 4 Raphael Groner 2015-04-07 11:30:11 UTC
Qupzilla package with its conditional in the spec file [1] is also a good sample how to switch between both qt versions, if you do not want to keep qt4 builds in newer Fedoras.

[1] http://pkgs.fedoraproject.org/cgit/qupzilla.git/tree/qupzilla.spec

Comment 5 Raphael Groner 2015-04-25 16:24:18 UTC
I would be glad to help maintain this package to keep it at a current state, please approve commit access.

Comment 7 Fedora Update System 2015-04-27 12:52:40 UTC
qtsingleapplication-2.6.1-13.fc22, qtlockedfile-2.4-13.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/qtsingleapplication-2.6.1-13.fc22,qtlockedfile-2.4-13.fc22

Comment 8 Fedora Update System 2015-04-27 13:15:15 UTC
qtlockedfile-2.4-13.fc21, qtsingleapplication-2.6.1-14.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/qtsingleapplication-2.6.1-14.fc21,qtlockedfile-2.4-13.fc21

Comment 10 Fedora Update System 2015-04-28 13:15:42 UTC
Package qtlockedfile-2.4-13.fc21, qtsingleapplication-2.6.1-14.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qtlockedfile-2.4-13.fc21 qtsingleapplication-2.6.1-14.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7061/qtsingleapplication-2.6.1-14.fc21,qtlockedfile-2.4-13.fc21
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2015-05-04 10:11:10 UTC
qtsingleapplication-2.6.1-16.fc22,qtlockedfile-2.4-15.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/qtsingleapplication-2.6.1-16.fc22,qtlockedfile-2.4-15.fc22

Comment 12 Fedora Update System 2015-05-04 10:15:24 UTC
qtsingleapplication-2.6.1-16.fc21,qtlockedfile-2.4-15.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/qtsingleapplication-2.6.1-16.fc21,qtlockedfile-2.4-15.fc21

Comment 13 Fedora Update System 2015-05-22 17:57:32 UTC
qtsingleapplication-2.6.1-17.fc21, qtlockedfile-2.4-16.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.