Bug 1091704 - qupzilla bundles qtsingleapplication (and qtlockedfile)
Summary: qupzilla bundles qtsingleapplication (and qtlockedfile)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qupzilla   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL: https://github.com/QupZilla/qupzilla/...
Whiteboard:
Keywords: FutureFeature, Reopened
Depends On: qtsingleapplication-qt5 qtlockedfile-qt5
Blocks: DuplicSysLibsTracker
TreeView+ depends on / blocked
 
Reported: 2014-04-27 12:55 UTC by Ville Skyttä
Modified: 2018-03-07 05:45 UTC (History)
7 users (show)

Fixed In Version: qtsingleapplication-2.6.1-23.fc22
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-07 13:02:54 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Specfile patch (1.19 KB, patch)
2014-04-27 12:55 UTC, Ville Skyttä
no flags Details | Diff
Sources patch (477 bytes, patch)
2014-04-27 12:55 UTC, Ville Skyttä
no flags Details | Diff
specfile patch to unbundle qtsingleapplication (2.64 KB, patch)
2015-07-20 20:09 UTC, Raphael Groner
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Qt Bug Tracker QTBUG-44595 None None None Never
Red Hat Bugzilla 1209261 None None None Never
Red Hat Bugzilla 1551678 None None None Never

Internal Trackers: 1209261 1551678

Description Ville Skyttä 2014-04-27 12:55:12 UTC
Created attachment 890222 [details]
Specfile patch

https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
https://fedoraproject.org/wiki/Packaging:Treatment_Of_Bundled_Libraries

qupzilla is using a bundled version of qtsingleapplication (and its dependency, qtlockedfile). The bundled version is somewhat different than the system one and isn't switchable without code changes, but attached is two patches that constitute a start.

Comment 1 Ville Skyttä 2014-04-27 12:55:59 UTC
Created attachment 890223 [details]
Sources patch

Comment 2 Jaroslav Reznik 2015-03-03 15:44:37 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 3 Raphael Groner 2015-03-31 12:43:48 UTC
What's the state here? I may help as co-maintainer.

Comment 4 Raphael Groner 2015-04-06 20:46:01 UTC
Unbundling is not possible currently at least for a Qt5 build, until qtsingleapplication will be availabe also for Qt5, see bug #1206841.

Comment 5 Raphael Groner 2015-04-06 20:48:04 UTC
Same qt5 issue for qtlockedfile that BR: qt4-devel explicitly.

Comment 6 Raphael Groner 2015-04-26 11:35:07 UTC
qtsingleapplication and qtlockedfile are both fixed to build with qt5, see depending bugs. Let's wait till the patches are applied properly in PkgDB.

Comment 7 Raphael Groner 2015-05-21 17:12:26 UTC
Not possible to unbundle qtsingleapplication because upstream added some additional functionality directly into the source.
For instance, there's no setAppId method in unbundled qtsingleapplication.h file that is called from qupzilla code.
https://github.com/QupZilla/qupzilla/issues/1503

Comment 8 Thomas Spura 2015-05-21 17:59:13 UTC
Please leave this bug open until it is fully resolved. See the 'must' in this guideline section:
https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries#When_a_Bundled_Library_is_Discovered_Post-Review

Comment 9 Raphael Groner 2015-07-20 20:09:27 UTC
Created attachment 1054023 [details]
specfile patch to unbundle qtsingleapplication

Please apply this patch.

I've patched qtsingleapplication to provide the two new API functions as differences between qtsingleapplication upstream and qupzilla's embedded fork.

Comment 10 Raphael Groner 2015-07-20 20:12:00 UTC
Rex, we may provide an update in combination with the new qtsingleapplication-qt5. Could you do that?

Comment 11 Fedora Update System 2015-07-20 20:25:43 UTC
qtsingleapplication-2.6.1-21.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/qtsingleapplication-2.6.1-21.fc22

Comment 12 Fedora Update System 2015-07-20 20:39:24 UTC
qtsingleapplication-2.6.1-21.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/qtsingleapplication-2.6.1-21.fc21

Comment 13 Raphael Groner 2015-07-22 06:54:08 UTC
There's a typo in the patch. Needs to be CONFIG+=QtSingleApplication (without spaces).

Comment 14 Fedora Update System 2015-07-22 19:15:08 UTC
qupzilla-1.8.6-6.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/qupzilla-1.8.6-6.fc22

Comment 15 Fedora Update System 2015-07-22 19:44:59 UTC
qupzilla-1.8.6-6.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/qupzilla-1.8.6-6.fc21

Comment 16 Fedora Update System 2015-07-24 21:23:53 UTC
qtsingleapplication-2.6.1-23.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/qtsingleapplication-2.6.1-23.fc22

Comment 17 Fedora Update System 2015-07-24 21:41:30 UTC
qtsingleapplication-2.6.1-23.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/qtsingleapplication-2.6.1-23.fc21

Comment 18 Fedora Update System 2015-07-29 01:36:08 UTC
Package qupzilla-1.8.6-6.fc21, qtsingleapplication-2.6.1-21.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qupzilla-1.8.6-6.fc21 qtsingleapplication-2.6.1-21.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-11952/qtsingleapplication-2.6.1-21.fc21,qupzilla-1.8.6-6.fc21
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2015-08-07 13:02:54 UTC
qupzilla-1.8.6-6.fc21, qtsingleapplication-2.6.1-21.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2015-08-07 13:09:10 UTC
qtsingleapplication-2.6.1-21.fc22, qupzilla-1.8.6-6.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2015-08-10 09:56:02 UTC
qtsingleapplication-2.6.1-23.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2015-08-10 09:57:26 UTC
qtsingleapplication-2.6.1-23.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.