Bug 1206862 - Boot EC requirement - Hotkeys not functional on Asus X550ZE
Boot EC requirement - Hotkeys not functional on Asus X550ZE
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
RejectedBlocker
:
: 1338082 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-28 21:06 EDT by Luya Tshimbalanga
Modified: 2016-11-07 21:35 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-07 21:35:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg grouped by hotkey (2.56 KB, text/plain)
2015-03-28 21:06 EDT, Luya Tshimbalanga
no flags Details
Journal output from Fedora 22 Beta TC6 (547.88 KB, text/plain)
2015-04-02 15:56 EDT, Luya Tshimbalanga
no flags Details
Journal output from Fedora 22 Beta updated on 20140429 (1.48 KB, text/plain)
2015-04-30 04:38 EDT, Luya Tshimbalanga
no flags Details
Xorg log (46.49 KB, text/plain)
2015-07-04 13:02 EDT, Luya Tshimbalanga
no flags Details
Xorg log (47.01 KB, text/plain)
2015-07-08 23:30 EDT, ubegun
no flags Details
Xorg,log on 20150802 (44.89 KB, text/plain)
2015-08-03 01:30 EDT, Luya Tshimbalanga
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 115021 None None None 2016-03-20 15:15 EDT

  None (edit)
Description Luya Tshimbalanga 2015-03-28 21:06:53 EDT
Created attachment 1007899 [details]
dmesg grouped by hotkey

Description of problem:
Installed Fedora 22 Beta TC5 has non-functional "Fn" keys neeed for backlight, volume and suspend on ASUS X550ZE laptop


Version-Release number of selected component (if applicable):
0.13.0

How reproducible:
Always

Steps to Reproduce:
1. Fresh instalation
2.
3.

Actual results:
All Fn keys not functional

Expected results:
All Fn keys work as intended

Additional info:
Test done on ASUS X550ZE
http://www.asus.com/Notebooks_Ultrabooks/X550ZE/specifications/

See attachment for information about hotkey
Comment 1 Luya Tshimbalanga 2015-04-02 15:56:08 EDT
Created attachment 1010336 [details]
Journal output from Fedora 22 Beta TC6

Revelant report including WMI detection.
Comment 2 Luya Tshimbalanga 2015-04-02 15:59:27 EDT
Switch to the right component.
Comment 3 Luya Tshimbalanga 2015-04-05 20:47:00 EDT
More details about the wmi module from cat /proc/bus/input/devices

I: Bus=0019 Vendor=0000 Product=0000 Version=0000
N: Name="Asus WMI hotkeys"
P: Phys=asus-nb-wmi/input0
S: Sysfs=/devices/platform/asus-nb-wmi/input/input11
U: Uniq=
H: Handlers=kbd event10 rfkill 
B: PROP=0
B: EV=100013
B: KEY=80000 0 800000000000 0 0 a1606f00900000 8200027800501000 e000000000000 0
B: MSC=10
Comment 4 Luya Tshimbalanga 2015-04-07 19:34:38 EDT
It looks like WMI is active but something fails to work

$ dmesg | egrep -i '(asus|wmi)'
[    0.000000] DMI: ASUSTeK COMPUTER INC. X550ZE/X550ZE, BIOS 204 11/20/2014
[    0.000000] ACPI: RSDP 0x000000006DBC4000 000024 (v02 _ASUS_)
[    0.000000] ACPI: XSDT 0x000000006DBC4098 0000B4 (v01 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: FACP 0x000000006DBD3E28 00010C (v05 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: DSDT 0x000000006DBC41E0 00FC46 (v02 _ASUS_ Notebook 00000204 INTL 20051117)
[    0.000000] ACPI: APIC 0x000000006DBD3F38 00007E (v03 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: FPDT 0x000000006DBD3FB8 000044 (v01 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: ECDT 0x000000006DBD4000 0000C1 (v01 _ASUS_ Notebook 00000001 OEM. 00000003)
[    0.000000] ACPI: MCFG 0x000000006DBD40C8 00003C (v01 _ASUS_ Notebook 01072009 MSFT 00010013)
[    0.000000] ACPI: MSDM 0x000000006DBD4108 000055 (v03 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: HPET 0x000000006DBD4160 000038 (v01 _ASUS_ Notebook 01072009 AMI  00000005)
[    0.000000] ACPI: UEFI 0x000000006DBD4198 000042 (v01 _ASUS_ Notebook 01072009      00000000)
[    0.000000] ACPI: VFCT 0x000000006DBD41E0 00F684 (v01 _ASUS_ Notebook 00000001 AMD  31504F47)
[    0.000000] ACPI: BGRT 0x000000006DBE3868 000038 (v00 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.804164] EFI: Loaded cert 'ASUSTeK Notebook SW Key Certificate: b8e581e4df77a5bb4282d5ccfc00c071' linked to '.system_keyring'
[    0.804444] EFI: Loaded cert 'ASUSTeK MotherBoard SW Key Certificate: da83b990422ebc8c441f8d8b039a65a2' linked to '.system_keyring'
[    6.140408] ATOM BIOS: Asus
[   17.355726] wmi: Mapper loaded
[   18.116334] asus_wmi: ASUS WMI generic driver loaded
[   18.831885] asus_wmi: Initialization: 0x1
[   18.832037] asus_wmi: BIOS WMI version: 8.1
[   18.832152] asus_wmi: SFUN value: 0x4a0875
[   18.834440] input: Asus WMI hotkeys as /devices/platform/asus-nb-wmi/input/input17
[   18.838054] asus_wmi: Backlight controlled by ACPI video driver
Comment 5 Luya Tshimbalanga 2015-04-10 12:57:15 EDT
Same result from F22 beta RC1

$ dmesg | egrep -i '(asus|wmi)'
[    0.000000] DMI: ASUSTeK COMPUTER INC. X550ZE/X550ZE, BIOS 204 11/20/2014
[    0.000000] ACPI: RSDP 0x000000006DBC4000 000024 (v02 _ASUS_)
[    0.000000] ACPI: XSDT 0x000000006DBC4098 0000B4 (v01 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: FACP 0x000000006DBD3E28 00010C (v05 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: DSDT 0x000000006DBC41E0 00FC46 (v02 _ASUS_ Notebook 00000204 INTL 20051117)
[    0.000000] ACPI: APIC 0x000000006DBD3F38 00007E (v03 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: FPDT 0x000000006DBD3FB8 000044 (v01 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: ECDT 0x000000006DBD4000 0000C1 (v01 _ASUS_ Notebook 00000001 OEM. 00000003)
[    0.000000] ACPI: MCFG 0x000000006DBD40C8 00003C (v01 _ASUS_ Notebook 01072009 MSFT 00010013)
[    0.000000] ACPI: MSDM 0x000000006DBD4108 000055 (v03 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.000000] ACPI: HPET 0x000000006DBD4160 000038 (v01 _ASUS_ Notebook 01072009 AMI  00000005)
[    0.000000] ACPI: UEFI 0x000000006DBD4198 000042 (v01 _ASUS_ Notebook 01072009      00000000)
[    0.000000] ACPI: VFCT 0x000000006DBD41E0 00F684 (v01 _ASUS_ Notebook 00000001 AMD  31504F47)
[    0.000000] ACPI: BGRT 0x000000006DBE3868 000038 (v00 _ASUS_ Notebook 01072009 AMI  00010013)
[    0.807914] EFI: Loaded cert 'ASUSTeK Notebook SW Key Certificate: b8e581e4df77a5bb4282d5ccfc00c071' linked to '.system_keyring'
[    0.808195] EFI: Loaded cert 'ASUSTeK MotherBoard SW Key Certificate: da83b990422ebc8c441f8d8b039a65a2' linked to '.system_keyring'
[    6.101307] ATOM BIOS: Asus
[   14.905084] wmi: Mapper loaded
[   16.307966] asus_wmi: ASUS WMI generic driver loaded
[   16.314298] asus_wmi: Initialization: 0x1
[   16.314397] asus_wmi: BIOS WMI version: 8.1
[   16.314476] asus_wmi: SFUN value: 0x4a0875
[   16.316017] input: Asus WMI hotkeys as /devices/platform/asus-nb-wmi/input/input14
[   16.319041] asus_wmi: Backlight controlled by ACPI video driver

It would be nice to fix before Fedora 22 release. If more info is needed, I will be ready to provide them.
Comment 6 Fedora Blocker Bugs Application 2015-04-10 13:33:36 EDT
Proposed as a Blocker for 22-final by Fedora user luya using the blocker tracking app because:

 ASUS wmi Hotkeys is correctly detected and activated but user is unable to use hotkeys (via "Fn"). Output fail to work as the xev output shows nothing. Test done on newer ASUS laptop, in this case X500ZE.
Comment 7 Josh Boyer 2015-04-10 13:35:24 EDT
It would be nice, but I really don't think this is blocker criteria.  Fn keys fail to work on one laptop or another with essentially every upstream kernel release.  I don't think this model is special.
Comment 8 Luya Tshimbalanga 2015-04-10 14:08:01 EDT
is it for every newer model Fn keys fail to work? For what I understand, there should be a generic Fn keys input allowing decent functionality for those laptop series.
Comment 9 Petr Schindler 2015-04-20 13:51:26 EDT
Discussed at today's blocker review meeting [1].

This bug was rejected as Final Blocker - this is hardware-specific (model or manufacturer) and in non-blocking functionality in any case

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-04-20/
Comment 10 Luya Tshimbalanga 2015-04-30 04:38:04 EDT
Created attachment 1020452 [details]
Journal output from Fedora 22 Beta updated on 20140429
Comment 11 Luya Tshimbalanga 2015-06-05 13:22:40 EDT
Latest update on F22 kernel returns same result. Basically the device was detected and correctly set up but inability to use Fn key. Note the laptop runs on EFI mode which was the default.
Comment 12 Luya Tshimbalanga 2015-07-04 13:02:07 EDT
Created attachment 1046058 [details]
Xorg log

Include Xorg log containing information about ASUS wmi detected
Comment 13 ubegun 2015-07-08 23:30:21 EDT
Created attachment 1050094 [details]
Xorg log

I have same result. Hotkeys doesn't work.
Comment 14 Luya Tshimbalanga 2015-08-03 01:30:07 EDT
Created attachment 1058647 [details]
Xorg,log on 20150802

Include the latest log. Setting secure boot off has no effect on the input following one suggestion. The Asus WMI is running fine but no Fn shortcut input.

Using search engine, here is the modinfo:

# modinfo asus-nb-wmi
filename:       /lib/modules/4.1.3-200.fc22.x86_64/kernel/drivers/platform/x86/asus-nb-wmi.ko.xz
alias:          wmi:0B3CBB35-E3C2-45ED-91C2-4C5A6D195D1C
license:        GPL
description:    Asus Notebooks WMI Hotkey Driver
author:         Corentin Chary <corentin.chary@gmail.com>
depends:        asus-wmi
intree:         Y
vermagic:       4.1.3-200.fc22.x86_64 SMP mod_unload 
signer:         Fedora kernel signing key
sig_key:        BC:F6:34:83:4A:40:E6:EE:ED:CA:2F:E2:7C:48:D1:F1:22:10:59:E2
sig_hashalgo:   sha256
parm:           wapf:WAPF value (uint)
Comment 15 Luya Tshimbalanga 2015-09-26 21:22:59 EDT
Trying kernel 4.2.1-300.fc23.x86_64

$ modinfo asus-nb-wmi
filename:       /lib/modules/4.2.1-300.fc23.x86_64/kernel/drivers/platform/x86/asus-nb-wmi.ko.xz
alias:          wmi:0B3CBB35-E3C2-45ED-91C2-4C5A6D195D1C
license:        GPL
description:    Asus Notebooks WMI Hotkey Driver
author:         Corentin Chary <corentin.chary@gmail.com>
depends:        asus-wmi
intree:         Y
vermagic:       4.2.1-300.fc23.x86_64 SMP mod_unload 
signer:         Fedora kernel signing key
sig_key:        45:14:26:FB:A0:20:93:5C:8E:6E:21:8F:E9:EC:18:6A:9E:65:6E:57
sig_hashalgo:   sha256
parm:           wapf:WAPF value (uint)

Reading the source code of asus-nb-wmi:
http://lxr.free-electrons.com/source/drivers/platform/x86/asus-nb-wmi.c

It looks like wapf value is unassigned to my current laptop (X550ZE) which probably explain why Fn keys does not work. According to the code, the wapf value should be set to "0" because the laptop have both Bluetooth and Wifi.
Comment 16 Luya Tshimbalanga 2015-10-16 13:26:27 EDT
Bumped to rawhide as the Fn key fails to work.
Comment 17 Luya Tshimbalanga 2015-11-03 23:07:28 EST
Update after running Fedora 23. Fn only works with the following hotkeys:
Pgup, Pgdn, End, Home

Other hotkeys for media, backlight, suspend failed to work. Perhaps having some help from ASUS themselves will be handy. I have contacted the author for that module asus-wmi which is himself unable to reach out ASUS. It will be nice kernel developers contact them to fix that quirk.
Comment 18 Luya Tshimbalanga 2016-08-30 20:34:49 EDT
Working with upstream revealed the bug related to ACPI due to a change the BIOS scheme found inside ASUS laptop i.e X550Z in my case. Once that cause figured out, all functionality from keybord to lid is nearly restored. See explanation on 
https://bugzilla.kernel.org/show_bug.cgi?id=115021#c54

I will leave this bug open until the fix is fully implemented upstream.
Comment 19 Luya Tshimbalanga 2016-08-30 21:46:56 EDT
*** Bug 1338082 has been marked as a duplicate of this bug. ***
Comment 20 Luya Tshimbalanga 2016-09-17 05:30:52 EDT
Current status of fix upstream:
https://patchwork.kernel.org/patch/9318649/

It looks like it will land on next kernel 4.8.0rcx, I will test the next release when available.
Comment 21 Luya Tshimbalanga 2016-11-07 21:35:21 EST
The fix landed in the upstream kernel 4.9:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=2a5708409e4e05446eb1a89ecb48641d6fd5d5a9

I am closing this report as Rawhide will get fix accessible via building system

Note You need to log in before you can comment on or make changes to this bug.