Bug 120705 - /sbin/lvm depends on /usr/lib/libreadline.so.4 so it can't run if /usr is a logical volume, boot fails
/sbin/lvm depends on /usr/lib/libreadline.so.4 so it can't run if /usr is a l...
Status: CLOSED DUPLICATE of bug 120458
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Stephen Tweedie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 04:50 EDT by Carl-Johan Kjellander
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-26 13:03:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl-Johan Kjellander 2004-04-13 04:50:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
A machine with fedora core 2 test 2 updated with the latest
development packages and /usr (and /home and /var) on a logical
volume fails to boot.

/sbin/lvm should not not be linked to anything in /usr/lib since then
it can't set up /usr on which some of it's libs are.


Version-Release number of selected component (if applicable):
lvm2-2.00.11-1.3

How reproducible:
Always

Steps to Reproduce:
Install fedora core 2 test 2 with /usr on a logical lvm2 volume.

Actual Results:  lvm fails to run since it needs 
/usr/lib/libreadline.so.4 so /usr can be mounted and the boot
fails.

Expected Results:  lvm should not depend on anything in /usr and it 
should mount /usr on the logical volume.

Additional info:

As you can see lvm from lvm2-2.00.11-1.3 and also 
lvm2-2.00.10-1.3.i386.rpm contains libs in /usr/lib.

# ldd /sbin/lvm
        libdevmapper.so.1.00 => /lib/libdevmapper.so.1.00 (0x00101000)
        libreadline.so.4 => /usr/lib/libreadline.so.4 (0x055be000)
        libselinux.so.1 => /lib/libselinux.so.1 (0x00115000)
        libncurses.so.5 => /usr/lib/libncurses.so.5 (0x0557c000)
        libc.so.6 => /lib/tls/libc.so.6 (0x009b0000)
        libgpm.so.1 => /usr/lib/libgpm.so.1 (0x0098c000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x00998000)
        libm.so.6 => /lib/tls/libm.so.6 (0x00ace000)

This is how the old package from test2 is linked:

# ldd /sbin/lvm
        libdevmapper.so.1.00 => /lib/libdevmapper.so.1.00 (0x007ff000)
        libselinux.so.1 => /lib/libselinux.so.1 (0x00a71000)
        libdl.so.2 => /lib/libdl.so.2 (0x00111000)
        libc.so.6 => /lib/tls/libc.so.6 (0x00827000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x007e7000)

Downgrading to the old package fixed it so it would boot again.
Comment 1 Miloslav Trmac 2004-04-13 07:37:53 EDT

*** This bug has been marked as a duplicate of 120458 ***

Note You need to log in before you can comment on or make changes to this bug.