Bug 120712 - mozilla seg faults with __static_initialization_and_destruction_0
mozilla seg faults with __static_initialization_and_destruction_0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
http://gcc.gnu.org/bugzilla/show_bug....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 09:20 EDT by Andrew Schultz
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 03:54:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Schultz 2004-04-13 09:20:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040411

Description of problem:
Mozilla seg faults during startup when compiled with gcc-3.3.3-6 with
__static_initialization_and_destruction_0 at the top of the stack. 
The problem is described in Mozilla bug 238368, and was filed with gcc
as bug 14640:

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=14640

which has been fixed upstream.

Version-Release number of selected component (if applicable):
gcc-c++-3.3.3-6

How reproducible:
Always

Steps to Reproduce:
1.compile Mozilla
2.start Mozilla

Actual Results:  segmentation fault

Expected Results:  startup
Comment 1 Jakub Jelinek 2004-04-14 03:54:24 EDT
Should be fixed in gcc-c++-3.3.3-7.
Comment 2 Andrew Schultz 2004-04-16 23:23:23 EDT
you are probably already aware of this, but this bug also affects
gcc34-c++-3.4.0-0.9

Note You need to log in before you can comment on or make changes to this bug.