Bug 1207566 - Should change the "bond_setup" to "bond" in /usr/libexec/ovirt-init-functions.sh
Summary: Should change the "bond_setup" to "bond" in /usr/libexec/ovirt-init-functions.sh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Douglas Schilling Landgraf
QA Contact: wanghui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-31 08:09 UTC by wanghui
Modified: 2016-03-09 14:20 UTC (History)
11 users (show)

Fixed In Version: ovirt-node-3.3.0-0.4.20150906git14a6024.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:20:46 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 39733 master MERGED ovirt-init-functions: Update comment about bond_setup Never

Description wanghui 2015-03-31 08:09:59 UTC
Description of problem:
According to bug#1156343, the bonding parameters in auto-installation change to 'bond={bond_name}:{list_of_interfaces}'. So we should change the the "bond_setup" to "bond" in /usr/libexec/ovirt-init-functions.sh.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.1-20150327.0.el7ev
ovirt-node-3.2.2-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-7.1-20150327.0.el7ev
2. Check the auto installation parameters in /usr/libexec/ovirt-init-functions.sh

Actual results:
1. It shows bond parameters as follows.
   #   bond_setup=<bondname>:<bondslaves>:[:<options>]

Expected results:
1. It should show bond parameter as follows.
   #   bond=<bondname>:<bondslaves>:[:<options>]

Additional info:

Comment 1 Fabian Deutsch 2015-04-01 11:11:29 UTC
IIUIC this is only about a updating a source code comment.

Comment 3 wanghui 2015-10-28 08:43:58 UTC
Test version:
rhev-hypervisor7-7.2-20151025.0.el7ev
ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch

Test steps:
1. Install rhev-hypervisor7-7.2-20151025.0.el7ev
2. Check the auto installation parameters in /usr/libexec/ovirt-init-functions.sh

Actual results:
1. It shows bond parameters as follows.
   #   bond_setup=<bondname>:<bondslave,bondslave>:[:<option_arg,option_arg>]
   #   Use bond for node based on RHEL/CentOS 7 or higher
   #   Use bond_setup for node based on RHEL/CentOS 6

But as the merged patch shows it should change to "bond or bond_setup=<bondname>:<bondslaves>:[:<options>]" which is difference. 

Hi Douglas, 

I want to check with you that is there any changes after the patch merged? If also, I'd like to change the "bond_setup=" to "bond or bond_setup=" to make that more clear.

Thanks,
Hui Wang

Comment 4 Douglas Schilling Landgraf 2015-10-28 12:46:23 UTC
(In reply to wanghui from comment #3)
> Test version:
> rhev-hypervisor7-7.2-20151025.0.el7ev
> ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch
> 
> Test steps:
> 1. Install rhev-hypervisor7-7.2-20151025.0.el7ev
> 2. Check the auto installation parameters in
> /usr/libexec/ovirt-init-functions.sh
> 
> Actual results:
> 1. It shows bond parameters as follows.
>    #   bond_setup=<bondname>:<bondslave,bondslave>:[:<option_arg,option_arg>]
>    #   Use bond for node based on RHEL/CentOS 7 or higher
>    #   Use bond_setup for node based on RHEL/CentOS 6
> 
> But as the merged patch shows it should change to "bond or
> bond_setup=<bondname>:<bondslaves>:[:<options>]" which is difference. 
> 
> Hi Douglas, 
> 
> I want to check with you that is there any changes after the patch merged?
> If also, I'd like to change the "bond_setup=" to "bond or bond_setup=" to
> make that more clear.
> 

I see this patch https://gerrit.ovirt.org/#/c/33348/ got merged after.
Ryan, what do you think about Wanghui comment#3?

Thanks!

Comment 5 Ryan Barry 2015-10-28 14:16:01 UTC
I have no qualms with changing the comment back, as long as it's clear which one should be used on EL6, and which on EL7

Comment 6 wanghui 2015-11-24 06:05:39 UTC
According to comment#5, the expected change should be as follows.

#   bond_setup=<bondname>:<bondslave,bondslave>:[:<option_arg,option_arg>]
#   Use bond for node based on RHEL/CentOS 7 or higher
#   Use bond_setup for node based on RHEL/CentOS 6

Verified this issue on rhev-hypervisor7-7.2-20151112.1.el7ev(ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch).

Comment 8 errata-xmlrpc 2016-03-09 14:20:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.