Bug 1207612 - Auto install: rhevm doesn't get ip address when using BOOTIF=interface
Summary: Auto install: rhevm doesn't get ip address when using BOOTIF=interface
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-3.6.0-rc3
: 3.6.0
Assignee: Douglas Schilling Landgraf
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks: 1193058 1213873
TreeView+ depends on / blocked
 
Reported: 2015-03-31 10:12 UTC by cshao
Modified: 2016-03-09 14:20 UTC (History)
11 users (show)

Fixed In Version: ovirt-node-3.2.2-3.el6 ovirt-node-3.2.2-3.el7 rhev-hypervisor6-6.6-20150402.0 rhev-hypervisor7-7.1-20150402.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1213873 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:20:52 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
engine.log (24.70 KB, text/plain)
2015-04-03 07:20 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1200207 high CLOSED Autoinstall RHEV-H - rhevm doesn't get ip address when using BOOTIF=$MACAddress 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC

Internal Links: 1200207

Comment 1 Fabian Deutsch 2015-03-31 10:22:39 UTC
This might be related to (or be a race between) the unified persistence of vdsm and the vdsm configure hook in the ovirt-node-plugin-vdsm package.

We should try to understand the flow during the installation.
And we need to understan dif the bug is during installation - or during the first boot (where the vdsm-tool configure call takes place).

Comment 2 Ying Cui 2015-03-31 12:23:43 UTC
No this issue in RHEV-H 7.0 for RHEV 3.5 build rhevh-7.0-20150128.0.1.el7ev.iso,
so it's a regression bug.

Comment 3 Yaniv Lavi 2015-03-31 14:33:45 UTC
Isn't this a dup of a but that was already resolved?

Comment 4 Fabian Deutsch 2015-03-31 14:39:41 UTC
The other (bug 1200207) was about using BOOTIF=<macaddr> , this is about using BOOTIF=<ifname>.

The <ifname> solution worked until recently, and there were no changes in that area on the node side.
It might be possibly related to the race we see with the vdsm hook.

Comment 5 Fabian Deutsch 2015-04-02 09:00:52 UTC
Our testign showed that builds with a more recent vdsm version do not have this bug anymore, probably again a symptom of the recent vdsm/hook race, which is fixed in the next RHEV-H build.

Setting it to TestOnly for now, and will move it to ON_QA once a build is available.

Comment 6 cshao 2015-04-03 07:20:18 UTC
Test version:
rhev-hypervisor7-7.1-20150402.0.el7ev    
ovirt-node-3.2.2-3.el7.noarch

Test steps:
1. Boot from PXE
2. Auto install RHEV-H with below parameters
BOOTIF=enp1s0 storage_init=/dev/sda management_server=$RHEV-M_IP  adminpw=xxxxxx firstboot
3. Login the hypervisor and check the nic status.
4. Approve the hypervisor in RHEVM web UI.

Test results:
1. Auto install: rhevm can get ip address when using BOOTIF=interface
2. Failed to approve the hypervisor.

Message: Host hp-z600-03.qe.lab.eng.nay.redhat.com does not comply with the cluster cshao_intel networks, the following networks are missing on host: 'rhevm'

Details info please see engine.log

Comment 7 cshao 2015-04-03 07:20:58 UTC
Created attachment 1010518 [details]
engine.log

Comment 8 cshao 2015-04-03 07:23:49 UTC
According #c6, change status to ASSIGNED.

Comment 9 cshao 2015-04-03 07:26:44 UTC
I noticed that the fixed in version: ovirt-node-3.2.2-3.el6 ovirt-node-3.2.2-3.el7 rhev-hypervisor6-6.6-20150402.0 rhev-hypervisor7-7.1-20150402.0,
but it not fixed yet, so I have to reassign this bug

Comment 10 Douglas Schilling Landgraf 2015-04-06 14:10:41 UTC
Hello shaochen,

(In reply to shaochen from comment #6)
> Test version:
> rhev-hypervisor7-7.1-20150402.0.el7ev    
> ovirt-node-3.2.2-3.el7.noarch
> 
> Test steps:
> 1. Boot from PXE
> 2. Auto install RHEV-H with below parameters
> BOOTIF=enp1s0 storage_init=/dev/sda management_server=$RHEV-M_IP 
> adminpw=xxxxxx firstboot
> 3. Login the hypervisor and check the nic status.
> 4. Approve the hypervisor in RHEVM web UI.
> 
> Test results:
> 1. Auto install: rhevm can get ip address when using BOOTIF=interface
> 2. Failed to approve the hypervisor.
> 
> Message: Host hp-z600-03.qe.lab.eng.nay.redhat.com does not comply with the
> cluster cshao_intel networks, the following networks are missing on host:
> 'rhevm'
> 
> Details info please see engine.log

With the image rhev-hypervisor7-7.1-20150402.0.el7ev  I cannot reproduce the original report anymore. I can do autoinstall/autoregister and approve without any issue. Do you mind to share your vdsm and vdsm-reg logs from the node?

Thanks!

Comment 11 cshao 2015-04-07 06:25:24 UTC
> With the image rhev-hypervisor7-7.1-20150402.0.el7ev  I cannot reproduce the
> original report anymore. I can do autoinstall/autoregister and approve
> without any issue. Do you mind to share your vdsm and vdsm-reg logs from the
> node?
> 
> Thanks!

Re-test this bug with other RHEVM env, the issue has been fixed. Autoinstall & autoregister and approve without any issue. Seem the #c6's issue was occurred due to the broken RHEVM. please ignore it.

Test version:
rhev-hypervisor7-7.1-20150402.0.el7ev    
ovirt-node-3.2.2-3.el7.noarch

Test steps:
1. Boot from PXE
2. Auto install RHEV-H with below parameters
BOOTIF=enp1s0/enp63s0 storage_init=/dev/sda management_server=$RHEV-M_IP  adminpw=xxxxxx firstboot
3. Login the hypervisor and check the nic status.
4. Approve the hypervisor in RHEVM web UI.

Test results:
1. Auto install: rhevm can get ip address when using BOOTIF=interface
2. Approve the hypervisor can succeed.

So the bug has been fixed. I will verify this bug after bug status change to ON_QA.

Thanks!

Comment 13 cshao 2015-11-11 09:56:22 UTC
Test version:
rhev-hypervisor7-7.2-20151104.0
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch

Test steps:
1. Boot from PXE
2. Auto install RHEV-H with below parameters
BOOTIF=enp63s0/em1 storage_init=/dev/sda management_server=$RHEV-M_IP  adminpw=xxxxxx firstboot
3. Login the hypervisor and check the nic status.
4. Approve RHEV-H in RHEV-M side

Test results:
1. rhevm can get ip address when using BOOTIF=interface.
2. RHEV-H can up in RHEV-M side.

So the bug is fixed, change bug status to VERIFIED.

Comment 14 cshao 2015-11-11 10:21:57 UTC
Bug 1280241 can trace the issue: Network status shows "Unknown ovirtmgmt" after register to rhevm3.6

Comment 16 errata-xmlrpc 2016-03-09 14:20:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.