Bug 1280241 - Network status shows "Unknown ovirtmgmt" after register to rhevm3.6
Network status shows "Unknown ovirtmgmt" after register to rhevm3.6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium
: ovirt-3.6.2
: ---
Assigned To: Ryan Barry
wanghui
:
: 1282313 1291608 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 05:11 EST by wanghui
Modified: 2016-03-30 10:11 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.6.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:43:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot for status page (46.92 KB, image/png)
2015-11-11 05:11 EST, wanghui
no flags Details
sosreport (5.73 MB, application/x-xz)
2015-11-12 03:53 EST, wanghui
no flags Details
output of ifconfig (1.28 KB, text/plain)
2015-11-12 03:54 EST, wanghui
no flags Details
vm-up-down (161.88 KB, image/png)
2016-02-24 00:57 EST, cshao
no flags Details
re-verify-log (1.16 MB, application/x-gzip)
2016-02-24 00:58 EST, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49051 master ABANDONED utils/network: NIC() set config.bridge 2016-01-11 11:25 EST
oVirt gerrit 50555 master ABANDONED sync_mgmt should return if there's an exception 2016-01-12 10:06 EST
oVirt gerrit 51560 master MERGED Sometimes BridgedNIC gets called with a bridge. Be smarter 2016-01-12 10:46 EST
oVirt gerrit 51742 ovirt-3.6 MERGED Sometimes BridgedNIC gets called with a bridge. Be smarter 2016-01-12 10:47 EST
oVirt gerrit 51756 master MERGED Sometimes BridgedNIC gets called with a bridge. Be smarter 2016-01-12 15:21 EST
oVirt gerrit 51758 ovirt-3.6 MERGED Sometimes BridgedNIC gets called with a bridge. Be smarter 2016-01-12 15:22 EST
oVirt gerrit 53684 master MERGED Bridge.slave_for_nic needs to exclude vnet devices 2016-03-30 07:04 EDT
oVirt gerrit 55486 ovirt-3.6 MERGED Bridge.slave_for_nic needs to exclude vnet devices 2016-03-30 13:48 EDT

  None (edit)
Description wanghui 2015-11-11 05:11:47 EST
Created attachment 1092634 [details]
Screenshot for status page

Description of problem:
It shows "Networking: Unknown ovirtmgmt" in status page after register to rhevm3.6 succeed. 

Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20151104.0.e17ev
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
ovirt-node-plugin-vdsm-0.6.1-2.el7ev.noarch 

How reproducible:
100%

Steps to Reproduce:
1. TUI clean install rhevh
2. Login rhevh, setup network via dhcp
3. Register to rhevm3.6 

Actual results:
1. After step3, it shows "Networking: Unknown ovirtmgmt" in status page. 

Expected results:
1.After step3, it should show "Networking: Connected ovirtmgmt" in status page. 

Additional info:
Comment 1 Fabian Deutsch 2015-11-11 08:41:31 EST
Please attach the sosreport.

We need to see if there are ifcfg files and the NIC has an IP.
Comment 2 wanghui 2015-11-12 03:53 EST
Created attachment 1093062 [details]
sosreport
Comment 3 wanghui 2015-11-12 03:54 EST
Created attachment 1093063 [details]
output of ifconfig
Comment 4 Fabian Deutsch 2015-11-17 03:10:03 EST
This is not nice, but a TUI only issue, thus lowering thej priority.
Comment 5 Fabian Deutsch 2015-11-23 08:42:59 EST
*** Bug 1282313 has been marked as a duplicate of this bug. ***
Comment 7 Huijuan Zhao 2015-12-14 22:14:28 EST
Also encounter this issue, but a bit different in rhev-hypervisor-7-7.2-20151210.1.e17ev.

After rhevh register to rhevm successful, it shows "Networking: Unknown" in status page, and it shows "Unconfigured" for NIC in Network page.

Test Steps:
1. TUI clean install rhevh
2. Login rhevh, setup network via dhcp
3. Register to rhevm3.6 

Actual results:
1. After step3, it shows "Networking: Unknown" in status page, and it shows "Unconfigured" for NIC in Network page.

Expected results:
1.After step3, it should show "Networking: Connected ovirtmgmt" in status page, and it shows "Managed" for NIC in Network page.
Comment 8 Ying Cui 2015-12-14 23:24:45 EST
(In reply to Huijuan Zhao from comment #7)
> Also encounter this issue, but a bit different in
> rhev-hypervisor-7-7.2-20151210.1.e17ev.
> 
> After rhevh register to rhevm successful, it shows "Networking: Unknown" in
> status page, and it shows "Unconfigured" for NIC in Network page.
> 
> Test Steps:
> 1. TUI clean install rhevh
> 2. Login rhevh, setup network via dhcp
> 3. Register to rhevm3.6 
> 
> Actual results:
> 1. After step3, it shows "Networking: Unknown" in status page, and it shows
> "Unconfigured" for NIC in Network page.
> 
> Expected results:
> 1.After step3, it should show "Networking: Connected ovirtmgmt" in status
> page, and it shows "Managed" for NIC in Network page.

Huijuan, see your comment, the issue is getting worse.
I can imagine the impact is after RHEV-H register to RHEVM, then all related network TUI components, can not work well,  example: RHN, Logging, Remote Storage, these TUI display "Networking is not configured".

This reminds me of one bug 1088875(VERIFIED), see comment 5 of bug 1088875. Could you work with Chen to confirm whether new regression happen on RHEV-H 7.2 for beta 2 for bug 1088875?
Comment 9 Huijuan Zhao 2015-12-15 00:05:45 EST
Ying, I checked as comment 5 of bug 1088875, the workaround is effective:
After register rhevm, enter into "RHEV-M" page of rhevh setup menu again, then it shows "Managed" for NIC in Network page, It shows "Networking: Unknown ovirtmgmt" in status page.
Comment 10 Fabian Deutsch 2015-12-15 08:47:19 EST
This might be related to bug 1289028
Comment 11 Douglas Schilling Landgraf 2015-12-16 13:30:13 EST
*** Bug 1291608 has been marked as a duplicate of this bug. ***
Comment 12 Anatoly Litovsky 2016-01-03 06:10:38 EST
Please retest with latest release.
There was general network/registration problem before
If still happens please provide env.
Comment 14 Ryan Barry 2016-01-05 09:17:49 EST
(In reply to Anatoly Litovsky from comment #12)
> Please retest with latest release.
> There was general network/registration problem before
> If still happens please provide env.

This can be reproduced without too much work.

MANAGED_IFACES is set to "" in /etc/default/ovirt (until the RHEV-M/Engine page is selected again after registration)

ovirt.node.utils.network.BridgedNIC.is_configured needs to be smarter
Comment 16 cshao 2016-01-19 04:33:55 EST
Test version:
rhev-hypervisor7-7.2-20160113.0
ovirt-node-3.6.1-3.0.el7ev.noarch

Test steps:
1. TUI clean install rhevh
2. Login rhevh, setup network via dhcp
3. Register to rhevm3.6 
4. Add RHEV-H from RHEV-M side.

Test result:
1. Step 3 & 4, Networking show as: Connected ovirtmgmt" in status page. 

So the bug is fixed, change bug status to VERIFIED.
Comment 17 Ryan Barry 2016-02-17 20:31:27 EST
Note: for re-verification, please ensure that there's a VM running.

With the original patch merged, it appears that the 2nd patch fails if there are VMs running, since vnetX may be selected instead (which has no configuration). This is the cause of the very similar HE bug.
Comment 18 cshao 2016-02-18 04:35:12 EST
(In reply to Ryan Barry from comment #17)
> Note: for re-verification, please ensure that there's a VM running.
> 
> With the original patch merged, it appears that the 2nd patch fails if there
> are VMs running, since vnetX may be selected instead (which has no
> configuration). This is the cause of the very similar HE bug.

Thank you very much for your kind explanation :)
Comment 19 cshao 2016-02-24 00:51:49 EST
(In reply to Ryan Barry from comment #17)
> Note: for re-verification, please ensure that there's a VM running.
> 
> With the original patch merged, it appears that the 2nd patch fails if there
> are VMs running, since vnetX may be selected instead (which has no
> configuration). This is the cause of the very similar HE bug.

Re-test with latest build:
rhev-hypervisor7-7.2-20160222.0 
ovirt-node-3.6.1-7.0.el7ev.noarch

Test steps:
1. TUI clean install rhevh
2. Login rhevh, setup network via dhcp
3. Register to rhevm3.6 
4. Add RHEV-H from RHEV-M side.
5. Create VM.
6. Run vm
7. Shutdown vm.

Test result:
1. Step 1-4, Networking show as: Connected ovirtmgmt" in status page. 
2. Step 5-6. Networking show as: unknown ovirtmgmt" in status page. 
3. Step 7,   Networking show as: Connected ovirtmgmt" in status page. 

Hi Ryan,

Do we need re-open this bug?

Thanks!
Comment 20 cshao 2016-02-24 00:57 EST
Created attachment 1130037 [details]
vm-up-down
Comment 21 cshao 2016-02-24 00:58 EST
Created attachment 1130039 [details]
re-verify-log
Comment 22 Ryan Barry 2016-02-24 09:45:05 EST
(In reply to shaochen from comment #19)
> (In reply to Ryan Barry from comment #17)
> > Note: for re-verification, please ensure that there's a VM running.
> > 
> > With the original patch merged, it appears that the 2nd patch fails if there
> > are VMs running, since vnetX may be selected instead (which has no
> > configuration). This is the cause of the very similar HE bug.
> 
> Re-test with latest build:
> rhev-hypervisor7-7.2-20160222.0 
> ovirt-node-3.6.1-7.0.el7ev.noarch
> 
> Test steps:
> 1. TUI clean install rhevh
> 2. Login rhevh, setup network via dhcp
> 3. Register to rhevm3.6 
> 4. Add RHEV-H from RHEV-M side.
> 5. Create VM.
> 6. Run vm
> 7. Shutdown vm.
> 
> Test result:
> 1. Step 1-4, Networking show as: Connected ovirtmgmt" in status page. 
> 2. Step 5-6. Networking show as: unknown ovirtmgmt" in status page. 
> 3. Step 7,   Networking show as: Connected ovirtmgmt" in status page. 
> 
> Hi Ryan,
> 
> Do we need re-open this bug?
> 
> Thanks!

The fix will be the same as the other bug (HE shows unknown ovirtmgmt). Re-opening would result in one of the two being closed as a duplicate, which is ok, but just FYI. I'll leave it to QE to decide
Comment 24 errata-xmlrpc 2016-03-09 09:43:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.