Bug 120776 - ImageMagick should require autoconf >= 2.58 and automake >= 1.7 to avoid rebuilding problems
ImageMagick should require autoconf >= 2.58 and automake >= 1.7 to avoid rebu...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jonathan Blandford
Mike McLean
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-04-13 16:38 EDT by Robert Scheck
Modified: 2013-04-02 00:19 EDT (History)
1 user (show)

See Also:
Fixed In Version: 6.0.7.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 09:58:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Allows to build ImageMagick 5.5.7 with automake >= 1.6 and autoconf >= 2.57 (5.29 KB, patch)
2004-04-13 16:39 EDT, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2004-04-13 16:38:55 EDT
Description of problem:
If I use automake = 1.6 and autoconf = 2.57 to rebuild 
ImageMagick, the rebuilding dies at the end with not found files 
(the .so extension is missing at all "so"-files in %{_libdir}).

Version-Release number of selected component (if applicable):
ImageMagick-5.5.7.15-1.3

How reproducible & Steps to Reproduce:
Every time, see above.
  
Actual results:
I my eyes, there are two possibilities:

- require automake > 1.6 (that means automake17 or automake >= 1.8) 
  and autoconf > 2.57 (automake >= 2.58)

or

- require automake >= 1.6 and autoconf >= 2.57, but add the patch
  (it's a modified patch 7)

Expected results:
One of the both suggest solutions or a better one.
Comment 1 Robert Scheck 2004-04-13 16:39:43 EDT
Created attachment 99381 [details]
Allows to build ImageMagick 5.5.7 with automake >= 1.6 and autoconf >= 2.57
Comment 2 Robert Scheck 2004-08-23 12:40:45 EDT
Okay, now autoconf 2.59 and automake 1.9.1 are the current versions, 
so I think, the build requirements should be fixed instead of some 
patch merging, I'm expecting now:

BuildRequires: automake >= 1.7 autoconf >= 2.58 libtool >= 1.5

To avoid rebuilding problems, this build requirements should set in 
the spec file. Marking this bug with priority low and as EasyFix.
Comment 3 Tim Waugh 2004-10-11 09:58:44 EDT
Fix built as 6.0.7.1-4.

Note You need to log in before you can comment on or make changes to this bug.