Bug 120795 - gdk-pixbuf-csource not choosing lib64 version of libpixbufloader-png.so
gdk-pixbuf-csource not choosing lib64 version of libpixbufloader-png.so
Status: CLOSED DUPLICATE of bug 124478
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gtk2 (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-13 19:21 EDT by Joshua Jensen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2004-04-13 19:21:02 EDT
Description of problem:

when compiling programs that call

"gdk-pixbuf-csource --raw --build-list xfcalendar_icon xyz.png"

gdk-pixbuf-csource is not smart enough to use
/usr/lib64/gtk-2.0/2.2.0/loaders/libpixbufloader-png.so
instead of
/usr/lib/gtk-2.0/2.2.0/loaders/libpixbufloader-png.so

So now the 64 bit app requires the /usr/lib/ .so :-(



Version-Release number of selected component (if applicable):

install RHEL3 AMD64 and apply all updates
Comment 1 Matthias Clasen 2004-06-24 22:30:57 EDT
Another symptom of bug 124478

*** This bug has been marked as a duplicate of 124478 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:34 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.