Bug 124478 - x86_64 and i386 gtk2 packages step on each other
Summary: x86_64 and i386 gtk2 packages step on each other
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
: 120795 122147 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-26 21:07 UTC by Nicholas Miell
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-08 18:32:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicholas Miell 2004-05-26 21:07:43 UTC
The x86_64 and i386 gtk2 packages both contain the following files:

/usr/bin/gdk-pixbuf-query-loaders
/usr/bin/gtk-demo
/usr/bin/gtk-query-immodules-2.0
/usr/bin/testgtk
/usr/bin/testtext

Which ones you get depends on which was installed last. This is mostly
harmless, except that you need both versions of
gtk-query-immodules-2.0 in order to correctly generate the config files.

(If you're wondering why nobody noticed this before, it's because rpm
deliberately ignores the file conflict.)

Comment 1 Matthias Clasen 2004-06-25 02:30:17 UTC
*** Bug 122147 has been marked as a duplicate of this bug. ***

Comment 2 Matthias Clasen 2004-06-25 02:31:01 UTC
*** Bug 120795 has been marked as a duplicate of this bug. ***

Comment 4 Moritz Barsnick 2004-07-05 19:25:39 UTC
This seems to have been fixed in gtk2-2.4.1-3, but breaks packages 
which utilize e.g. gdk-pixbuf-query-loaders (librsvg2, libwmf). Okay, 
these packages should have a "Requires:", but perhaps gtk2 should 
also provide at least a symbolic link from 
/usr/bin/gdk-pixbuf-query-loaders to one of the two binaries?

Comment 5 Matthias Clasen 2004-07-08 17:45:42 UTC
Frank: see bug 127051 regarding multilib gtk2 on RHEL3

Comment 6 Matthias Clasen 2004-07-08 18:32:19 UTC
I have updated librsvg2 and libwmf to use the new
update-gdk-pixbuf-loaders script. The only thing that fails now if you
upgrade from pre-2.4.1-2 gtk2 and librsvg2 to the current is that the
postun hook of the old librsvg2 fails, since gdk-pixbuf-query-loaders
is already gone by the time it runs. This is not serious, and while
adding a gdk-pixbuf-query-loaders link would make the postun hook
succeed, it would also make it write the file to the wrong location,
which seems worse than letting postun fail.


Note You need to log in before you can comment on or make changes to this bug.