Bug 1208662 - SVG icon types set to Fixed (prevents scaling & messes up Gtk apps)
Summary: SVG icon types set to Fixed (prevents scaling & messes up Gtk apps)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-breeze
Version: 23
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1234376 1280122 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-02 19:36 UTC by Marcelo Ricardo Leitner
Modified: 2016-01-20 19:50 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-20 19:50:37 UTC
Type: Bug


Attachments (Terms of Use)
toolbar screenshot (11.83 KB, image/png)
2015-04-02 19:36 UTC, Marcelo Ricardo Leitner
no flags Details


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 355204 0 None None None Never

Description Marcelo Ricardo Leitner 2015-04-02 19:36:42 UTC
Created attachment 1010309 [details]
toolbar screenshot

Please check the attachment. The icon is just too big for this toolbar.
This is probably not a virt-manager issue but a template one, but I don't know which component I should report it against.

Comment 1 Marcelo Ricardo Leitner 2015-04-02 19:37:04 UTC
virt-manager-1.1.0-6.git8ca8490c.fc22.noarch btw

Comment 2 Cole Robinson 2015-04-03 14:07:36 UTC
Yeah I don't think that's virt-manager's fault, whatever icon theme you are using likely isn't providing a toolbar sized icon, gtk3 stopped scaling icons in F21 cycle.

What desktop environment are you using? Probably reassign the bug to their icon theme for further triage

Comment 3 Marcelo Ricardo Leitner 2015-04-06 13:38:31 UTC
Hi Cole. I'm using KDE, using the default icon theme, breeze. Moving then, but please fix it if I did it wrong. Thanks!

Comment 4 Marcelo Ricardo Leitner 2015-08-03 12:09:14 UTC
Folks, any news on this? It's really annoying to loose a big part of the screen to this.

Comment 5 Rex Dieter 2015-08-03 12:12:57 UTC
Naively, I'd still assume this to be an application issue... it should scale icons (if needed)

Comment 6 Cole Robinson 2015-08-09 22:13:31 UTC
virt-manager's UI is using glade, which AFAICT doesn't provide any way to enable scaling with gtk. Since IIRC gtk 3.10 it's been a bit extra work to say 'scale this icon to a non-default size'

Since it seems breeze-icon-theme ships only .svg icons compared to gtk's multiple sized .png images, maybe there's some gtk setting breeze can set in the theme to enable scaling by default? otherwise all gtk apps are going to need to deal with things like this...

Comment 7 Rex Dieter 2015-10-14 13:08:07 UTC
Poking gtk3 devs for advice here, about how gtk3 applications are expected to deal with (mostly) svg-only icon themes.

Comment 8 Cole Robinson 2015-11-11 01:37:45 UTC
*** Bug 1280122 has been marked as a duplicate of this bug. ***

Comment 9 Cole Robinson 2015-11-11 01:38:09 UTC
*** Bug 1234376 has been marked as a duplicate of this bug. ***

Comment 10 Cole Robinson 2015-11-11 01:39:03 UTC
One of those dupes is on f23 as well, so the issue is still present.

Anyone on the gnome side have a suggestion here?

Comment 11 Ian Pilcher 2015-11-11 17:26:01 UTC
I've been doing a bit of digging on this (yay strace!), and the problem does seem to be that Plasma themes provide 22x22 icons, but Gtk is looking for 24x24.  When it can't find a 24x24 icon, it moves up to the next size that is available -- 32x32 in the case of the shutdown icon, 64x64 in the case of the details icon.

Looking at http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html, I see a number of icon scaling/size-related keys that aren't present in /usr/share/icons/breeze/index.theme, e.g.:

 * Type=Scalable or Type=Threshold
 * MaxSize
 * MinSize
 * Threshold

And in fact, setting Type=Scalable, MinSize=23 and MaxSize=256 for the [status/64] directory causes the details icon to be scaled as one would expect.

So I'm going to say that this is an issue with the theme, rather than Gtk.

Comment 12 Rex Dieter 2015-11-11 17:49:09 UTC
Thanks for the excellent detective-work

Comment 13 Christian Stadelmann 2016-01-19 18:07:59 UTC
The upstream bug is marked as fixed, can you confirm that?

Comment 14 Ian Pilcher 2016-01-20 19:32:53 UTC
Upstream fixed it by adding 24x24 icons for the toolbar icons.

Comment 15 Rex Dieter 2016-01-20 19:50:37 UTC
Upstream fix was included in (at least) breeze-icon-theme-5.18.0 and newer (in stable updates now),
https://bodhi.fedoraproject.org/updates/FEDORA-2016-68b5eec2f4


Note You need to log in before you can comment on or make changes to this bug.