Bug 1208676 - No support for mounting volumes with volume files
Summary: No support for mounting volumes with volume files
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: scripts
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Ernestas Lukoševičius
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1297339
TreeView+ depends on / blocked
 
Reported: 2015-04-02 20:04 UTC by Ernestas Lukoševičius
Modified: 2016-01-11 09:39 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1297339 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:29:26 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ernestas Lukoševičius 2015-04-02 20:04:09 UTC
Description of problem:
Mounting a Gluster volume with a volume file was not possible due to a small bug in mount script:


Version-Release number of selected component (if applicable):
3.6.2 from ppa:gluster/glusterfs-3.6

How reproducible:
By installing latest GlusterFS 3.6 and trying to mount a volume using volume files.

Steps to Reproduce:
1. Install GlusterFS 3.6.
2. Try mounting volume using Gluster volume file.

Actual results:
root@puppet2:/home/supervisor# mount -t glusterfs /etc/gfs.vol /data2
ERROR: Server name/volume name unspecified cannot proceed further..
Please specify correct format
Usage:
man 8 /sbin/mount.glusterfs
root@puppet2:/home/supervisor# cat /etc/gfs.vol 
volume files1
  type protocol/client
  option transport-type tcp
  option remote-host files1.xx.com
  option remote-subvolume /data/puppet
end-volume

volume files2
  type protocol/client
  option transport-type tcp
  option remote-host files2.xx.com
  option remote-subvolume /data/puppet
end-volume

volume files3
  type protocol/client
  option transport-type tcp
  option remote-host files3.xx.com
  option remote-subvolume /data/puppet
end-volume
 
volume replicate
  type cluster/replicate
  subvolumes files1 files2 files3
end-volume
 
volume writebehind
  type performance/write-behind
  option window-size 2MB
  subvolumes replicate
end-volume
 
volume cache
  type performance/io-cache
  option cache-size 512MB
  subvolumes writebehind
end-volume
root@puppet2:/home/supervisor# 

Expected results:
root@puppet2:/home/supervisor# mount -t glusterfs /etc/gfs.vol /data2
root@puppet2:/home/supervisor#

Comment 1 Anand Avati 2015-04-02 20:17:49 UTC
REVIEW: http://review.gluster.org/10123 (mount.glusterfs: add support for mounting volumes with volume files) posted (#1) for review on master by Ernestas Lukoševičius (ernetas@gmail.com)

Comment 2 Anand Avati 2015-04-02 20:29:47 UTC
REVIEW: http://review.gluster.org/10126 (mount.glusterfs: mounting volumes with volume files) posted (#1) for review on master by Ernestas Lukoševičius (ernetas@gmail.com)

Comment 3 Anand Avati 2015-04-07 09:01:34 UTC
COMMIT: http://review.gluster.org/10126 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit a0e3634c6f0d349a3433cdbeabd93043f5f43e9d
Author: Ernestas Lukoševičius <ernetas@gmail.com>
Date:   Thu Apr 2 23:28:29 2015 +0300

    mount.glusterfs: mounting volumes with volume files
    
    This is a patch for bug-1208676.
    
    When using volume files to mount glusterfs volume,
    this line is always true:
    
    [ -z "$volume_id" -o -z "$server_ip" ] && {
    
    That's because at this place, $volume_id and $server_ip are
    set only and only if the $volfile_loc file was unreadable
    or undefined.
    
    Change-Id: Icdf7612ac13a8f953f2a2adaa426b6339cd9f8fd
    BUG: 1208676
    Signed-off-by: Ernestas Lukoševičius <ernetas@gmail.com>
    Reviewed-on: http://review.gluster.org/10126
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 4 Niels de Vos 2015-05-14 17:29:26 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:35:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:38:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:46:49 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Dragan Rakita 2016-01-11 08:34:38 UTC
Will this be resolved in 3.6? I have installed 3.6.7 last week on Centos. I had to comment lines  602-610 in /sbin/mount.glusterfs to be able to mount.
Am I making some other mistake?


Note You need to log in before you can comment on or make changes to this bug.