Bug 1297339 - No support for mounting volumes with volume files
No support for mounting volumes with volume files
Status: CLOSED NEXTRELEASE
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
3.6.8
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
: Triaged
Depends On: 1208676
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 04:39 EST by Niels de Vos
Modified: 2016-08-30 08:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1208676
Environment:
Last Closed: 2016-08-30 08:52:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels de Vos 2016-01-11 04:39:01 EST
+++ This bug was initially created as a clone of Bug #1208676 +++
+++                                                           +++
+++ Use this bug to provide a backport to release-3.6.        +++

Description of problem:
Mounting a Gluster volume with a volume file was not possible due to a small bug in mount script:


Version-Release number of selected component (if applicable):
3.6.2 from ppa:gluster/glusterfs-3.6

How reproducible:
By installing latest GlusterFS 3.6 and trying to mount a volume using volume files.

Steps to Reproduce:
1. Install GlusterFS 3.6.
2. Try mounting volume using Gluster volume file.

Actual results:
root@puppet2:/home/supervisor# mount -t glusterfs /etc/gfs.vol /data2
ERROR: Server name/volume name unspecified cannot proceed further..
Please specify correct format
Usage:
man 8 /sbin/mount.glusterfs
root@puppet2:/home/supervisor# cat /etc/gfs.vol 
volume files1
  type protocol/client
  option transport-type tcp
  option remote-host files1.xx.com
  option remote-subvolume /data/puppet
end-volume

volume files2
  type protocol/client
  option transport-type tcp
  option remote-host files2.xx.com
  option remote-subvolume /data/puppet
end-volume

volume files3
  type protocol/client
  option transport-type tcp
  option remote-host files3.xx.com
  option remote-subvolume /data/puppet
end-volume
 
volume replicate
  type cluster/replicate
  subvolumes files1 files2 files3
end-volume
 
volume writebehind
  type performance/write-behind
  option window-size 2MB
  subvolumes replicate
end-volume
 
volume cache
  type performance/io-cache
  option cache-size 512MB
  subvolumes writebehind
end-volume
root@puppet2:/home/supervisor# 

Expected results:
root@puppet2:/home/supervisor# mount -t glusterfs /etc/gfs.vol /data2
root@puppet2:/home/supervisor#

--- Additional comment from Anand Avati on 2015-04-02 22:17:49 CEST ---

REVIEW: http://review.gluster.org/10123 (mount.glusterfs: add support for mounting volumes with volume files) posted (#1) for review on master by Ernestas Lukoševičius (ernetas@gmail.com)

--- Additional comment from Anand Avati on 2015-04-02 22:29:47 CEST ---

REVIEW: http://review.gluster.org/10126 (mount.glusterfs: mounting volumes with volume files) posted (#1) for review on master by Ernestas Lukoševičius (ernetas@gmail.com)

--- Additional comment from Anand Avati on 2015-04-07 11:01:34 CEST ---

COMMIT: http://review.gluster.org/10126 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit a0e3634c6f0d349a3433cdbeabd93043f5f43e9d
Author: Ernestas Lukoševičius <ernetas@gmail.com>
Date:   Thu Apr 2 23:28:29 2015 +0300

    mount.glusterfs: mounting volumes with volume files
    
    This is a patch for bug-1208676.
    
    When using volume files to mount glusterfs volume,
    this line is always true:
    
    [ -z "$volume_id" -o -z "$server_ip" ] && {
    
    That's because at this place, $volume_id and $server_ip are
    set only and only if the $volfile_loc file was unreadable
    or undefined.
    
    Change-Id: Icdf7612ac13a8f953f2a2adaa426b6339cd9f8fd
    BUG: 1208676
    Signed-off-by: Ernestas Lukoševičius <ernetas@gmail.com>
    Reviewed-on: http://review.gluster.org/10126
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

--- Additional comment from Dragan Rakita on 2016-01-11 09:34:38 CET ---

Will this be resolved in 3.6? I have installed 3.6.7 last week on Centos. I had to comment lines  602-610 in /sbin/mount.glusterfs to be able to mount.
Am I making some other mistake?

Note You need to log in before you can comment on or make changes to this bug.