Bug 120873 - update to imap-2004a (+ rename -> imap-libs)
update to imap-2004a (+ rename -> imap-libs)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libc-client (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: FutureFeature
: 132928 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-14 15:15 EDT by Rex Dieter
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-22 12:45:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to include ability to build imap-server (7.02 KB, patch)
2004-04-14 15:34 EDT, Rex Dieter
no flags Details | Diff
specfile including ability to build/include imap server (8.02 KB, text/plain)
2004-04-14 15:36 EDT, Rex Dieter
no flags Details

  None (edit)
Description Rex Dieter 2004-04-14 15:15:50 EDT
Here's a patch as well as patched specfile the allows for the building
of the imap server portion, toggled via macro define:
%define libonly 1

As an aside, why name this pkg libc-client?  Wouldn't imap-libs (and
imap-devel) provide for a simpler/cleaner upgrade path?
Comment 1 Rex Dieter 2004-04-14 15:34:35 EDT
Created attachment 99422 [details]
patch to include ability to build imap-server
Comment 2 Rex Dieter 2004-04-14 15:36:20 EDT
Created attachment 99423 [details]
specfile including ability to build/include imap server
Comment 3 Mike A. Harris 2004-04-14 20:38:21 EDT
The package is named libc-client, because the UW imap server is
intentionally no longer shipped with the OS and not supported,
however there are other pieces of software present which currently
rely on the c-client library which ships with UW imap.  Since
the package is shipped solely to provide the c-client library to
these specific applications, it is named libc-client (which IMHO
is confusing as it sounds like a client for the C library, but then
the library's own name "c-client" is kindof silly anyway, so it's
at least consistently silly)  ;o)

Comment 4 Joe Orton 2004-04-16 11:50:44 EDT
And hence, WONTFIX, I'd say.  The UW imap server can easily be
packaged independently of the libc-client package, if really you want
to do that.
Comment 5 Rex Dieter 2004-04-16 12:06:20 EDT
I know why the name libc-client was chosen, I just think it's a bad 
choice,  
1.  It's confusing (libc-c?), imap-libs is more descriptive, and is 
at least based on the upstream tarball (that's admittedly a 
pet-peave of mine, packages should preserve their upstream 
heritage). 
 
2.  keeping/using imap, imap-libs, imap-devel provides 
simpler/cleanup upgrade path, from previous imap, imap-devel 
releases. 
 
and (IMHO) 
3.  Purposely omitting at least the *ability* to build the imap 
server portion is lame, especially considering I did the hard work 
for you, providing a working patch/specfile. 
Comment 6 Tim Powers 2004-04-16 12:22:37 EDT
Rex: Why can't you do this as an addition "extras" or something instead it having to be in 
the OS proper?
Comment 7 Rex Dieter 2004-04-16 12:27:02 EDT
Sure, it (the server build option) can be in "extras", but it's a
shame to have essentially the same pkg in 2 places.

At this point, my biggest beef is naming.
Comment 8 Rex Dieter 2004-07-20 11:26:20 EDT
FYI, "extras" submission:
http://bugzilla.fedora.us/show_bug.cgi?id=1838

including libc-client -> imap-libs rename
Comment 9 Warren Togami 2004-07-22 21:10:48 EDT
Certain Red Hat developers have taken an active interest in
discouraging the use of these UW software because they are slow,
insecure and buggy (race conditions, severe code quality concerns). 
They also do not appreciate the attitude of a certain upstream
developer.  Note that I personally don't care at all about this package.

So why not remove it entirely from FC3, and let the community maintain
it however they wish in Extras?
Comment 10 Rex Dieter 2004-07-22 22:26:29 EDT
AFAIK, the only reason this package (libc-client) is currently in 
Core is for php-imap.  So, if this goes, so does php-imap as well.
Comment 11 Warren Togami 2004-09-20 03:02:40 EDT
*** Bug 132928 has been marked as a duplicate of this bug. ***
Comment 12 Oskari Saarenmaa 2004-09-20 08:46:44 EDT
http://rpms.www.sumu.org/php-imap-4.3.8.2002e-1.i386.rpm (fc1)
http://rpms.www.sumu.org/php-imap-4.3.8.2002e-1.src.rpm

standalone php-imap rpm that statically links c-client.a and removes
need for libc-client packages
Comment 13 Rex Dieter 2005-06-22 12:45:26 EDT
Ah, heck, let's just get this stuffed into Fedora Extras.  Yes, I'm the
sucker^?^?^? err... volunteer to do it.

Note You need to log in before you can comment on or make changes to this bug.