Bug 1209008 - [abrt] gnome-shell: meta_frame_left_click_event(): gnome-shell killed by SIGABRT
[abrt] gnome-shell: meta_frame_left_click_event(): gnome-shell killed by SIGABRT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Florian Müllner
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:82bec53a82e7cc63b4eb52d9baf...
:
: 1227391 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-05 01:36 EDT by iliketurtlesbro
Modified: 2015-09-17 08:20 EDT (History)
37 users (show)

See Also:
Fixed In Version: mutter-3.16.3-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-21 04:11:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (33.31 KB, text/plain)
2015-04-05 01:36 EDT, iliketurtlesbro
no flags Details
File: cgroup (190 bytes, text/plain)
2015-04-05 01:36 EDT, iliketurtlesbro
no flags Details
File: core_backtrace (17.34 KB, text/plain)
2015-04-05 01:36 EDT, iliketurtlesbro
no flags Details
File: dso_list (24.56 KB, text/plain)
2015-04-05 01:36 EDT, iliketurtlesbro
no flags Details
File: environ (813 bytes, text/plain)
2015-04-05 01:36 EDT, iliketurtlesbro
no flags Details
File: limits (1.29 KB, text/plain)
2015-04-05 01:36 EDT, iliketurtlesbro
no flags Details
File: maps (111.93 KB, text/plain)
2015-04-05 01:36 EDT, iliketurtlesbro
no flags Details
File: mountinfo (3.50 KB, text/plain)
2015-04-05 01:36 EDT, iliketurtlesbro
no flags Details
File: namespaces (85 bytes, text/plain)
2015-04-05 01:37 EDT, iliketurtlesbro
no flags Details
File: open_fds (5.49 KB, text/plain)
2015-04-05 01:37 EDT, iliketurtlesbro
no flags Details
File: proc_pid_status (996 bytes, text/plain)
2015-04-05 01:37 EDT, iliketurtlesbro
no flags Details
File: var_log_messages (646 bytes, text/plain)
2015-04-05 01:37 EDT, iliketurtlesbro
no flags Details

  None (edit)
Description iliketurtlesbro 2015-04-05 01:36:51 EDT
Version-Release number of selected component:
gnome-shell-3.16.0-1.fc22

Additional info:
reporter:       libreport-2.5.0
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell --wayland --display-server
crash_function: meta_frame_left_click_event
executable:     /usr/bin/gnome-shell
global_pid:     1670
kernel:         4.0.0-0.rc5.git4.1.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 meta_frame_left_click_event at ui/frames.c:1057
 #5 handle_button_press_event at ui/frames.c:1107
 #6 meta_ui_frame_handle_event at ui/frames.c:1580
 #7 meta_window_handle_ungrabbed_event at core/window.c:7771
 #8 meta_display_handle_event at core/events.c:268
 #9 event_callback at core/events.c:333
 #10 _clutter_event_process_filters at clutter-event.c:1768
 #11 emit_pointer_event at clutter-main.c:2022
 #12 _clutter_process_event_details at clutter-main.c:2377
 #13 _clutter_process_event at clutter-main.c:2537
Comment 1 iliketurtlesbro 2015-04-05 01:36:53 EDT
Created attachment 1011039 [details]
File: backtrace
Comment 2 iliketurtlesbro 2015-04-05 01:36:54 EDT
Created attachment 1011040 [details]
File: cgroup
Comment 3 iliketurtlesbro 2015-04-05 01:36:55 EDT
Created attachment 1011041 [details]
File: core_backtrace
Comment 4 iliketurtlesbro 2015-04-05 01:36:56 EDT
Created attachment 1011042 [details]
File: dso_list
Comment 5 iliketurtlesbro 2015-04-05 01:36:56 EDT
Created attachment 1011043 [details]
File: environ
Comment 6 iliketurtlesbro 2015-04-05 01:36:57 EDT
Created attachment 1011044 [details]
File: limits
Comment 7 iliketurtlesbro 2015-04-05 01:36:58 EDT
Created attachment 1011045 [details]
File: maps
Comment 8 iliketurtlesbro 2015-04-05 01:36:59 EDT
Created attachment 1011046 [details]
File: mountinfo
Comment 9 iliketurtlesbro 2015-04-05 01:37:00 EDT
Created attachment 1011047 [details]
File: namespaces
Comment 10 iliketurtlesbro 2015-04-05 01:37:00 EDT
Created attachment 1011048 [details]
File: open_fds
Comment 11 iliketurtlesbro 2015-04-05 01:37:01 EDT
Created attachment 1011049 [details]
File: proc_pid_status
Comment 12 iliketurtlesbro 2015-04-05 01:37:02 EDT
Created attachment 1011050 [details]
File: var_log_messages
Comment 13 Adam Williamson 2015-04-08 16:35:34 EDT
I hit this when I dragged a virt-manager window from one monitor to another.
Comment 14 Andrew Cook 2015-06-06 05:15:08 EDT
this happens when get_control returns META_FRAME_CONTROL_NONE

Fairly sure it's reproducible, but don't know exactly how; it's some weird specific series of inputs.
Comment 15 Samuel Irlapati 2015-06-08 13:34:58 EDT
For me this happens when i do copy paste. If i highlight some text in a terminal or gvim window using the mouse and then switch to a different window or even a different desktop, it crashes.
Comment 16 Samuel Irlapati 2015-06-08 14:21:44 EDT
This also happens when i change desktops quickly after typing in a thunderbird window.
Comment 17 Andrew Cook 2015-06-08 21:41:24 EDT
Reliably?
Comment 18 Samuel Irlapati 2015-06-08 23:52:25 EDT
Sorry but not reliably. I want to give as many scenarios as possible so that the cause can be narrowed down. The most reliable case for me is when i highlight something in a terminal or gvim window and switch to another window quickly.
Comment 19 Hin-Tak Leung 2015-06-09 16:05:41 EDT
Google'ing the first interesting frame of a backtrace got me here. For some reason abrt-cli report doesn't seem to work lately (just takes forever). I was just using the computer like I normally do, clicking/switching firefox windows and stuff, then suddenly gnom-shell restarted. This is non-wayland, and also under a classic session. I have had the same backtrace onece of twice before, but as I said, abrt-cli report took forever so I gave up then. 

# abrt-cli list
id 882c97e04008fddd0b1c1f7542ec8eb3157ebaa4
reason:         gnome-shell killed by SIGABRT
time:           Tue 09 Jun 2015 20:05:59 BST
cmdline:        /usr/bin/gnome-shell
package:        gnome-shell-3.16.2-1.fc22
uid:            1000 (Hin-Tak)
count:          1
Directory:      /var/tmp/abrt/ccpp-2015-06-09-20:05:59-2069

(gdb) bt
#0  0x00000034e2434a98 in raise () at /lib64/libc.so.6
#1  0x00000034e243672a in abort () at /lib64/libc.so.6
#2  0x00000034e4c702a5 in g_assertion_message () at /lib64/libglib-2.0.so.0
#3  0x00000034e4c7033a in g_assertion_message_expr () at /lib64/libglib-2.0.so.0
#4  0x0000003b37e8aa02 in meta_frame_left_click_event () at /lib64/libmutter.so.0
#5  0x0000003b37e87776 in meta_window_handle_ungrabbed_event () at /lib64/libmutter.so.0
#6  0x0000003b37e6a896 in event_callback () at /lib64/libmutter.so.0
#7  0x0000003b3868149d in _clutter_event_process_filters () at /lib64/libclutter-1.0.so.0
#8  0x0000003b386942cb in _clutter_process_event () at /lib64/libclutter-1.0.so.0
#9  0x0000003b386ae309 in _clutter_stage_process_queued_events () at /lib64/libclutter-1.0.so.0
#10 0x0000003b38696539 in clutter_clock_dispatch () at /lib64/libclutter-1.0.so.0
#11 0x00000034e4c49a8a in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#12 0x00000034e4c49e20 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#13 0x00000034e4c4a142 in g_main_loop_run () at /lib64/libglib-2.0.so.0
#14 0x0000003b37e71356 in meta_run () at /lib64/libmutter.so.0
#15 0x00000000004023fd in main ()
(gdb) q
Comment 20 Florian Müllner 2015-06-12 10:55:55 EDT
*** Bug 1227391 has been marked as a duplicate of this bug. ***
Comment 21 udo 2015-06-12 10:59:15 EDT
I got sent here.
I can do the gnome-shell crash when using clearlooks-phenix theme.
This theme was adapted for Gnome 3.14.
And it makes gnome-shell crash when I click at the right hand edge of the creen in firefox. Also at the left hand side and bottom but I did less testing there.
Default theme does not show this behaviour. See https://bugzilla.redhat.com/show_bug.cgi?id=1227391 to confirm this is the same issue.
Comment 22 udo 2015-06-12 11:00:04 EDT
My way of reproducing this issue is very reliable.
Comment 23 rh 2015-06-21 17:04:05 EDT
I have experienced this issue when using GfxTablet, together with https://bugzilla.redhat.com/show_bug.cgi?id=1215320

Is there anything how I can help to identify and fix it?
Comment 24 udo 2015-06-23 11:02:09 EDT
(In reply to udo from comment #22)
> My way of reproducing this issue is very reliable.

See https://bugzilla.redhat.com/show_bug.cgi?id=1230326 for details.
Comment 25 Andrew Cook 2015-06-26 23:11:53 EDT
gnome-shell sometimes doesn't restart automatically, leaving you with a practically unusable session
Comment 26 Adam Williamson 2015-06-26 23:24:38 EDT
FWIW when that happens, go to a tty (ctrl-alt-f2), log in, and run 'DISPLAY=:0 gnome-shell --replace &', and it should start the Shell up again.

obviously that's just a workaround, but handy to know if it tends to happen to you.
Comment 27 Andrew Cook 2015-06-26 23:27:35 EDT
Usually have a terminal open I can run --replace from, but i don't think it's fair to expect an average user to do that.

Has this been reported upstream yet?
Comment 28 Adam Williamson 2015-06-26 23:30:05 EDT
Don't know offhand, but more or less the same people should see it in both places. Can't hurt to have an upstream report if it hasn't happened yet, though.
Comment 29 mchalupa 2015-07-03 05:26:13 EDT
Upstream bug:
https://bugzilla.gnome.org/show_bug.cgi?id=751884
Comment 30 udo 2015-07-03 06:22:38 EDT
(In reply to mchalupa from comment #29)
> Upstream bug:
> https://bugzilla.gnome.org/show_bug.cgi?id=751884

Thanks!
So we have a patch.
Please verify and push RPMs please.
Comment 31 udo 2015-07-03 06:32:13 EDT
Also see https://bugzilla.redhat.com/show_bug.cgi?id=1230326 as this clearlook-phenix is not intended from this Gnome release....
Comment 32 Fedora Update System 2015-07-14 17:45:24 EDT
mutter-3.16.3-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/mutter-3.16.3-2.fc22
Comment 33 Fedora Update System 2015-07-17 22:05:42 EDT
Package mutter-3.16.3-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mutter-3.16.3-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-11751/mutter-3.16.3-2.fc22
then log in and leave karma (feedback).
Comment 34 Fedora Update System 2015-07-21 04:11:23 EDT
mutter-3.16.3-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.