Bug 1227391 - scrolling/clicking in firefox/thunderbird can CRASH gnome-shell when Clearlooks-Phenix theme is in use (oh no something has gone wrong)
Summary: scrolling/clicking in firefox/thunderbird can CRASH gnome-shell when Clearloo...
Keywords:
Status: CLOSED DUPLICATE of bug 1209008
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-02 14:35 UTC by udo
Modified: 2015-06-12 14:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-12 14:55:55 UTC


Attachments (Terms of Use)
backtrace (8.36 KB, text/plain)
2015-06-03 13:15 UTC, udo
no flags Details
backtrace (8.35 KB, text/plain)
2015-06-03 13:16 UTC, udo
no flags Details
coredumps of gnome-shell found in messages file (221.58 KB, text/plain)
2015-06-04 15:44 UTC, udo
no flags Details

Description udo 2015-06-02 14:35:53 UTC
Description of problem:
The Gnome session crashes sometimes when scrolling a page in firefox by dragging the slider. the fg/bgorder of windows is disturbed and sometimes the Gnome session is ended

Version-Release number of selected component (if applicable):
gnome-shell-3.16.2-1.fc22.x86_64

How reproducible:
See description.


Actual results:
Not so stable desktop experience

Expected results:
Stable desktop experience

Additional info:
How/where can I find logs of what happens on the hood when this issue occurs?

Comment 1 udo 2015-06-02 14:37:54 UTC
This problem was not occurring on Fedora 20.

Comment 2 udo 2015-06-02 16:02:44 UTC
It appears that the far right of the screen has sensitive pixels in some way.
Clicking and.or scrolling makes weird things happen like described above.

Comment 3 udo 2015-06-02 16:04:20 UTC
Clicking on the far right of the scrollbar on the right appears to trigger the issue.

Comment 4 udo 2015-06-03 13:15:47 UTC
Created attachment 1034315 [details]
backtrace

backtrace etc using https://wiki.gnome.org/Projects/GnomeShell/Debugging

Comment 5 udo 2015-06-03 13:16:23 UTC
Created attachment 1034316 [details]
backtrace

backtrace using https://wiki.gnome.org/Projects/GnomeShell/Debugging

Comment 6 udo 2015-06-03 13:40:25 UTC
FWIW: screen is 1680*1050 
Could this be an 'off' size that influences this problem?

Comment 7 udo 2015-06-04 14:18:24 UTC
Also the left edge of the screen has this issue.
This makes gnome shell the most unstable part of the system at this time.

Comment 8 udo 2015-06-04 15:22:19 UTC
core dump from dmesg (was not so nicely formatted...)

systemd-coredump: Process 26705 (gnome-shell) of user 500 dumped core.
#012#012Stack trace of thread 26705:
#012#0  0x00007fd23bd64a98 raise (libc.so.6)
#012#1  0x00007fd23bd6672a abort (libc.so.6)
#012#2  0x00007fd23d9782a5 g_assertion_message (libglib-2.0.so.0)
#012#3  0x00007fd23d97833a g_assertion_message_expr (libglib-2.0.so.0)
#012#4  0x00007fd241502a02 meta_frame_left_click_event (libmutter.so.0)
#012#5  0x00007fd2414ff776 meta_window_handle_ungrabbed_event (libmutter.so.0)
#012#6  0x00007fd2414e2896 event_callback (libmutter.so.0)
#012#7  0x00007fd2408a949d _clutter_event_process_filters (libclutter-1.0.so.0)
#012#8  0x00007fd2408bc2cb _clutter_process_event (libclutter-1.0.so.0)
#012#9  0x00007fd2408d6309 _clutter_stage_process_queued_events (libclutter-1.0.so.0)
#012#10 0x00007fd2408be539 clutter_clock_dispatch (libclutter-1.0.so.0)
#012#11 0x00007fd23d951a8a g_main_context_dispatch (libglib-2.0.so.0)
#012#12 0x00007fd23d951e20 g_main_context_iterate.isra.29 (libglib-2.0.so.0)
#012#13 0x00007fd23d952142 g_main_loop_run (libglib-2.0.so.0)
#012#14 0x00007fd2414e9356 meta_run (libmutter.so.0)
#012#15 0x00000000004023fd main (gnome-shell)
#012#16 0x00007fd23bd50790 __libc_start_main (libc.so.6)
#012#17 0x0000000000402509 _start (gnome-shell)
#012#012Stack trace of thread 26719:
#012#0  0x00007fd23be2666d poll (libc.so.6)
#012#1  0x00007fd23d951dbc g_main_context_iterate.isra.29 (libglib-2.0.so.0)
#012#2  0x00007fd23d951ecc g_main_context_iteration (libglib-2.0.so.0)
#012#3  0x00007fd23d951f09 glib_worker_main (libglib-2.0.so.0)
#012#4  0x00007fd23d9790a5 g_thread_proxy (libglib-2.0.so.0)
#012#5  0x00007fd23c0f7555 start_thread (libpthread.so.0)
#012#6  0x00007fd23be31f3d __clone (libc.so.6)
#012#012Stack trace of thread 26735:
#012#0  0x00007fd23c0fc530 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#012#1  0x00007fd228f462aa cnd_wait (r600_dri.so)
#012#2  0x00007fd228f45b27 impl_thrd_routine (r600_dri.so)
#012#3  0x00007fd23c0f7555 start_thread (libpthread.so.0)
#012#4  0x00007fd23be31f3d __clone (libc.so.6)
#012#012Stack trace of thread 26743:
#012#0  0x00007fd23c0fc530 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#012#1  0x00007fd2399eb440 PR_WaitCondVar (libnspr4.so)
#012#2  0x00007fd244825bfe _ZN2js22SourceCompressorThread16compressorThreadEPv (libmozjs-24.so)
#012#3  0x00007fd2399f0cab _pt_root (libnspr4.so)
#012#4  0x00007fd23c0f7555 start_thread (libpthread.so.0)
#012#5  0x00007fd23be31f3d __clone (libc.so.6)
#012#012Stack trace of thread 26736:
#012#0  0x00007fd23be2666d poll (libc.so.6)
#012#1  0x00007fd23d951dbc g_main_context_iterate.isra.29 (libglib-2.0.so.0)
#012#2  0x00007fd23d952142 g_main_loop_run (libglib-2.0.so.0)
#012#3  0x00007fd23ee0f696 gdbus_shared_thread_func (libgio-2.0.so.0)
#012#4  0x00007fd23d9790a5 g_thread_proxy (libglib-2.0.so.0)
#012#5  0x00007fd23c0f7555 start_thread (libpthread.so.0)
#012#6  0x00007fd23be31f3d __clone (libc.so.6)
#012#012Stack trace of thread 26742:
#012#0  0x00007fd23c0fc530 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#012#1  0x00007fd2399eb440 PR_WaitCondVar (libnspr4.so)
#012#2  0x00007fd2447b0636 _ZN2js14GCHelperThread10threadLoopEv (libmozjs-24.so)
#012#3  0x00007fd2399f0cab _pt_root (libnspr4.so)
#012#4  0x00007fd23c0f7555 start_thread (libpthread.so.0)
#012#5  0x00007fd23be31f3d __clone (libc.so.6)
#012#012Stack trace of thread 26738:
#012#0  0x00007fd23be2666d poll (libc.so.6)
#012#1  0x00007fd23d951dbc g_main_context_iterate.isra.29 (libglib-2.0.so.0)
#012#2  0x00007fd23d951ecc g_main_context_iteration (libglib-2.0.so.0)
#012#3  0x00007fd2206572ad dconf_gdbus_worker_thread (libdconfsettings.so
)#012#4  0x00007fd23d9790a5 g_thread_proxy (libglib-2.0.so.0)#012#5  0x00007fd23c0f7555 start_thread (libpthread.so.0)#012#6  0x00007fd23be31f3d __clone (libc.so.6)#012#012Stack trace of thread 26741:#012#0  0x00007fd23be2666d poll (libc.so.6)#012#1  0x00007fd2457d36d1 poll_func (libpulse.so.0)#012#2  0x00007fd2457c4dd1 pa_mainloop_poll (libpulse.so.0)#012#3  0x00007fd2457c546e pa_mainloop_iterate (libpulse.so.0)#012#4  0x00007fd2457c5520 pa_mainloop_run (libpulse.so.0)#012#5  0x00007fd2457d3666 thread (libpulse.so.0)#012#6  0x00007fd23bb02708 internal_thread_func (libpulsecommon-6.0.so)#012#7  0x00007fd23c0f7555 start_thread (libpthread.so.0)#012#8  0x00007fd23be31f3d __clone (libc.so.6)

Who designs a dump like this?
Also gedit cannot cope with these long lines while beautifying the layout a bit: the scrollbar at the bottom obscures the line I need to edit.
Do I notice a downward spiralling trend?

Comment 9 udo 2015-06-04 15:41:30 UTC
Older dump:

systemd-coredump: Process 13521 (gnome-shell) of user 500 dumped core.#012#012Stack trace of thread 13521:#012#0  0x00007f93c8e94a98 raise (libc.so.6)#012#1  0x00007f93c8e9672a abort (libc.so.6)#012#2  0x00007f93caaa82a5 g_assertion_message (libglib-2.0.so.0)#012#3  0x00007f93caaa833a g_assertion_message_expr (libglib-2.0.so.0)#012#4  0x00007f93ce632a02 meta_frame_left_click_event (libmutter.so.0)#012#5  0x00007f93ce62f776 meta_window_handle_ungrabbed_event (libmutter.so.0)#012#6  0x00007f93ce612896 event_callback (libmutter.so.0)#012#7  0x00007f93cd9d949d _clutter_event_process_filters (libclutter-1.0.so.0)#012#8  0x00007f93cd9ec2cb _clutter_process_event (libclutter-1.0.so.0)#012#9  0x00007f93cda06309 _clutter_stage_process_queued_events (libclutter-1.0.so.0)#012#10 0x00007f93cd9ee539 clutter_clock_dispatch (libclutter-1.0.so.0)#012#11 0x00007f93caa81a8a g_main_context_dispatch (libglib-2.0.so.0)#012#12 0x00007f93caa81e20 g_main_context_iterate.isra.29 (libglib-2.0.so.0)#012#13 0x00007f93caa82142 g_main_loop_run (libglib-2.0.so.0)#012#14 0x00007f93ce619356 meta_run (libmutter.so.0)#012#15 0x00000000004023fd main (gnome-shell)#012#16 0x00007f93c8e80790 __libc_start_main (libc.so.6)#012#17 0x0000000000402509 _start (gnome-shell)#012#012Stack trace of thread 13531:#012#0  0x00007f93c8f5666d poll (libc.so.6)#012#1  0x00007f93caa81dbc g_main_context_iterate.isra.29 (libglib-2.0.so.0)#012#2  0x00007f93caa82142 g_main_loop_run (libglib-2.0.so.0)#012#3  0x00007f93cbf3f696 gdbus_shared_thread_func (libgio-2.0.so.0)#012#4  0x00007f93caaa90a5 g_thread_proxy (libglib-2.0.so.0)#012#5  0x00007f93c9227555 start_thread (libpthread.so.0)#012#6  0x00007f93c8f61f3d __clone (libc.so.6)#012#012Stack trace of thread 13533:#012#0  0x00007f93c8f5666d poll (libc.so.6)#012#1  0x00007f93caa81dbc g_main_context_iterate.isra.29 (libglib-2.0.so.0)#012#2  0x00007f93caa81ecc g_main_context_iteration (libglib-2.0.so.0)#012#3  0x00007f93ad85f2ad dconf_gdbus_worker_thread (libdconfsettings.so)#012#4  0x00007f93caaa90a5 g_thread_proxy (libglib-2.0.so.0)#012#5  0x00007f93c9227555 start_thread (libpthread.so.0)#012#6  0x00007f93c8f61f3d __clone (libc.so.6)#012#012Stack trace of thread 13528:#012#0  0x00007f93c922c530 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)#012#1  0x00007f93b60762aa cnd_wait (r600_dri.so)#012#2  0x00007f93b6075b27 impl_thrd_routine (r600_dri.so)#012#3  0x00007f93c9227555 start_thread (libpthread.so.0)#012#4  0x00007f93c8f61f3d __clone (libc.so.6)#012#012Stack trace of thread 13535:#012#0  0x00007f93c922c530 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)#012#1  0x00007f93c6b1b440 PR_WaitCondVar (libnspr4.so)#012#2  0x00007f93d18e0636 _ZN2js14GCHelperThread10threadLoopEv (libmozjs-24.so)#012#3  0x00007f93c6b20cab _pt_root (libnspr4.so)#012#4  0x00007f93c9227555 start_thread (libpthread.so.0)#012#5  0x00007f93c8f61f3d __clone (libc.so.6)#012#012Stack trace of thread 13534:#012#0  0x00007f93c8f5666d poll (libc.so.6)#012#1  0x00007f93d29036d1 poll_func (libpulse.so.0)#012#2  0x00007f93d28f4dd1 pa_mainloop_poll (libpulse.so.0)#012#3  0x00007f93d28f546e pa_mainloop_iterate (libpulse.so.0)#012#4  0x00007f93d28f5520 pa_mainloop_run (libpulse.so.0)#012#5  0x00007f93d2903666 thread (libpulse.so.0)#012#6  0x00007f93c8c32708 internal_thread_func (libpulsecommon-6.0.so)#012#7  0x00007f93c9227555 start_thread (libpthread.so.0)#012#8  0x00007f93c8f61f3d __clone (libc.so.6)#012#012Stack trace of thread 13536:#012#0  0x00007f93c922c530 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)#012#1  0x00007f93c6b1b440 PR_WaitCondVar (libnspr4.so)#012#2  0x00007f93d1955bfe _ZN2js22SourceCompressorThread16compressorThreadEPv (libmozjs-24.so)#012#3  0x00007f93c6b20cab _pt_root (libnspr4.so)#012#4  0x00007f93c9227555 start_thread (libpthread.so.0)#012#5  0x00007f93c8f61f3d __clone (libc.so.6)#012#012Stack trace of thread 13523:#012#0  0x00007f93c8f5666d poll (libc.so.6)#012#1  0x00007f93caa81dbc g_main_context_iterate.isra.29 (libglib-2.0.so.0)#012#2  0x00007f93caa81ecc g_main_context_iteration (libglib-2.0.so.0)#012#3  0x00007f93caa81f09 glib_worker_main (libglib-2.0.so.0)#012#4  0x00007f93caaa90a5 g_thread_proxy (libglib-2.0.so.0)#012#5  0x00007f93c9227555 start_thread (libpthread.so.0)#012#6  0x00007f93c8f61f3d __clone (libc.so.6)

Comment 10 udo 2015-06-04 15:44:53 UTC
Created attachment 1034786 [details]
coredumps of gnome-shell found in messages file

Comment 11 udo 2015-06-06 13:43:57 UTC
When this issue happens, and it happens a lot, gnome-shell or whatever forgets about the enabled extensions, windows positions shift (if we don't have the complete shutdown as in 'oh no something has gone wrong') a bit, etc.
Please fix!

Comment 12 udo 2015-06-07 08:47:47 UTC
The issue does not happen when the adwaita theme is selected.
So something is not handling the Clearlooks-Phenix theme very well.

Comment 13 udo 2015-06-07 08:51:11 UTC
Or perhaps clearlooks-phenix-gtk3-theme-6.0.3-1.fc22.noarch is indeed not 100% gnome 3.16 compatible.

Comment 14 Florian Müllner 2015-06-12 14:55:55 UTC

*** This bug has been marked as a duplicate of bug 1209008 ***


Note You need to log in before you can comment on or make changes to this bug.