Bug 1209104 - Do not let an inode evict during split-brain resolution process.
Summary: Do not let an inode evict during split-brain resolution process.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anuradha
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1219388
TreeView+ depends on / blocked
 
Reported: 2015-04-06 06:49 UTC by Anuradha
Modified: 2016-09-20 02:01 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1219388 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:47:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Anuradha 2015-04-06 06:49:25 UTC
Description of problem:

During split-brain resolution from mount, an inode may get evicted from table even before inspection/resolution is complete, leading to failure. This should not happen.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-04-06 10:39:36 UTC
REVIEW: http://review.gluster.org/10134 (cluster/afr : Prevent inode-evict during split-brain resolution) posted (#1) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 2 Anand Avati 2015-04-06 13:25:16 UTC
REVIEW: http://review.gluster.org/10134 (cluster/afr : Prevent inode-evict during split-brain resolution) posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 3 Anand Avati 2015-04-16 10:54:22 UTC
REVIEW: http://review.gluster.org/10134 (cluster/afr : Prevent inode-evict during split-brain resolution) posted (#3) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 4 Anand Avati 2015-04-16 11:00:04 UTC
REVIEW: http://review.gluster.org/10134 (cluster/afr : Prevent inode-evict during split-brain resolution) posted (#4) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 5 Anand Avati 2015-04-17 12:33:20 UTC
REVIEW: http://review.gluster.org/10134 (cluster/afr : Prevent inode-evict during split-brain resolution) posted (#6) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 6 Anand Avati 2015-04-17 12:40:42 UTC
REVIEW: http://review.gluster.org/10134 (cluster/afr : Prevent inode-evict during split-brain resolution) posted (#7) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 7 Anand Avati 2015-04-17 13:08:14 UTC
REVIEW: http://review.gluster.org/10134 (cluster/afr : Prevent inode-evict during split-brain resolution) posted (#8) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 8 Anand Avati 2015-04-27 10:59:53 UTC
REVIEW: http://review.gluster.org/10134 (cluster/afr : Prevent inode-evict during split-brain resolution) posted (#9) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 9 Anand Avati 2015-04-27 11:15:00 UTC
REVIEW: http://review.gluster.org/10134 (cluster/afr : Prevent inode-evict during split-brain resolution) posted (#10) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 10 Anand Avati 2015-04-30 10:05:58 UTC
REVIEW: http://review.gluster.org/10134 (cluster/afr : Prevent inode-evict during split-brain resolution) posted (#11) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 11 Anand Avati 2015-05-06 05:57:39 UTC
REVIEW: http://review.gluster.org/10134 (cluster/afr : Prevent inode-evict during split-brain resolution) posted (#12) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 12 Nagaprasad Sathyanarayana 2015-10-25 14:53:21 UTC
Fix for this bug is already made in a GlusterFS release. The cloned BZ has details of the fix and the release. Hence closing this mainline BZ.

Comment 13 Nagaprasad Sathyanarayana 2015-10-25 15:11:44 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 14 Niels de Vos 2016-06-16 12:47:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.